summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-11-21 11:56:41 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-11-21 11:56:41 +0000
commit81cf66be651d1b7c2a796f2ba9d8eec3b779ee05 (patch)
treefd19bc1d3fb4c77ffc645dd406a9cdb7dac8fef8
parentbug #149660. pending removal of package. (diff)
downloadgentoo-2-81cf66be651d1b7c2a796f2ba9d8eec3b779ee05.tar.gz
gentoo-2-81cf66be651d1b7c2a796f2ba9d8eec3b779ee05.tar.bz2
gentoo-2-81cf66be651d1b7c2a796f2ba9d8eec3b779ee05.zip
Readd kde support on popular demand. Drizztbsd and others say that it is working
(Portage version: 2.1.2_rc2-r1)
-rw-r--r--net-www/gnash/ChangeLog7
-rw-r--r--net-www/gnash/gnash-0.7.2.ebuild11
-rw-r--r--net-www/gnash/gnash-0.7.2_p20099999.ebuild11
3 files changed, 18 insertions, 11 deletions
diff --git a/net-www/gnash/ChangeLog b/net-www/gnash/ChangeLog
index ea28086c16c1..347ce77ebee3 100644
--- a/net-www/gnash/ChangeLog
+++ b/net-www/gnash/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-www/gnash
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/gnash/ChangeLog,v 1.29 2006/11/18 20:58:06 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/gnash/ChangeLog,v 1.30 2006/11/21 11:56:41 genstef Exp $
+
+ 21 Nov 2006; Stefan Schweizer <genstef@gentoo.org> gnash-0.7.2.ebuild,
+ gnash-0.7.2_p20099999.ebuild:
+ Readd kde support on popular demand. Drizztbsd and others say that it is
+ working
*gnash-0.7.2_p20099999 (18 Nov 2006)
diff --git a/net-www/gnash/gnash-0.7.2.ebuild b/net-www/gnash/gnash-0.7.2.ebuild
index 0713194ef9de..b3dafc212c50 100644
--- a/net-www/gnash/gnash-0.7.2.ebuild
+++ b/net-www/gnash/gnash-0.7.2.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/gnash/gnash-0.7.2.ebuild,v 1.2 2006/11/18 20:52:55 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/gnash/gnash-0.7.2.ebuild,v 1.3 2006/11/21 11:56:41 genstef Exp $
-inherit nsplugins
+inherit nsplugins kde-functions
+set-kdedir
DESCRIPTION="Gnash is a GNU Flash movie player that supports many SWF v7 features"
HOMEPAGE="http://www.gnu.org/software/gnash"
@@ -11,7 +12,7 @@ SRC_URI="ftp://ftp.gnu.org/pub/gnu/${PN}/${PV}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 -sparc ~x86 ~ppc"
-IUSE="agg gstreamer ffmpeg nsplugin xml video_cards_i810"
+IUSE="agg gstreamer ffmpeg kde nsplugin xml video_cards_i810"
#dmalloc, broken see bug 142939
#dmalloc? ( dev-libs/dmalloc )
# $(use_enable dmalloc) \
@@ -47,6 +48,7 @@ RDEPEND="
>x11-libs/gtk+-2
x11-libs/pango
!agg? ( virtual/opengl x11-libs/gtkglext )
+ kde? ( kde-base/kdelibs )
agg? ( x11-libs/agg )"
#cairo? ( x11-libs/cairo )
@@ -80,13 +82,12 @@ src_compile() {
myconf="${myconf} --with-mp3-decoder=ffmpeg"
fi
- # klash is broken, thus we do not offer it
econf \
$(use_enable nsplugin plugin) \
$(use_enable xml) \
$(use_enable video_cards_i810 i810-lod-bias) \
--without-gcc-arch \
- --disable-klash \
+ $(use_enable kde klash) \
${myconf} || die "econf failed"
emake || die "emake failed"
}
diff --git a/net-www/gnash/gnash-0.7.2_p20099999.ebuild b/net-www/gnash/gnash-0.7.2_p20099999.ebuild
index 1db71f575ee0..242d02fff449 100644
--- a/net-www/gnash/gnash-0.7.2_p20099999.ebuild
+++ b/net-www/gnash/gnash-0.7.2_p20099999.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/gnash/gnash-0.7.2_p20099999.ebuild,v 1.1 2006/11/18 20:58:06 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/gnash/gnash-0.7.2_p20099999.ebuild,v 1.2 2006/11/21 11:56:41 genstef Exp $
WANT_AUTOCONF=latest
-inherit nsplugins autotools cvs
+inherit nsplugins autotools cvs kde-functions
+set-kdedir
DESCRIPTION="Gnash is a GNU Flash movie player that supports many SWF v7 features"
HOMEPAGE="http://www.gnu.org/software/gnash"
@@ -17,7 +18,7 @@ S=${WORKDIR}/${PN}
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="-*"
-IUSE="agg gstreamer ffmpeg nsplugin xml video_cards_i810"
+IUSE="agg gstreamer ffmpeg kde nsplugin xml video_cards_i810"
#dmalloc, broken see bug 142939
#dmalloc? ( dev-libs/dmalloc )
# $(use_enable dmalloc) \
@@ -53,6 +54,7 @@ RDEPEND="
>x11-libs/gtk+-2
x11-libs/pango
!agg? ( virtual/opengl x11-libs/gtkglext )
+ kde? ( kde-base/kdelibs )
agg? ( x11-libs/agg )"
#cairo? ( x11-libs/cairo )
@@ -94,13 +96,12 @@ src_compile() {
myconf="${myconf} --with-mp3-decoder=ffmpeg"
fi
- # klash is broken, thus we do not offer it
econf \
$(use_enable nsplugin plugin) \
$(use_enable xml) \
$(use_enable video_cards_i810 i810-lod-bias) \
--without-gcc-arch \
- --disable-klash \
+ $(use_enable kde klash) \
${myconf} || die "econf failed"
emake -j1 || die "emake failed"
}