summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2009-01-03 22:53:39 +0000
committerMark Loeser <halcy0n@gentoo.org>2009-01-03 22:53:39 +0000
commit9d1e8d7c6f13c9ab291d6eeba1550ebb40cce53c (patch)
tree86f94a791fcbb7be58a7f9c52ac4679423da22f3
parentadd use-based deps (diff)
downloadgentoo-2-9d1e8d7c6f13c9ab291d6eeba1550ebb40cce53c.tar.gz
gentoo-2-9d1e8d7c6f13c9ab291d6eeba1550ebb40cce53c.tar.bz2
gentoo-2-9d1e8d7c6f13c9ab291d6eeba1550ebb40cce53c.zip
Add patch to fix compilation with gcc-4.3; bug #250754
(Portage version: 2.2_rc20/cvs/Linux 2.6.28 i686)
-rw-r--r--app-text/rtf2html/ChangeLog8
-rw-r--r--app-text/rtf2html/files/rtf2html-0.2.0-gcc43.patch22
-rw-r--r--app-text/rtf2html/rtf2html-0.2.0.ebuild15
3 files changed, 37 insertions, 8 deletions
diff --git a/app-text/rtf2html/ChangeLog b/app-text/rtf2html/ChangeLog
index f1d1678d16c6..0956d4fb6248 100644
--- a/app-text/rtf2html/ChangeLog
+++ b/app-text/rtf2html/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/rtf2html
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/rtf2html/ChangeLog,v 1.2 2008/03/23 11:15:30 swegener Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/rtf2html/ChangeLog,v 1.3 2009/01/03 22:53:39 halcy0n Exp $
+
+ 03 Jan 2009; Mark Loeser <halcy0n@gentoo.org>
+ +files/rtf2html-0.2.0-gcc43.patch, rtf2html-0.2.0.ebuild:
+ Add patch to fix compilation with gcc-4.3; bug #250754
*rtf2html-0.2.0 (17 Mar 2008)
diff --git a/app-text/rtf2html/files/rtf2html-0.2.0-gcc43.patch b/app-text/rtf2html/files/rtf2html-0.2.0-gcc43.patch
new file mode 100644
index 000000000000..f87661fd3796
--- /dev/null
+++ b/app-text/rtf2html/files/rtf2html-0.2.0-gcc43.patch
@@ -0,0 +1,22 @@
+diff -ur rtf2html-0.2.0-orig/rtf_keyword.h rtf2html-0.2.0/rtf_keyword.h
+--- rtf2html-0.2.0-orig/rtf_keyword.h 2007-08-03 04:50:45.000000000 -0400
++++ rtf2html-0.2.0/rtf_keyword.h 2009-01-03 17:45:14.000000000 -0500
+@@ -2,6 +2,7 @@
+
+ #include "config.h"
+ #include <string>
++#include <cstdlib>
+ #include <map>
+ #include <ctype.h>
+
+diff -ur rtf2html-0.2.0-orig/rtf_table.cpp rtf2html-0.2.0/rtf_table.cpp
+--- rtf2html-0.2.0-orig/rtf_table.cpp 2007-07-31 11:16:52.000000000 -0400
++++ rtf2html-0.2.0/rtf_table.cpp 2009-01-03 17:45:14.000000000 -0500
+@@ -4,6 +4,7 @@
+ #include <iostream>
+ #include <stdexcept>
+ #include <functional>
++#include <algorithm>
+
+ typedef std::set<int> intset;
+
diff --git a/app-text/rtf2html/rtf2html-0.2.0.ebuild b/app-text/rtf2html/rtf2html-0.2.0.ebuild
index a0490f029a4f..f9732f296231 100644
--- a/app-text/rtf2html/rtf2html-0.2.0.ebuild
+++ b/app-text/rtf2html/rtf2html-0.2.0.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/rtf2html/rtf2html-0.2.0.ebuild,v 1.1 2008/03/17 10:57:23 s4t4n Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/rtf2html/rtf2html-0.2.0.ebuild,v 1.2 2009/01/03 22:53:39 halcy0n Exp $
+
+inherit eutils
IUSE=""
@@ -16,10 +18,11 @@ IUSE=""
DEPEND=""
RDEPEND="${DEPEND}"
-src_compile()
-{
- econf || die "Configuration failed"
- emake || die "Compilation failed"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-gcc43.patch
}
src_install()