summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-08-05 17:34:14 +0000
committerMichał Górny <mgorny@gentoo.org>2013-08-05 17:34:14 +0000
commite2cee10803c7baa26a634155e0d5f65ff0a38249 (patch)
treed5a58ef4b59f3a2e81f73ec98a31d9007adadb34
parentRemove old versions for bug 479812. (diff)
downloadgentoo-2-e2cee10803c7baa26a634155e0d5f65ff0a38249.tar.gz
gentoo-2-e2cee10803c7baa26a634155e0d5f65ff0a38249.tar.bz2
gentoo-2-e2cee10803c7baa26a634155e0d5f65ff0a38249.zip
Turn setuptools into an RDEPEND, since pkg_resources are used.
(Portage version: 2.2.0_alpha194/cvs/Linux x86_64, signed Manifest commit with key 9627F456F9DA7643!)
-rw-r--r--dev-python/ipython/ChangeLog5
-rw-r--r--dev-python/ipython/ipython-0.13.2.ebuild6
2 files changed, 7 insertions, 4 deletions
diff --git a/dev-python/ipython/ChangeLog b/dev-python/ipython/ChangeLog
index 0676ccc33014..be25e3985161 100644
--- a/dev-python/ipython/ChangeLog
+++ b/dev-python/ipython/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/ipython
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/ipython/ChangeLog,v 1.111 2013/06/30 04:43:41 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ipython/ChangeLog,v 1.112 2013/08/05 17:34:14 mgorny Exp $
+
+ 05 Aug 2013; Michał Górny <mgorny@gentoo.org> ipython-0.13.2.ebuild:
+ Turn setuptools into an RDEPEND, since pkg_resources are used.
30 Jun 2013; Mike Frysinger <vapier@gentoo.org> ipython-0.13.2.ebuild:
Add ~arm to latest version too.
diff --git a/dev-python/ipython/ipython-0.13.2.ebuild b/dev-python/ipython/ipython-0.13.2.ebuild
index 9b53014575ff..bfec03964100 100644
--- a/dev-python/ipython/ipython-0.13.2.ebuild
+++ b/dev-python/ipython/ipython-0.13.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/ipython/ipython-0.13.2.ebuild,v 1.5 2013/06/30 04:43:41 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ipython/ipython-0.13.2.ebuild,v 1.6 2013/08/05 17:34:14 mgorny Exp $
EAPI=5
@@ -23,8 +23,9 @@ PY2_USEDEP=$(python_gen_usedep 'python2*')
CDEPEND="dev-python/decorator[${PYTHON_USEDEP}]
dev-python/pexpect[${PY2_USEDEP}]
- virtual/pyparsing[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/simplegeneric[${PYTHON_USEDEP}]
+ virtual/pyparsing[${PYTHON_USEDEP}]
virtual/python-argparse[${PYTHON_USEDEP}]
emacs? ( app-emacs/python-mode virtual/emacs )
matplotlib? ( dev-python/matplotlib[${PYTHON_USEDEP}] )
@@ -40,7 +41,6 @@ RDEPEND="${CDEPEND}
dev-python/pygments[${PYTHON_USEDEP}]
dev-python/pyzmq[${PYTHON_USEDEP}] )"
DEPEND="${CDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
test? ( dev-python/nose[${PYTHON_USEDEP}] )"
PY2_REQUSE="|| ( $(python_gen_useflags python2* ) )"