summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Redaelli <drizzt@gentoo.org>2007-04-26 20:59:09 +0000
committerTimothy Redaelli <drizzt@gentoo.org>2007-04-26 20:59:09 +0000
commit82ed2c9cad1f20d264a7a07c44ff0ce71c3b163a (patch)
treeaa43b8122bf8c71d395f7584801ea56c6e6fcaf6 /app-arch
parentFix RDEPEND. (diff)
downloadgentoo-2-82ed2c9cad1f20d264a7a07c44ff0ce71c3b163a.tar.gz
gentoo-2-82ed2c9cad1f20d264a7a07c44ff0ce71c3b163a.tar.bz2
gentoo-2-82ed2c9cad1f20d264a7a07c44ff0ce71c3b163a.zip
Version bump, fixed static patch
(Portage version: 2.1.2.3)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/bsdtar/ChangeLog8
-rw-r--r--app-arch/bsdtar/bsdtar-2.1.9.ebuild82
-rw-r--r--app-arch/bsdtar/files/digest-bsdtar-2.1.93
-rw-r--r--app-arch/bsdtar/files/libarchive-2.1.9-static.patch36
4 files changed, 128 insertions, 1 deletions
diff --git a/app-arch/bsdtar/ChangeLog b/app-arch/bsdtar/ChangeLog
index 058a20cd6971..41e0cbc09520 100644
--- a/app-arch/bsdtar/ChangeLog
+++ b/app-arch/bsdtar/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-arch/bsdtar
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/bsdtar/ChangeLog,v 1.63 2007/04/17 20:32:15 drizzt Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/bsdtar/ChangeLog,v 1.64 2007/04/26 20:59:09 drizzt Exp $
+
+*bsdtar-2.1.9 (26 Apr 2007)
+
+ 26 Apr 2007; Timothy Redaelli <drizzt@gentoo.org>
+ +files/libarchive-2.1.9-static.patch, +bsdtar-2.1.9.ebuild:
+ Version bump, fixed static patch
*bsdtar-2.1.5 (17 Apr 2007)
diff --git a/app-arch/bsdtar/bsdtar-2.1.9.ebuild b/app-arch/bsdtar/bsdtar-2.1.9.ebuild
new file mode 100644
index 000000000000..d52b798ecdc4
--- /dev/null
+++ b/app-arch/bsdtar/bsdtar-2.1.9.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/bsdtar/bsdtar-2.1.9.ebuild,v 1.1 2007/04/26 20:59:09 drizzt Exp $
+
+inherit eutils autotools toolchain-funcs flag-o-matic
+
+MY_P="libarchive-${PV/_beta/b}"
+
+DESCRIPTION="BSD tar command"
+HOMEPAGE="http://people.freebsd.org/~kientzle/libarchive/"
+SRC_URI="http://people.freebsd.org/~kientzle/libarchive/src/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="build static acl xattr"
+
+RDEPEND="!dev-libs/libarchive
+ kernel_linux? (
+ acl? ( sys-apps/acl )
+ xattr? ( sys-apps/attr )
+ )
+ !static? ( !build? (
+ app-arch/bzip2
+ sys-libs/zlib ) )"
+DEPEND="${RDEPEND}
+ kernel_linux? ( sys-fs/e2fsprogs
+ virtual/os-headers )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/libarchive-2.1.9-static.patch
+ epatch "${FILESDIR}"/libarchive-2.1.5-acl.patch
+
+ eautoreconf
+ epunt_cxx
+}
+
+src_compile() {
+ local myconf
+
+ if use static || use build ; then
+ myconf="${myconf} --enable-static-bsdtar"
+ else
+ myconf="${myconf} --disable-static-bsdtar"
+ fi
+
+ # Upstream doesn't seem to care to fix the problems
+ # and I don't want to continue running after them.
+ append-flags -fno-strict-aliasing
+
+ econf \
+ --bindir=/bin \
+ $(use_enable acl) \
+ $(use_enable xattr) \
+ ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die "emake install failed"
+
+ # Create tar symlink for FreeBSD
+ if [[ ${CHOST} == *-freebsd* ]]; then
+ dosym bsdtar /bin/tar
+ dosym bsdtar.1 /usr/share/man/man1/tar.1
+ fi
+
+ if use build; then
+ rm -rf "${D}"/usr
+ rm -rf "${D}"/lib/*.so*
+ return 0
+ fi
+
+ dodir /$(get_libdir)
+ mv "${D}"/usr/$(get_libdir)/*.so* "${D}"/$(get_libdir)
+ gen_usr_ldscript libarchive.so
+}
diff --git a/app-arch/bsdtar/files/digest-bsdtar-2.1.9 b/app-arch/bsdtar/files/digest-bsdtar-2.1.9
new file mode 100644
index 000000000000..3345a5fe4cb7
--- /dev/null
+++ b/app-arch/bsdtar/files/digest-bsdtar-2.1.9
@@ -0,0 +1,3 @@
+MD5 de9b2e9faed17dcfe2066e4b1dfbfdb3 libarchive-2.1.9.tar.gz 614004
+RMD160 63726482e805508df6c40d627e08f558a6d1e3ac libarchive-2.1.9.tar.gz 614004
+SHA256 0748bf8bc06d7ab20fb3046f9f057a0d00d26c00fda416b9f911de06238663ef libarchive-2.1.9.tar.gz 614004
diff --git a/app-arch/bsdtar/files/libarchive-2.1.9-static.patch b/app-arch/bsdtar/files/libarchive-2.1.9-static.patch
new file mode 100644
index 000000000000..f59e176473e1
--- /dev/null
+++ b/app-arch/bsdtar/files/libarchive-2.1.9-static.patch
@@ -0,0 +1,36 @@
+Index: libarchive-1.3.1/configure.ac
+===================================================================
+--- libarchive-1.3.1.orig/configure.ac
++++ libarchive-1.3.1/configure.ac
+@@ -71,6 +71,11 @@ AC_CHECK_HEADERS([locale.h paths.h])
+ AC_CHECK_HEADERS([stdint.h stdlib.h string.h sys/acl.h sys/ioctl.h])
+ AC_CHECK_HEADERS([sys/param.h sys/time.h unistd.h wchar.h zlib.h])
+
++AC_ARG_ENABLE([static-bsdtar],
++ AS_HELP_STRING([--disable-static-bsdtar], [Makes bsdtar link dynamically to libarchive (default: static)]) )
++
++AM_CONDITIONAL([STATIC_BSDTAR], [test "x$enable_static_bsdtar" != "xno"])
++
+ # Checks for libraries.
+ AC_CHECK_LIB(acl,acl_set_file)
+ AC_CHECK_LIB(attr,setxattr)
+Index: libarchive-1.3.1/Makefile.am
+===================================================================
+--- libarchive-1.3.1.orig/Makefile.am
++++ libarchive-1.3.1/Makefile.am
+@@ -114,8 +114,12 @@ bsdtar_DEPENDENCIES = libarchive.la \
+ libarchive/archive_entry.h \
+ libarchive/archive.h
+
+-bsdtar_LDADD= -larchive
+-bsdtar_CPPFLAGS=-I$(top_builddir)/libarchive
++if STATIC_BSDTAR
+ # Link libarchive statically...
+-bsdtar_LDFLAGS= -static -I$(destdir)/libarchive
++static=-all-static
++endif
++
++bsdtar_LDADD= -L. -larchive -lbz2 -lz
++bsdtar_CPPFLAGS=-I$(top_builddir)/libarchive
++bsdtar_LDFLAGS= $(static)
+ bsdtar_dist_man_MANS= tar/bsdtar.1