summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-08-02 04:58:29 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-08-02 04:58:29 +0000
commit93842146c4c3e319a7f05df60d99030dd08e0b1f (patch)
tree5275e683567219f9766ff473314a8b6fe3f0d9f7 /app-arch
parentmodernized (diff)
downloadgentoo-2-93842146c4c3e319a7f05df60d99030dd08e0b1f.tar.gz
gentoo-2-93842146c4c3e319a7f05df60d99030dd08e0b1f.tar.bz2
gentoo-2-93842146c4c3e319a7f05df60d99030dd08e0b1f.zip
modernised
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/unlzx/unlzx-1.1.ebuild14
-rw-r--r--app-arch/zip/zip-2.3-r1.ebuild23
2 files changed, 13 insertions, 24 deletions
diff --git a/app-arch/unlzx/unlzx-1.1.ebuild b/app-arch/unlzx/unlzx-1.1.ebuild
index 66babb69f403..ae9ba52fc22a 100644
--- a/app-arch/unlzx/unlzx-1.1.ebuild
+++ b/app-arch/unlzx/unlzx-1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-arch/unlzx/unlzx-1.1.ebuild,v 1.6 2002/08/02 04:50:11 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/unlzx/unlzx-1.1.ebuild,v 1.7 2002/08/02 04:58:29 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Unarchiver for Amiga LZX archives"
@@ -14,23 +14,17 @@ KEYWORDS="x86"
DEPEND="virtual/glibc"
src_unpack() {
-
- mkdir ${S}
- gzip -dc ${DISTDIR}/${PN}.c.gz > ${S}/unlzx.c
- cp ${DISTDIR}/${PN}.c.gz.readme ${S}/${PN}.c.gz.readme
-
+ mkdir ${S}
+ gzip -dc ${DISTDIR}/${PN}.c.gz > ${S}/unlzx.c
+ cp ${DISTDIR}/${PN}.c.gz.readme ${S}/${PN}.c.gz.readme
}
src_compile() {
-
gcc ${CFLAGS} -o unlzx unlzx.c
-
}
src_install () {
-
dobin unlzx
dodoc unlzx.c.gz.readme
-
}
diff --git a/app-arch/zip/zip-2.3-r1.ebuild b/app-arch/zip/zip-2.3-r1.ebuild
index 263b84757887..039ccbedb8a6 100644
--- a/app-arch/zip/zip-2.3-r1.ebuild
+++ b/app-arch/zip/zip-2.3-r1.ebuild
@@ -1,37 +1,32 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-arch/zip/zip-2.3-r1.ebuild,v 1.9 2002/08/02 04:50:11 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/zip/zip-2.3-r1.ebuild,v 1.10 2002/08/02 04:57:53 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Info ZIP"
SRC_URI="http://www.ibiblio.org/pub/Linux/distributions/gentoo/distfiles/${PN}23.tar.gz"
-SLOT="0"
HOMEPAGE="ftp://ftp.freesoftware.com/pub/infozip/Zip.html"
+
+SLOT="0"
+KEYWORDS="x86 ppc"
LICENSE="Info-ZIP"
DEPEND="virtual/glibc"
-KEYWORDS="x86 ppc"
src_unpack() {
-
- unpack ${A}
- cd ${S}/unix
- cp Makefile Makefile.orig
- sed -e "s:-O2:${CFLAGS}:" Makefile.orig > Makefile
-
+ unpack ${A}
+ cd ${S}/unix
+ cp Makefile Makefile.orig
+ sed -e "s:-O2:${CFLAGS}:" Makefile.orig > Makefile
}
-src_compile() {
+src_compile() {
make -f unix/Makefile generic_gcc || die
-
}
src_install () {
-
dobin zip zipcloak zipnote zipsplit
doman man/zip.1
dodoc BUGS CHANGES LICENSE MANUAL README TODO WHATSNEW WHERE
-
}
-