summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-04-26 21:31:31 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-04-26 21:31:31 +0000
commitfe2daebff0d42ed14df34c540f4cf1d551ea0622 (patch)
tree2babcde0845b3fed8466c012db931bdbf63861ca /app-doc/doxygen
parentThis changelog was nice but is more noise than anything else. This directory ... (diff)
downloadgentoo-2-fe2daebff0d42ed14df34c540f4cf1d551ea0622.tar.gz
gentoo-2-fe2daebff0d42ed14df34c540f4cf1d551ea0622.tar.bz2
gentoo-2-fe2daebff0d42ed14df34c540f4cf1d551ea0622.zip
fix build with BSD userland
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'app-doc/doxygen')
-rw-r--r--app-doc/doxygen/ChangeLog5
-rw-r--r--app-doc/doxygen/doxygen-1.8.0.ebuild8
2 files changed, 10 insertions, 3 deletions
diff --git a/app-doc/doxygen/ChangeLog b/app-doc/doxygen/ChangeLog
index 8e2bc0dd3521..60edfd51f864 100644
--- a/app-doc/doxygen/ChangeLog
+++ b/app-doc/doxygen/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-doc/doxygen
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/ChangeLog,v 1.220 2012/04/13 17:39:03 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/ChangeLog,v 1.221 2012/04/26 21:31:31 aballier Exp $
+
+ 26 Apr 2012; Alexis Ballier <aballier@gentoo.org> doxygen-1.8.0.ebuild:
+ fix build with BSD userland
13 Apr 2012; Ulrich Müller <ulm@gentoo.org> doxygen-1.7.5.1.ebuild:
Move EAPI assignment to top of ebuild, bug 411875.
diff --git a/app-doc/doxygen/doxygen-1.8.0.ebuild b/app-doc/doxygen/doxygen-1.8.0.ebuild
index 2952254929dc..ea424aa29c84 100644
--- a/app-doc/doxygen/doxygen-1.8.0.ebuild
+++ b/app-doc/doxygen/doxygen-1.8.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.8.0.ebuild,v 1.1 2012/02/29 09:12:35 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.8.0.ebuild,v 1.2 2012/04/26 21:31:31 aballier Exp $
EAPI=4
@@ -15,7 +15,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86
~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
-IUSE="debug doc dot qt4 latex elibc_FreeBSD"
+IUSE="debug doc dot qt4 latex elibc_FreeBSD userland_GNU"
#missing SerbianCyrilic, JapaneseEn, KoreanEn, Chinesetraditional
@@ -143,6 +143,10 @@ src_configure() {
use qt4 && my_conf="${my_conf} --with-doxywizard"
+ # On non GNU userland (e.g. BSD), configure script picks up make and bails
+ # out because it is not GNU make, so we force the right value.
+ use userland_GNU || my_conf="${my_conf} --make ${MAKE} --install install"
+
export LINK="${QMAKE_LINK}"
export LINK_SHLIB="${QMAKE_CXX}"