summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-04 21:39:20 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-04 21:39:20 +0000
commitf23767ac80b0853b5c6a01f7f091f49bda06e08e (patch)
tree693b799bd067cdf7bf30be4364d2d3ecf96a9569 /app-editors/nano
parentold (diff)
downloadgentoo-2-f23767ac80b0853b5c6a01f7f091f49bda06e08e.tar.gz
gentoo-2-f23767ac80b0853b5c6a01f7f091f49bda06e08e.tar.bz2
gentoo-2-f23767ac80b0853b5c6a01f7f091f49bda06e08e.zip
ver bump
Diffstat (limited to 'app-editors/nano')
-rw-r--r--app-editors/nano/ChangeLog11
-rw-r--r--app-editors/nano/files/1.3.2-nomac.patch11
-rw-r--r--app-editors/nano/files/1.3.2-wsconvert.patch197
-rw-r--r--app-editors/nano/files/digest-nano-1.3.21
-rw-r--r--app-editors/nano/nano-1.3.2.ebuild65
5 files changed, 282 insertions, 3 deletions
diff --git a/app-editors/nano/ChangeLog b/app-editors/nano/ChangeLog
index 10d34cc5e417..0c34e3896356 100644
--- a/app-editors/nano/ChangeLog
+++ b/app-editors/nano/ChangeLog
@@ -1,12 +1,17 @@
# ChangeLog for app-editors/nano
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/ChangeLog,v 1.46 2004/03/30 00:08:18 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/ChangeLog,v 1.47 2004/04/04 21:39:19 vapier Exp $
- 29 Mar 2004; Gustavo Zacarias <gustavoz@gentoo.org> nano-1.2.3.ebuild:
- stable on sparc, thanks to txromeo for additional testing
+*nano-1.3.2 (04 Apr 2004)
+
+ 04 Apr 2004; Mike Frysinger <vapier@gentoo.org> :
+ Version bump.
*nano-1.2.3 (16 Jan 2004)
+ 29 Mar 2004; Gustavo Zacarias <gustavoz@gentoo.org> nano-1.2.3.ebuild:
+ stable on sparc, thanks to txromeo for additional testing
+
16 Jan 2004; Mike Frysinger <vapier@gentoo.org> :
Version bump for stable tree.
diff --git a/app-editors/nano/files/1.3.2-nomac.patch b/app-editors/nano/files/1.3.2-nomac.patch
new file mode 100644
index 000000000000..c03eb459aeef
--- /dev/null
+++ b/app-editors/nano/files/1.3.2-nomac.patch
@@ -0,0 +1,11 @@
+diff -ur src.orig/global.c src/global.c
+--- src.orig/global.c 2004-01-26 03:41:57.311795432 -0500
++++ src/global.c 2004-01-26 03:49:42.517073480 -0500
+@@ -290,7 +290,6 @@
+ #endif
+ toggle_init_one(TOGGLE_NOCONVERT_KEY, toggle_noconvert_msg, NO_CONVERT);
+ toggle_init_one(TOGGLE_DOS_KEY, toggle_dos_msg, DOS_FILE);
+- toggle_init_one(TOGGLE_MAC_KEY, toggle_mac_msg, MAC_FILE);
+ toggle_init_one(TOGGLE_BACKUP_KEY, toggle_backup_msg, BACKUP_FILE);
+ toggle_init_one(TOGGLE_SMOOTH_KEY, toggle_smooth_msg, SMOOTHSCROLL);
+ #ifdef ENABLE_COLOR
diff --git a/app-editors/nano/files/1.3.2-wsconvert.patch b/app-editors/nano/files/1.3.2-wsconvert.patch
new file mode 100644
index 000000000000..824397c3669b
--- /dev/null
+++ b/app-editors/nano/files/1.3.2-wsconvert.patch
@@ -0,0 +1,197 @@
+diff -ur nano-1.3.1.orig/doc/nanorc.sample nano-1.3.1/doc/nanorc.sample
+--- nano-1.3.1.orig/doc/nanorc.sample 2004-01-10 03:04:04.105882992 -0500
++++ nano-1.3.1/doc/nanorc.sample 2004-01-10 03:04:29.507021432 -0500
+@@ -89,6 +89,16 @@
+ ## Use this tab size instead of the default; it must be greater than 0
+ # set tabsize 8
+
++## Use this tab char instead of the default space; it can either be the
++## ascii value of the character you wish to see (refer to ascii(7)) or
++## it can be a single character. 187 seems to be a 'good' value.
++# set tabconvert 32
++## Same as tabconverting above, but applied to spaces.
++## it can be a single character. 183 seems to be a 'good' value.
++# set spaceconvert 32
++## Finally, you can toggle whitespace converting with this
++# set wsconvert
++
+ ## Save automatically on exit, don't prompt
+ # set tempfile
+
+diff -ur nano-1.3.1.orig/src/global.c nano-1.3.1/src/global.c
+--- nano-1.3.1.orig/src/global.c 2004-01-10 03:04:04.115881472 -0500
++++ nano-1.3.1/src/global.c 2004-01-10 03:05:01.991083104 -0500
+@@ -87,6 +87,9 @@
+ int tabsize = -1; /* Our internal tabsize variable. The
+ default value 8 is set in main(). */
+
++int tabconvert = ' ';
++int spaceconvert = ' ';
++
+ char *hblank = NULL; /* A horizontal blank line */
+ #ifndef DISABLE_HELP
+ char *help_text; /* The text in the help window */
+@@ -231,7 +234,7 @@
+ char *toggle_const_msg, *toggle_autoindent_msg, *toggle_suspend_msg,
+ *toggle_nohelp_msg, *toggle_cuttoend_msg,
+ *toggle_noconvert_msg, *toggle_dos_msg, *toggle_mac_msg,
+- *toggle_backup_msg, *toggle_smooth_msg;
++ *toggle_backup_msg, *toggle_smooth_msg, *toggle_wsconvert_msg;
+ #ifndef DISABLE_MOUSE
+ char *toggle_mouse_msg;
+ #endif
+@@ -263,6 +266,7 @@
+ toggle_mac_msg = _("Writing file in Mac format");
+ toggle_backup_msg = _("Backing up file");
+ toggle_smooth_msg = _("Smooth scrolling");
++ toggle_wsconvert_msg = _("Whitespace converting");
+ #ifdef ENABLE_COLOR
+ toggle_syntax_msg = _("Color syntax highlighting");
+ #endif
+@@ -279,6 +283,7 @@
+ #endif
+ toggle_init_one(TOGGLE_CONST_KEY, toggle_const_msg, CONSTUPDATE);
+ toggle_init_one(TOGGLE_AUTOINDENT_KEY, toggle_autoindent_msg, AUTOINDENT);
++ toggle_init_one(TOGGLE_WSCONVERT_KEY, toggle_wsconvert_msg, WS_CONVERT);
+ #ifndef DISABLE_WRAPPING
+ toggle_init_one(TOGGLE_WRAP_KEY, toggle_wrap_msg, NO_WRAP);
+ #endif
+diff -ur nano-1.3.1.orig/src/nano.c nano-1.3.1/src/nano.c
+--- nano-1.3.1.orig/src/nano.c 2004-01-10 03:04:04.140877672 -0500
++++ nano-1.3.1/src/nano.c 2004-01-10 03:04:29.511020824 -0500
+@@ -3006,6 +3006,9 @@
+ edit_refresh();
+ break;
+ #endif
++ case TOGGLE_WSCONVERT_KEY:
++ edit_refresh();
++ break;
+ }
+
+ /* We are assuming here that shortcut_init() above didn't free and
+diff -ur nano-1.3.1.orig/src/nano.h nano-1.3.1/src/nano.h
+--- nano-1.3.1.orig/src/nano.h 2004-01-10 03:04:04.139877824 -0500
++++ nano-1.3.1/src/nano.h 2004-01-10 03:04:29.512020672 -0500
+@@ -296,6 +296,7 @@
+ #define PRESERVE (1<<27)
+ #define HISTORY_CHANGED (1<<28)
+ #define HISTORYLOG (1<<29)
++#define WS_CONVERT (1<<31)
+
+ /* Control key sequences, changing these would be very very bad. */
+ #define NANO_CONTROL_SPACE 0
+@@ -461,6 +462,7 @@
+ #define TOGGLE_MAC_KEY NANO_ALT_O
+ #define TOGGLE_SMOOTH_KEY NANO_ALT_S
+ #define TOGGLE_NOCONVERT_KEY NANO_ALT_N
++#define TOGGLE_WSCONVERT_KEY NANO_ALT_E
+ #define TOGGLE_BACKUP_KEY NANO_ALT_B
+ #define TOGGLE_SYNTAX_KEY NANO_ALT_Y
+ #endif /* !NANO_SMALL */
+diff -ur nano-1.3.1.orig/src/proto.h nano-1.3.1/src/proto.h
+--- nano-1.3.1.orig/src/proto.h 2004-01-10 03:04:04.140877672 -0500
++++ nano-1.3.1/src/proto.h 2004-01-10 03:04:29.513020520 -0500
+@@ -41,7 +41,7 @@
+ extern long totsize;
+ extern int temp_opt;
+ extern int flags;
+-extern int tabsize;
++extern int tabsize, tabconvert, spaceconvert;
+ extern int search_last_line;
+ extern int search_offscreen;
+ extern int currslen;
+diff -ur nano-1.3.1.orig/src/rcfile.c nano-1.3.1/src/rcfile.c
+--- nano-1.3.1.orig/src/rcfile.c 2004-01-10 03:04:04.140877672 -0500
++++ nano-1.3.1/src/rcfile.c 2004-01-10 03:04:29.514020368 -0500
+@@ -61,6 +61,7 @@
+ #endif
+ #ifndef NANO_SMALL
+ {"noconvert", NO_CONVERT},
++ {"wsconvert", WS_CONVERT},
+ #endif
+ {"nofollow", NOFOLLOW_SYMLINKS},
+ {"nohelp", NO_HELP},
+@@ -86,6 +87,8 @@
+ #endif
+ {"suspend", SUSPEND},
+ {"tabsize", 0},
++ {"tabconvert", ' '},
++ {"spaceconvert", ' '},
+ {"tempfile", TEMP_OPT},
+ {"view", VIEW_MODE},
+ {NULL, 0}
+@@ -532,6 +535,8 @@
+ #endif
+ if (set == 1) {
+ if (!strcasecmp(rcopts[i].name, "tabsize")
++ || !strcasecmp(rcopts[i].name, "tabconvert")
++ || !strcasecmp(rcopts[i].name, "spaceconvert")
+ #ifndef DISABLE_OPERATINGDIR
+ || !strcasecmp(rcopts[i].name, "operatingdir")
+ #endif
+@@ -603,12 +608,30 @@
+ * accept 0 while checking other
+ * errors. */
+ j = (int)strtol(option, &first_error, 10);
+- if (errno == ERANGE || *option == '\0' || *first_error != '\0')
+- rcfile_error(_("Requested tab size %d invalid"),
+- j);
+- else
+- tabsize = j;
+- }
++ if (!strcasecmp(rcopts[i].name, "tabconvert")) {
++ if (errno == ERANGE || *first_error != '\0') {
++ if (*option == '\0')
++ rcfile_error(_("requested tab convert is invalid"));
++ else
++ tabconvert = option[0];
++ } else
++ tabconvert = j;
++ } else if (!strcasecmp(rcopts[i].name, "spaceconvert")) {
++ if (errno == ERANGE || *first_error != '\0') {
++ if (*option == '\0')
++ rcfile_error(_("requested space convert is invalid"));
++ else
++ spaceconvert = option[0];
++ } else
++ spaceconvert = j;
++ } else {
++ if (errno == ERANGE || *option == '\0' || *first_error != '\0')
++ rcfile_error(_("requested tab size %d invalid"),
++ j);
++ else
++ tabsize = j;
++ }
++ }
+ } else
+ SET(rcopts[i].flag);
+ #ifdef DEBUG
+diff -ur nano-1.3.1.orig/src/winio.c nano-1.3.1/src/winio.c
+--- nano-1.3.1.orig/src/winio.c 2004-01-10 03:04:04.138877976 -0500
++++ nano-1.3.1/src/winio.c 2004-01-10 03:04:29.516020064 -0500
+@@ -1009,11 +1009,12 @@
+ index = 0;
+
+ for (; index < alloc_len; buf++) {
+- if (*buf == '\t')
+- do {
++ if (*buf == '\t') {
++ converted[index++] = (ISSET(WS_CONVERT) ? tabconvert : ' ');
++ while ((column + index) % tabsize) {
+ converted[index++] = ' ';
+- } while ((column + index) % tabsize);
+- else if (is_cntrl_char(*buf)) {
++ }
++ } else if (is_cntrl_char(*buf)) {
+ converted[index++] = '^';
+ if (*buf == '\n')
+ /* Treat newlines embedded in a line as encoded nulls;
+@@ -1025,7 +1026,7 @@
+ else
+ converted[index++] = *buf + 64;
+ } else
+- converted[index++] = *buf;
++ converted[index++] = (*buf==' '&&ISSET(WS_CONVERT)) ? spaceconvert : *buf;
+ }
+ assert(len <= alloc_len + column - start_col);
+ charmove(converted, converted + start_col - column, len);
diff --git a/app-editors/nano/files/digest-nano-1.3.2 b/app-editors/nano/files/digest-nano-1.3.2
new file mode 100644
index 000000000000..54ccd0c171ed
--- /dev/null
+++ b/app-editors/nano/files/digest-nano-1.3.2
@@ -0,0 +1 @@
+MD5 86f0cd4dcba4811494151d64b944cbe3 nano-1.3.2.tar.gz 944954
diff --git a/app-editors/nano/nano-1.3.2.ebuild b/app-editors/nano/nano-1.3.2.ebuild
new file mode 100644
index 000000000000..ee531e1ed623
--- /dev/null
+++ b/app-editors/nano/nano-1.3.2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-1.3.2.ebuild,v 1.1 2004/04/04 21:39:19 vapier Exp $
+
+inherit eutils
+
+MY_P=${PN}-${PV/_}
+DESCRIPTION="GNU GPL'd Pico clone with more functionality"
+HOMEPAGE="http://www.nano-editor.org/"
+SRC_URI="http://www.nano-editor.org/dist/v1.3/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~amd64 ~ia64 ~ppc64 ~s390"
+IUSE="nls build spell justify debug slang nomac wsconvert"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ nls? ( sys-devel/gettext )
+ slang? ( sys-libs/slang )"
+PROVIDE="virtual/editor"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ use nomac && epatch ${FILESDIR}/${PV}-nomac.patch
+ use wsconvert && epatch ${FILESDIR}/${PV}-wsconvert.patch
+}
+
+src_compile() {
+ local myconf=""
+ use build && myconf="${myconf} --disable-wrapping-as-root"
+ use ncurses || myconf="${myconf} `use_with slang`"
+
+ econf \
+ --bindir=/bin \
+ --enable-color \
+ --enable-multibuffer \
+ --enable-nanorc \
+ `use_enable justify` \
+ `use_enable spell` \
+ `use_enable debug` \
+ `use_enable nls` \
+ ${myconf} \
+ || die "configure failed"
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ if use build ; then
+ rm -rf ${D}/usr/share
+ else
+ cat ${FILESDIR}/nanorc-* >> doc/nanorc.sample
+ dodoc ChangeLog README doc/nanorc.sample AUTHORS BUGS NEWS TODO
+ dohtml *.html
+ insinto /etc
+ newins doc/nanorc.sample nanorc
+ fi
+
+ dodir /usr/bin
+ dosym ../../bin/nano /usr/bin/nano
+}