summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Marineau <marineam@gentoo.org>2007-08-27 17:19:12 +0000
committerMichael Marineau <marineam@gentoo.org>2007-08-27 17:19:12 +0000
commitef2da7ff76779f7596ff2726815fbb414630ed41 (patch)
tree469ae4327b5632e45f3e0d889e5aed15938b8947 /app-emulation
parentFix shell for the p2p user, bug 189412 (diff)
downloadgentoo-2-ef2da7ff76779f7596ff2726815fbb414630ed41.tar.gz
gentoo-2-ef2da7ff76779f7596ff2726815fbb414630ed41.tar.bz2
gentoo-2-ef2da7ff76779f7596ff2726815fbb414630ed41.zip
Die if both x86 and amd64 are set
(Portage version: 2.1.2.11)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/xen/ChangeLog13
-rw-r--r--app-emulation/xen/xen-3.0.4_p1.ebuild6
-rw-r--r--app-emulation/xen/xen-3.1.0.ebuild6
3 files changed, 20 insertions, 5 deletions
diff --git a/app-emulation/xen/ChangeLog b/app-emulation/xen/ChangeLog
index 668ae18c23c0..afd8cfe69418 100644
--- a/app-emulation/xen/ChangeLog
+++ b/app-emulation/xen/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for app-emulation/xen
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/ChangeLog,v 1.47 2007/07/10 17:01:29 marineam Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/ChangeLog,v 1.48 2007/08/27 17:19:12 marineam Exp $
+
+ 27 Aug 2007; Michael Marineau <marineam@gentoo.org> xen-3.0.4_p1.ebuild,
+ xen-3.1.0.ebuild:
+ Die if both x86 and amd64 are set in USE.
+
+*xen-3.1.0 (24 Aug 2007)
+
+ 24 Aug 2007; Michael Marineau <marineam@gentoo.org>
+ -xen-3.0.2.ebuild, +xen-3.1.0.ebuild:
+ Copy Xen 3.1.0 related ebuilds over from the Xen project overlay.
+ Remove Xen 3.0.2.
10 Jul 2007; Michael Marineau <marineam@gentoo.org> xen-3.0.4_p1.ebuild:
Fix building with --as-needed
diff --git a/app-emulation/xen/xen-3.0.4_p1.ebuild b/app-emulation/xen/xen-3.0.4_p1.ebuild
index d7a42176f0b5..7874fc418765 100644
--- a/app-emulation/xen/xen-3.0.4_p1.ebuild
+++ b/app-emulation/xen/xen-3.0.4_p1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/xen-3.0.4_p1.ebuild,v 1.4 2007/07/10 17:01:29 marineam Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/xen-3.0.4_p1.ebuild,v 1.5 2007/08/27 17:19:12 marineam Exp $
inherit mount-boot flag-o-matic
@@ -27,7 +27,9 @@ QA_WX_LOAD="boot/xen-syms-${MY_PV/_/-}"
pkg_setup() {
if [[ -z ${XEN_TARGET_ARCH} ]]; then
- if use x86; then
+ if use x86 && use amd64; then
+ die "Confusion! Both x86 and amd64 are set in your use flags!"
+ elif use x86; then
export XEN_TARGET_ARCH="x86_32"
elif use amd64; then
export XEN_TARGET_ARCH="x86_64"
diff --git a/app-emulation/xen/xen-3.1.0.ebuild b/app-emulation/xen/xen-3.1.0.ebuild
index 7b0f04236c38..dcc4d72fbaac 100644
--- a/app-emulation/xen/xen-3.1.0.ebuild
+++ b/app-emulation/xen/xen-3.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/xen-3.1.0.ebuild,v 1.1 2007/08/24 23:22:32 marineam Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/xen-3.1.0.ebuild,v 1.2 2007/08/27 17:19:12 marineam Exp $
inherit mount-boot flag-o-matic
@@ -26,7 +26,9 @@ QA_WX_LOAD="boot/xen-syms-${PV}"
pkg_setup() {
if [[ -z ${XEN_TARGET_ARCH} ]]; then
- if use x86; then
+ if use x86 && use amd64; then
+ die "Confusion! Both x86 and amd64 are set in your use flags!"
+ elif use x86; then
export XEN_TARGET_ARCH="x86_32"
elif use amd64; then
export XEN_TARGET_ARCH="x86_64"