summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-07-05 15:54:02 +0000
committerAron Griffis <agriffis@gentoo.org>2004-07-05 15:54:02 +0000
commit9fe271a3724bd0aacd269479e83252e7e6faeff3 (patch)
treef7996f9649387d7ecf109381b9e8b2bd9e62f673 /app-pda/jpilot-backup/jpilot-backup-0.50.ebuild
parentenable raw printing, bug #54981 (Manifest recommit) (diff)
downloadgentoo-2-9fe271a3724bd0aacd269479e83252e7e6faeff3.tar.gz
gentoo-2-9fe271a3724bd0aacd269479e83252e7e6faeff3.tar.bz2
gentoo-2-9fe271a3724bd0aacd269479e83252e7e6faeff3.zip
New ebuild for Jason Day's backup plugin for jpilot
Diffstat (limited to 'app-pda/jpilot-backup/jpilot-backup-0.50.ebuild')
-rw-r--r--app-pda/jpilot-backup/jpilot-backup-0.50.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-pda/jpilot-backup/jpilot-backup-0.50.ebuild b/app-pda/jpilot-backup/jpilot-backup-0.50.ebuild
new file mode 100644
index 000000000000..0e8f56a13b37
--- /dev/null
+++ b/app-pda/jpilot-backup/jpilot-backup-0.50.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/jpilot-backup/jpilot-backup-0.50.ebuild,v 1.1 2004/07/05 15:54:02 agriffis Exp $
+
+DESCRIPTION="Backup plugin for jpilot"
+SRC_URI="http://jasonday.home.att.net/code/backup/${P}.tar.gz"
+HOMEPAGE="http://jasonday.home.att.net/code/backup/backup.html"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~alpha"
+IUSE="nls gtk2"
+
+RDEPEND="gtk2? ( >=x11-libs/gtk+-2 )
+ !gtk2? ( >=x11-libs/gtk+-1.2 )
+ app-pda/jpilot"
+DEPEND="${RDEPEND}
+ gtk2? ( dev-util/pkgconfig )"
+
+src_compile() {
+ econf $(use_enable gtk2) || die "configure failed"
+ emake -j1 || die "make failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die
+}