summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2014-07-02 15:15:17 +0000
committerMark Wright <gienah@gentoo.org>2014-07-02 15:15:17 +0000
commitca973340a14fea658dfb5299a02dffbf65bb0417 (patch)
treeb0a672c691e6452a8725c95b0fbde4d5d0726c5a /dev-haskell
parentAdd data-hash (diff)
downloadgentoo-2-ca973340a14fea658dfb5299a02dffbf65bb0417.tar.gz
gentoo-2-ca973340a14fea658dfb5299a02dffbf65bb0417.tar.bz2
gentoo-2-ca973340a14fea658dfb5299a02dffbf65bb0417.zip
Bump configfile to 1.1.2
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/configfile/ChangeLog10
-rw-r--r--dev-haskell/configfile/configfile-1.1.2.ebuild40
-rw-r--r--dev-haskell/configfile/metadata.xml20
3 files changed, 67 insertions, 3 deletions
diff --git a/dev-haskell/configfile/ChangeLog b/dev-haskell/configfile/ChangeLog
index df5143e9e6f5..471d7c71e92c 100644
--- a/dev-haskell/configfile/ChangeLog
+++ b/dev-haskell/configfile/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/configfile
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/configfile/ChangeLog,v 1.4 2013/07/21 07:43:33 pacho Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/configfile/ChangeLog,v 1.5 2014/07/02 15:15:17 gienah Exp $
+
+*configfile-1.1.2 (02 Jul 2014)
+
+ 02 Jul 2014; Mark Wright <gienah@gentoo.org> +configfile-1.1.2.ebuild,
+ metadata.xml:
+ Bump configfile to 1.1.2
21 Jul 2013; Pacho Ramos <pacho@gentoo.org> -configfile-1.0.6.ebuild:
Remove masked for removal package
diff --git a/dev-haskell/configfile/configfile-1.1.2.ebuild b/dev-haskell/configfile/configfile-1.1.2.ebuild
new file mode 100644
index 000000000000..2f256bd4e1d2
--- /dev/null
+++ b/dev-haskell/configfile/configfile-1.1.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/configfile/configfile-1.1.2.ebuild,v 1.1 2014/07/02 15:15:16 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="ConfigFile"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Configuration file reading & writing"
+HOMEPAGE="http://software.complete.org/configfile"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="buildtests"
+
+RDEPEND=">=dev-haskell/missingh-1.0.0:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/parsec:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ buildtests? ( dev-haskell/hunit:=[profile?]
+ dev-haskell/testpack:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2.3
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag buildtests buildtests)
+}
diff --git a/dev-haskell/configfile/metadata.xml b/dev-haskell/configfile/metadata.xml
index 4005b90f6691..777a155adb21 100644
--- a/dev-haskell/configfile/metadata.xml
+++ b/dev-haskell/configfile/metadata.xml
@@ -1,8 +1,26 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>haskell</herd>
+ <herd>haskell</herd>
<maintainer>
<email>haskell@gentoo.org</email>
</maintainer>
+ <longdescription>
+ Parser and writer for handling sectioned config files in
+ Haskell.
+
+ The ConfigFile module works with configuration files in a standard
+ format that is easy for the user to edit, easy for the programmer
+ to work with, yet remains powerful and flexible. It is inspired by,
+ and compatible with, Python&#39;s ConfigParser module. It uses files
+ that resemble Windows .INI-style files, but with numerous
+ improvements.
+
+ ConfigFile provides simple calls to both read and write config files.
+ It&#39;s possible to make a config file parsable by this module,
+ the Unix shell, and make.
+ </longdescription>
+<use>
+ <flag name='buildtests'>Build the executable to run unit tests.</flag>
+</use>
</pkgmetadata>