summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2014-03-02 14:45:06 +0000
committerTom Wijsman <tomwij@gentoo.org>2014-03-02 14:45:06 +0000
commit3434dead6cfc9ccc895b34a9f17cb2add1aa7e46 (patch)
tree66b388b029daf31c6b8a6bd8e4fe2396bf5a36c0 /dev-java/bcprov
parentfixing deps of multimode without revbump because it either broke build or it ... (diff)
downloadgentoo-2-3434dead6cfc9ccc895b34a9f17cb2add1aa7e46.tar.gz
gentoo-2-3434dead6cfc9ccc895b34a9f17cb2add1aa7e46.tar.bz2
gentoo-2-3434dead6cfc9ccc895b34a9f17cb2add1aa7e46.zip
Make slot for 1.49 to unbreak reverse dependency net-p2p/freenet.
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'dev-java/bcprov')
-rw-r--r--dev-java/bcprov/ChangeLog7
-rw-r--r--dev-java/bcprov/bcprov-1.49-r3.ebuild81
2 files changed, 87 insertions, 1 deletions
diff --git a/dev-java/bcprov/ChangeLog b/dev-java/bcprov/ChangeLog
index cee2936c93d6..db2698a3312f 100644
--- a/dev-java/bcprov/ChangeLog
+++ b/dev-java/bcprov/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/bcprov
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/bcprov/ChangeLog,v 1.59 2014/02/06 13:58:56 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/bcprov/ChangeLog,v 1.60 2014/03/02 14:45:06 tomwij Exp $
+
+*bcprov-1.49-r3 (02 Mar 2014)
+
+ 02 Mar 2014; Tom Wijsman <TomWij@gentoo.org> +bcprov-1.49-r3.ebuild:
+ Make slot for 1.49 to unbreak reverse dependency net-p2p/freenet.
*bcprov-1.50 (06 Feb 2014)
diff --git a/dev-java/bcprov/bcprov-1.49-r3.ebuild b/dev-java/bcprov/bcprov-1.49-r3.ebuild
new file mode 100644
index 000000000000..6822a65ea358
--- /dev/null
+++ b/dev-java/bcprov/bcprov-1.49-r3.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/bcprov/bcprov-1.49-r3.ebuild,v 1.1 2014/03/02 14:45:06 tomwij Exp $
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2
+
+MY_P="${PN}-jdk15on-${PV/./}"
+DESCRIPTION="Java cryptography APIs"
+HOMEPAGE="http://www.bouncycastle.org/java.html"
+SRC_URI="http://www.bouncycastle.org/download/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="1.49"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x64-macos"
+
+# Tests are currently broken. Needs further investigation.
+# java.security.NoSuchAlgorithmException: Cannot find any provider supporting McElieceFujisakiWithSHA256
+RESTRICT="test"
+
+# The src_unpack find needs a new find
+# https://bugs.gentoo.org/show_bug.cgi?id=182276
+DEPEND=">=virtual/jdk-1.5
+ userland_GNU? ( >=sys-apps/findutils-4.3 )
+ app-arch/unzip
+ test? ( dev-java/junit:4 )"
+RDEPEND=">=virtual/jre-1.5"
+
+IUSE="userland_GNU"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ default
+
+ cd "${S}" || die
+ unpack ./src.zip
+}
+
+java_prepare() {
+ mkdir "${S}"/classes || die
+
+ if use test ; then
+ java-pkg_jar-from --build-only junit-4
+ fi
+}
+
+src_compile() {
+ find . -name "*.java" > "${T}"/src.list
+
+ local cp
+ if use test ; then
+ cp="-cp junit.jar"
+ else
+ sed -i '/\/test\//d' "${T}"/src.list || die "Failed to remove test classes"
+ fi
+
+ ejavac $cp -encoding ISO-8859-1 -d "${S}"/classes "@${T}"/src.list
+
+ cd "${S}"/classes || die
+
+ jar -cf "${S}"/${PN}.jar * || die "Failed to create jar."
+}
+
+src_test() {
+ java -cp ${PN}.jar:junit.jar org.bouncycastle.pqc.jcajce.provider.test.AllTests | tee pqc.tests
+ java -cp ${PN}.jar:junit.jar org.bouncycastle.ocsp.test.AllTests | tee oscp.tests
+ java -cp ${PN}.jar:junit.jar org.bouncycastle.jce.provider.test.AllTests | tee jce.tests
+
+ grep -q FAILURES *.tests && die "Tests failed."
+}
+
+src_install() {
+ java-pkg_dojar ${PN}.jar
+
+ use source && java-pkg_dosrc org
+ use doc && java-pkg_dojavadoc docs
+}