summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2011-09-06 09:57:09 +0000
committerVlastimil Babka <caster@gentoo.org>2011-09-06 09:57:09 +0000
commitea9d46e04c8554569bc209ca9df995727eb6b180 (patch)
tree1e98584b6836b61e27aa6babf524784414c3e7c2 /dev-java/icedtea-web
parentVersion bump (diff)
downloadgentoo-2-ea9d46e04c8554569bc209ca9df995727eb6b180.tar.gz
gentoo-2-ea9d46e04c8554569bc209ca9df995727eb6b180.tar.bz2
gentoo-2-ea9d46e04c8554569bc209ca9df995727eb6b180.zip
Version bump. Support building against npapi-sdk instead of xulrunner, bug #381957. Also remove xulrunner from RDEPEND in all older versions, bug #381147.
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'dev-java/icedtea-web')
-rw-r--r--dev-java/icedtea-web/ChangeLog10
-rw-r--r--dev-java/icedtea-web/icedtea-web-1.1.1.ebuild6
-rw-r--r--dev-java/icedtea-web/icedtea-web-1.1.2.ebuild (renamed from dev-java/icedtea-web/icedtea-web-1.1.ebuild)36
3 files changed, 37 insertions, 15 deletions
diff --git a/dev-java/icedtea-web/ChangeLog b/dev-java/icedtea-web/ChangeLog
index e4a2e8d88d62..a1f03cacae95 100644
--- a/dev-java/icedtea-web/ChangeLog
+++ b/dev-java/icedtea-web/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-java/icedtea-web
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea-web/ChangeLog,v 1.7 2011/07/22 09:08:37 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea-web/ChangeLog,v 1.8 2011/09/06 09:57:09 caster Exp $
+
+*icedtea-web-1.1.2 (06 Sep 2011)
+
+ 06 Sep 2011; Vlastimil Babka <caster@gentoo.org> -icedtea-web-1.1.ebuild,
+ icedtea-web-1.1.1.ebuild, +icedtea-web-1.1.2.ebuild:
+ Version bump. Support building against npapi-sdk instead of xulrunner, bug
+ #381957. Also remove xulrunner from RDEPEND in all older versions, bug
+ #381147.
*icedtea-web-1.1.1 (22 Jul 2011)
diff --git a/dev-java/icedtea-web/icedtea-web-1.1.1.ebuild b/dev-java/icedtea-web/icedtea-web-1.1.1.ebuild
index a9fe3110aaab..e68dac07c5e6 100644
--- a/dev-java/icedtea-web/icedtea-web-1.1.1.ebuild
+++ b/dev-java/icedtea-web/icedtea-web-1.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea-web/icedtea-web-1.1.1.ebuild,v 1.1 2011/07/22 09:08:37 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea-web/icedtea-web-1.1.1.ebuild,v 1.2 2011/09/06 09:57:09 caster Exp $
# Build written by Andrew John Hughes (ahughes@redhat.com)
EAPI="2"
@@ -17,9 +17,9 @@ HOMEPAGE="http://icedtea.classpath.org"
IUSE="build doc +nsplugin"
-RDEPEND="dev-java/icedtea:${SLOT}
+RDEPEND="dev-java/icedtea:${SLOT}"
+DEPEND="${RDEPEND}
nsplugin? ( >=net-libs/xulrunner-1.9.1 )"
-DEPEND="${RDEPEND}"
# a bit of hack so the VM switching is triggered without causing dependency troubles
JAVA_PKG_NV_DEPEND=">=virtual/jdk-1.6"
diff --git a/dev-java/icedtea-web/icedtea-web-1.1.ebuild b/dev-java/icedtea-web/icedtea-web-1.1.2.ebuild
index 6ebc9fa2fe63..3b54b93cd9ed 100644
--- a/dev-java/icedtea-web/icedtea-web-1.1.ebuild
+++ b/dev-java/icedtea-web/icedtea-web-1.1.2.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea-web/icedtea-web-1.1.ebuild,v 1.2 2011/06/20 12:34:46 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea-web/icedtea-web-1.1.2.ebuild,v 1.1 2011/09/06 09:57:09 caster Exp $
# Build written by Andrew John Hughes (ahughes@redhat.com)
EAPI="2"
-inherit eutils java-pkg-2 java-vm-2
+inherit autotools eutils java-pkg-2 java-vm-2
LICENSE="GPL-2 GPL-2-with-linking-exception LGPL-2"
SLOT="6"
@@ -15,11 +15,13 @@ DESCRIPTION="FOSS Java browser plugin and Web Start implementation"
SRC_URI="http://icedtea.classpath.org/download/source/${P}.tar.gz"
HOMEPAGE="http://icedtea.classpath.org"
-IUSE="doc +nsplugin"
+IUSE="build doc +nsplugin"
-RDEPEND="dev-java/icedtea:${SLOT}
- nsplugin? ( >=net-libs/xulrunner-1.9.1 )"
-DEPEND="${RDEPEND}"
+RDEPEND="dev-java/icedtea:${SLOT}"
+DEPEND="${RDEPEND}
+ nsplugin? (
+ || ( net-misc/npapi-sdk
+ >=net-libs/xulrunner-1.9.1 ) )"
# a bit of hack so the VM switching is triggered without causing dependency troubles
JAVA_PKG_NV_DEPEND=">=virtual/jdk-1.6"
@@ -60,20 +62,32 @@ src_unpack() {
default
}
+src_prepare() {
+ epatch "${FILESDIR}"/0001-Support-using-NPAPI-SDK-headers-instead-of-whole-xul.patch
+ eautoreconf
+}
+
src_configure() {
local vmhome=$(java-config -O)
- icedteadir="/usr/$(get_libdir)/icedtea${SLOT}"
+
+ if use build; then
+ icedteadir="${ICEDTEA_BIN_DIR}"
+ installdir="/opt/icedtea${SLOT}-web-bin"
+ else
+ icedteadir="/usr/$(get_libdir)/icedtea${SLOT}"
+ installdir="/usr/$(get_libdir)/icedtea${SLOT}-web"
+ fi
unset_vars
- if [[ ${vmhome} == ${icedteadir} ]] ; then
- installdir="/usr/$(get_libdir)/icedtea${SLOT}-web"
+ if use build || [[ ${vmhome} == ${icedteadir} ]] ; then
VMHANDLE="icedtea${SLOT}"
else
die "Unexpected install location of IcedTea${SLOT}"
fi
- elog "Installing IcedTea-Web in ${installdir}"
+ einfo "Installing IcedTea-Web in ${installdir}"
+ einfo "Installing IcedTea-Web for Icedtea${SLOT} in ${icedteadir}"
if [ ! -e ${vmhome} ] ; then
eerror "Could not find JDK install directory ${vmhome}."
die
@@ -84,7 +98,7 @@ src_configure() {
# the suffix the man page will end up compressed with, anyway
econf \
--prefix=${installdir} --mandir=${icedteadir}/man --infodir=${installdir}/share/info --datadir=${installdir}/share \
- --with-jdk-home=${vmhome} \
+ --with-jdk-home=${icedteadir} \
$(use_enable doc docs) \
$(use_enable nsplugin plugin) \
|| die "configure failed"