summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2010-05-13 21:13:34 +0000
committerMatti Bickel <mabi@gentoo.org>2010-05-13 21:13:34 +0000
commita1233cd687c5966c2102ae09f1d761254293ff6a (patch)
tree634ea75027e90f3285923a08f129a28f60f31985 /dev-java/sun-j2me-bin
parentsun-j2me-bin requires x86 java (now with correct atom string) (diff)
downloadgentoo-2-a1233cd687c5966c2102ae09f1d761254293ff6a.tar.gz
gentoo-2-a1233cd687c5966c2102ae09f1d761254293ff6a.tar.bz2
gentoo-2-a1233cd687c5966c2102ae09f1d761254293ff6a.zip
bump
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-java/sun-j2me-bin')
-rw-r--r--dev-java/sun-j2me-bin/ChangeLog10
-rw-r--r--dev-java/sun-j2me-bin/files/java-config.patch101
-rw-r--r--dev-java/sun-j2me-bin/sun-j2me-bin-2.5.2.01.ebuild109
3 files changed, 218 insertions, 2 deletions
diff --git a/dev-java/sun-j2me-bin/ChangeLog b/dev-java/sun-j2me-bin/ChangeLog
index 552218755133..c68964a01f4a 100644
--- a/dev-java/sun-j2me-bin/ChangeLog
+++ b/dev-java/sun-j2me-bin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/sun-j2me-bin
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-j2me-bin/ChangeLog,v 1.10 2009/11/25 09:55:53 maekke Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-j2me-bin/ChangeLog,v 1.11 2010/05/13 21:13:34 mabi Exp $
+
+*sun-j2me-bin-2.5.2.01 (13 May 2010)
+
+ 13 May 2010; <mabi@gentoo.org> +sun-j2me-bin-2.5.2.01.ebuild,
+ +files/java-config.patch:
+ bump (bug #209396), thanks to Ciprian Ciubotariu et.al.
25 Nov 2009; Markus Meier <maekke@gentoo.org> sun-j2me-bin-2.2-r3.ebuild:
amd64 stable, bug #284298
diff --git a/dev-java/sun-j2me-bin/files/java-config.patch b/dev-java/sun-j2me-bin/files/java-config.patch
new file mode 100644
index 000000000000..6905b9fc207d
--- /dev/null
+++ b/dev-java/sun-j2me-bin/files/java-config.patch
@@ -0,0 +1,101 @@
+--- bin/ktoolbar 2008-02-08 19:49:45.000000000 +0100
++++ bin/ktoolbar 2008-02-08 20:19:57.000000000 +0100
+@@ -1,6 +1,10 @@
+ #!/bin/sh
+
+-javapathtowtk=`java-config --jdk-home`"/bin/"
++if [ "`uname -m`" = "x86_64" ]; then
++ javapathtowtk=`java-config --select-vm=emul-linux-x86-java --jdk-home`"/bin/"
++else
++ javapathtowtk=`java-config --jdk-home`"/bin/"
++fi
+
+ PRG=$0
+
+--- bin/prefs 2008-02-08 19:49:45.000000000 +0100
++++ bin/prefs 2008-02-08 20:19:57.000000000 +0100
+@@ -1,6 +1,10 @@
+ #!/bin/sh
+
+-javapathtowtk=`java-config --jdk-home`"/bin/"
++if [ "`uname -m`" = "x86_64" ]; then
++ javapathtowtk=`java-config --select-vm=emul-linux-x86-java --jdk-home`"/bin/"
++else
++ javapathtowtk=`java-config --jdk-home`"/bin/"
++fi
+
+ PRG=$0
+
+--- bin/utils 2008-02-08 19:49:45.000000000 +0100
++++ bin/utils 2008-02-08 20:19:57.000000000 +0100
+@@ -1,6 +1,10 @@
+ #!/bin/sh
+
+-javapathtowtk=`java-config --jdk-home`"/bin/"
++if [ "`uname -m`" = "x86_64" ]; then
++ javapathtowtk=`java-config --select-vm=emul-linux-x86-java --jdk-home`"/bin/"
++else
++ javapathtowtk=`java-config --jdk-home`"/bin/"
++fi
+
+ PRG=$0
+
+--- bin/wscompile 2008-02-08 19:49:45.000000000 +0100
++++ bin/wscompile 2008-02-08 20:19:57.000000000 +0100
+@@ -1,6 +1,10 @@
+ #!/bin/sh
+
+-javapathtowtk=`java-config --jdk-home`"/bin/"
++if [ "`uname -m`" = "x86_64" ]; then
++ javapathtowtk=`java-config --select-vm=emul-linux-x86-java --jdk-home`"/bin/"
++else
++ javapathtowtk=`java-config --jdk-home`"/bin/"
++fi
+
+ PRG=$0
+
+
+--- bin/mekeytool 2008-02-08 19:49:45.000000000 +0100
++++ bin/mekeytool 2008-02-08 20:19:57.000000000 +0100
+@@ -1,6 +1,10 @@
+ #!/bin/sh
+
+-javapathtowtk=`java-config --jdk-home`"/bin/"
++if [ "`uname -m`" = "x86_64" ]; then
++ javapathtowtk=`java-config --select-vm=emul-linux-x86-java --jdk-home`"/bin/"
++else
++ javapathtowtk=`java-config --jdk-home`"/bin/"
++fi
+
+ PRG=$0
+
+--- bin/emulator 2008-02-08 19:49:45.000000000 +0100
++++ bin/emulator 2008-02-08 20:19:57.000000000 +0100
+@@ -1,6 +1,10 @@
+ #!/bin/sh
+
+-javapathtowtk=`java-config --jdk-home`"/bin/"
++if [ "`uname -m`" = "x86_64" ]; then
++ javapathtowtk=`java-config --select-vm=emul-linux-x86-java --jdk-home`"/bin/"
++else
++ javapathtowtk=`java-config --jdk-home`"/bin/"
++fi
+
+ PRG=$0
+
+
+--- bin/defaultdevice 2008-02-08 19:49:45.000000000 +0100
++++ bin/defaultdevice 2008-02-08 20:19:57.000000000 +0100
+@@ -1,6 +1,10 @@
+ #!/bin/sh
+
+-javapathtowtk=`java-config --jdk-home`"/bin/"
++if [ "`uname -m`" = "x86_64" ]; then
++ javapathtowtk=`java-config --select-vm=emul-linux-x86-java --jdk-home`"/bin/"
++else
++ javapathtowtk=`java-config --jdk-home`"/bin/"
++fi
+
+ PRG=$0
+
+
diff --git a/dev-java/sun-j2me-bin/sun-j2me-bin-2.5.2.01.ebuild b/dev-java/sun-j2me-bin/sun-j2me-bin-2.5.2.01.ebuild
new file mode 100644
index 000000000000..940b3105a611
--- /dev/null
+++ b/dev-java/sun-j2me-bin/sun-j2me-bin-2.5.2.01.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-j2me-bin/sun-j2me-bin-2.5.2.01.ebuild,v 1.1 2010/05/13 21:13:34 mabi Exp $
+
+inherit java-pkg-2
+
+DESCRIPTION="Java 2 Micro Edition Wireless Toolkit for developing wireless applications"
+HOMEPAGE="http://java.sun.com/products/j2mewtoolkit/"
+
+DOWNLOAD_URL="http://java.sun.com/products/sjwtoolkit/download.html"
+BINARY="sun_java_wireless_toolkit-2.5.2_01-linuxi486.bin.sh"
+
+SRC_URI="${BINARY}"
+LICENSE="sun-bcla-j2me"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+RESTRICT="fetch"
+
+COMMON_DEP="
+ dev-java/sun-jaf
+ dev-java/sun-javamail
+ dev-java/xsdlib"
+RDEPEND="${COMMON_DEP}
+ >=virtual/jdk-1.4.2
+ amd64? ( app-emulation/emul-linux-x86-java )"
+DEPEND="${COMMON_DEP}
+ app-arch/unzip"
+
+S=${WORKDIR}
+
+MY_FILE=${DISTDIR}/${BINARY}
+
+pkg_nofetch() {
+
+ einfo "Please navigate your browser to"
+ einfo "${DOWNLOAD_URL}"
+ einfo "scroll down and notice the download button."
+ einfo "Click the Download button for J2ME Wireless Toolkit 2.5.2"
+ einfo "and download ${BINARY}"
+ einfo "Put this file to ${DISTDIR} and resume the installation"
+
+}
+
+src_unpack() {
+
+ if [[ ! -r ${MY_FILE} ]]; then
+
+ eerror "cannot read ${A}. Please check the permission and try again."
+ die
+
+ fi
+
+ #extract compressed data and unpack
+ ebegin "Unpacking ${BINARY}"
+ dd bs=2048 if=${MY_FILE} of=install.zip skip=13 2>/dev/null || die
+ unzip install.zip >/dev/null || die
+ eend $?
+ rm install.zip
+
+ #Set the java-bin-path in some scripts
+ for file in ktoolbar emulator mekeytool prefs utils wscompile defaultdevice; do
+ sed -i -e \
+ "s@pathtowtk=\$@pathtowtk=\`java-config --jdk-home\`\"/bin/\"@" \
+ "${WORKDIR}/bin/${file}" || die
+ done
+
+ cd "${S}/bin"
+ rm -f activation.jar mail.jar xsdlib.jar
+
+}
+
+src_compile() {
+ epatch "${FILESDIR}/java-config.patch"
+}
+
+src_install() {
+
+ local DIR=/opt/${P}
+ cd "${WORKDIR}"
+
+ einfo "Copying files"
+ dodir ${DIR}
+ cp -r j2mewtk_template bin lib wtklib "${D}/${DIR}"
+ use examples && cp -r apps "${D}/${DIR}"
+
+ einfo "Setting permissions"
+ chmod 755 "${D}/${DIR}/bin/"* || die
+ chmod 644 "${D}/${DIR}/bin/"*.jar || die
+
+ einfo "Installing documentation"
+ dohtml *.html
+ use doc && java-pkg_dohtml -r docs/*
+
+ cd "${D}/${DIR}/bin"
+ java-pkg_jar-from sun-jaf activation.jar
+ java-pkg_jar-from sun-javamail mail.jar
+ java-pkg_jar-from xsdlib xsdlib.jar
+
+ einfo "Registering jar files"
+ # The zip files are somehow broken and python zip handling errors on them
+ JAVA_PKG_STRICT= java-pkg_regjar \
+ "${D}${DIR}/lib/"*.jar \
+ "${D}${DIR}/wtklib/kenv.zip" \
+ "${D}${DIR}/wtklib/"*.jar
+
+ dodir /usr/bin
+ dosym "${DIR}/bin/ktoolbar" /usr/bin/ktoolbar
+}