summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2011-05-11 23:27:04 +0000
committerMichael Weber <xmw@gentoo.org>2011-05-11 23:27:04 +0000
commita5f094aa3d3b671c564c4fb7392a0bf59f212890 (patch)
tree89b96038f8daaf6544860461d6fcd21bf3b95612 /dev-libs/libsqlora8
parentadded ~amd64 keyword (diff)
downloadgentoo-2-a5f094aa3d3b671c564c4fb7392a0bf59f212890.tar.gz
gentoo-2-a5f094aa3d3b671c564c4fb7392a0bf59f212890.tar.bz2
gentoo-2-a5f094aa3d3b671c564c4fb7392a0bf59f212890.zip
Version bump
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libsqlora8')
-rw-r--r--dev-libs/libsqlora8/ChangeLog9
-rw-r--r--dev-libs/libsqlora8/libsqlora8-2.3.3.ebuild62
2 files changed, 69 insertions, 2 deletions
diff --git a/dev-libs/libsqlora8/ChangeLog b/dev-libs/libsqlora8/ChangeLog
index eb0c999b486d..c93f31d6a62b 100644
--- a/dev-libs/libsqlora8/ChangeLog
+++ b/dev-libs/libsqlora8/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libsqlora8
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsqlora8/ChangeLog,v 1.8 2008/08/06 10:04:34 ulm Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsqlora8/ChangeLog,v 1.9 2011/05/11 23:27:04 xmw Exp $
+
+*libsqlora8-2.3.3 (11 May 2011)
+
+ 11 May 2011; Michael Weber <xmw@gentoo.org> +libsqlora8-2.3.3.ebuild:
+ Version bump, thanks to Eckard Brauer for the hint (bug 186461)
06 Aug 2008; Ulrich Mueller <ulm@gentoo.org> metadata.xml:
Add USE flag description to metadata wrt GLEP 56.
diff --git a/dev-libs/libsqlora8/libsqlora8-2.3.3.ebuild b/dev-libs/libsqlora8/libsqlora8-2.3.3.ebuild
new file mode 100644
index 000000000000..277a27208ccd
--- /dev/null
+++ b/dev-libs/libsqlora8/libsqlora8-2.3.3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsqlora8/libsqlora8-2.3.3.ebuild,v 1.1 2011/05/11 23:27:04 xmw Exp $
+
+IUSE="threads orathreads"
+
+DESCRIPTION="libsqlora8 is a simple C-library to access Oracle databases via the OCI interface"
+SRC_URI="http://www.poitschke.de/libsqlora8/${P}.tar.gz"
+HOMEPAGE="http://www.poitschke.de/libsqlora8/index_noframe.html"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND=""
+
+pkg_setup() {
+ if use orathreads && use threads; then
+ eerror
+ eerror 'Enable the "threads" USE flag for POSIX threads,'
+ eerror '*or* the "orathreads" USE flag for Oracle threads'
+ eerror
+ die 'Both "threads" and "orathreads" USE flags set, see above'
+ fi
+
+ # Make sure ORACLE_HOME is set
+ if [ -z "${ORACLE_HOME}" ]; then
+ eerror
+ eerror 'libsqlora8 requires that the ORACLE_HOME environment variable be set.'
+ eerror 'Try: "export ORACLE_HOME=/usr/local/oracle" if you do not know what to do.'
+ eerror
+ die 'ORACLE_HOME not set, see above'
+ fi
+}
+
+src_compile() {
+ local myconf;
+
+ # Add $ORACLE_HOME/lib to LD_LIBRARY_PATH
+ if [ -z "${LD_LIBRARY_PATH}" ]; then
+ LD_LIBRARY_PATH=${ORACLE_HOME}/lib
+ else
+ LD_LIBRARY_PATH=${ORACLE_HOME}/lib:${LD_LIBRARY_PATH}
+ fi
+
+ export LD_LIBRARY_PATH
+
+ use threads && myconf="--with-threads=posix"
+ use orathreads && myconf="--with-threads=oracle"
+
+ # Build
+ econf ${myconf} || die "configure failed"
+ emake
+}
+
+src_install () {
+ einstall
+ dodoc COPYING ChangeLog INSTALL NEWS NEWS-2.2
+
+ # TODO
+ # Copy contents of doc and examples directory to doc
+}