summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2003-12-21 06:02:37 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2003-12-21 06:02:37 +0000
commit58b869ed2460c4c993fe7443fba716ccc591a7af (patch)
tree7e03f18087adbf481638fb966c566aa03cae1944 /dev-lisp/xlispstat
parent*** empty log message *** (diff)
downloadgentoo-2-58b869ed2460c4c993fe7443fba716ccc591a7af.tar.gz
gentoo-2-58b869ed2460c4c993fe7443fba716ccc591a7af.tar.bz2
gentoo-2-58b869ed2460c4c993fe7443fba716ccc591a7af.zip
*** empty log message ***
Diffstat (limited to 'dev-lisp/xlispstat')
-rw-r--r--dev-lisp/xlispstat/ChangeLog9
-rw-r--r--dev-lisp/xlispstat/Manifest7
-rw-r--r--dev-lisp/xlispstat/files/digest-xlispstat-3.52.201
-rw-r--r--dev-lisp/xlispstat/metadata.xml5
-rw-r--r--dev-lisp/xlispstat/xlispstat-3.52.20.ebuild34
5 files changed, 52 insertions, 4 deletions
diff --git a/dev-lisp/xlispstat/ChangeLog b/dev-lisp/xlispstat/ChangeLog
new file mode 100644
index 000000000000..6114877e5a8f
--- /dev/null
+++ b/dev-lisp/xlispstat/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-lisp/xlispstat
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/xlispstat/ChangeLog,v 1.1 2003/12/21 06:02:30 mkennedy Exp $
+
+*xlispstat-3.52.20 (20 Dec 2003)
+
+ 20 Dec 2003; <mkennedy@gentoo.org> metadata.xml, xlispstat-3.52.20.ebuild:
+ initial import. ebuild contributed by Matthew Kennedy <mkennedy@gentoo.org>
+
diff --git a/dev-lisp/xlispstat/Manifest b/dev-lisp/xlispstat/Manifest
index c67c8aa106b0..4d9b9be37fb9 100644
--- a/dev-lisp/xlispstat/Manifest
+++ b/dev-lisp/xlispstat/Manifest
@@ -1,5 +1,4 @@
-MD5 125ee013081b112d56a1d15507d72ef2 skel.ChangeLog 3674
-MD5 a4de292547a7d4fbe157a4ecb4ce2193 skel.metadata.xml 821
-MD5 a06c762785c8c7751eddfbf358406a11 xlispstat-3.52.20.ebuild 2733
-MD5 652f011c07ca925858993d5f54bc1f06 xlispstat-3.52.20.ebuild~ 6006
+MD5 885733bc3770f1885f3b8f52a97fd894 xlispstat-3.52.20.ebuild 1054
+MD5 9b65b0341efc8f4b29498aad23315229 metadata.xml 164
+MD5 a00450772978444662db0a1bfe49dd76 ChangeLog 411
MD5 5a05689a66ffe0bedddb5d275bdc4f4a files/digest-xlispstat-3.52.20 70
diff --git a/dev-lisp/xlispstat/files/digest-xlispstat-3.52.20 b/dev-lisp/xlispstat/files/digest-xlispstat-3.52.20
new file mode 100644
index 000000000000..c54635d83397
--- /dev/null
+++ b/dev-lisp/xlispstat/files/digest-xlispstat-3.52.20
@@ -0,0 +1 @@
+MD5 93ec54218aaa450f0909e4a3ba22e08f xlispstat-3-52-20.tar.gz 1527951
diff --git a/dev-lisp/xlispstat/metadata.xml b/dev-lisp/xlispstat/metadata.xml
new file mode 100644
index 000000000000..f418045b09c8
--- /dev/null
+++ b/dev-lisp/xlispstat/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>common-lisp</herd>
+</pkgmetadata>
diff --git a/dev-lisp/xlispstat/xlispstat-3.52.20.ebuild b/dev-lisp/xlispstat/xlispstat-3.52.20.ebuild
new file mode 100644
index 000000000000..3a9c89aae3c5
--- /dev/null
+++ b/dev-lisp/xlispstat/xlispstat-3.52.20.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/xlispstat/xlispstat-3.52.20.ebuild,v 1.1 2003/12/21 06:02:30 mkennedy Exp $
+
+DESCRIPTION="XLISP-STAT is a statistical environment based on a dialect of the Lisp language called XLISP."
+HOMEPAGE="http://www.stat.uiowa.edu/~luke/xls/xlsinfo/xlsinfo.html"
+SRC_URI="ftp://ftp.stat.umn.edu/pub/xlispstat/current/xlispstat-${PV//./-}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="X"
+DEPEND="X? ( virtual/x11 )"
+
+S=${WORKDIR}/${P//./-}
+
+src_compile() {
+ local opts=''
+ use X && opts='--with-x' || opts='--without-x'
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ ${opts} || die "./configure failed"
+ make UCFLAGS="${CFLAGS} -mieee-fp" || die
+}
+
+src_install() {
+ dodir /usr/bin
+ dodir /usr/lib/xlispstat
+ make prefix=${D}/usr/ install || die
+ dodoc COPYING INSTALL README* RELEASE
+ dodoc doc/xlispins.doc doc/xlispdoc.{ps,txt}
+}