summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2007-12-17 17:41:16 +0000
committerAlexis Ballier <aballier@gentoo.org>2007-12-17 17:41:16 +0000
commitfb0685ed7f286c81256e8e50db8b21504b2c1e56 (patch)
tree955522f5cd68be2974f6f07c65ed86b748c3bbdc /dev-ml
parentamd64 stable (diff)
downloadgentoo-2-fb0685ed7f286c81256e8e50db8b21504b2c1e56.tar.gz
gentoo-2-fb0685ed7f286c81256e8e50db8b21504b2c1e56.tar.bz2
gentoo-2-fb0685ed7f286c81256e8e50db8b21504b2c1e56.zip
Version bump, featuring findlib support, thanks Daniel
(Portage version: 2.1.4_rc10)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/camlp5/ChangeLog7
-rw-r--r--dev-ml/camlp5/camlp5-5.05.ebuild38
-rw-r--r--dev-ml/camlp5/files/digest-camlp5-5.053
3 files changed, 47 insertions, 1 deletions
diff --git a/dev-ml/camlp5/ChangeLog b/dev-ml/camlp5/ChangeLog
index 225703f9d995..8fe1ada1929a 100644
--- a/dev-ml/camlp5/ChangeLog
+++ b/dev-ml/camlp5/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/camlp5
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlp5/ChangeLog,v 1.10 2007/11/27 20:10:26 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlp5/ChangeLog,v 1.11 2007/12/17 17:41:15 aballier Exp $
+
+*camlp5-5.05 (17 Dec 2007)
+
+ 17 Dec 2007; Alexis Ballier <aballier@gentoo.org> +camlp5-5.05.ebuild:
+ Version bump, featuring findlib support, thanks Daniel
*camlp5-5.04 (27 Nov 2007)
diff --git a/dev-ml/camlp5/camlp5-5.05.ebuild b/dev-ml/camlp5/camlp5-5.05.ebuild
new file mode 100644
index 000000000000..58e0bb49de63
--- /dev/null
+++ b/dev-ml/camlp5/camlp5-5.05.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlp5/camlp5-5.05.ebuild,v 1.1 2007/12/17 17:41:15 aballier Exp $
+
+inherit multilib findlib
+
+DESCRIPTION="A preprocessor-pretty-printer of ocaml"
+HOMEPAGE="http://pauillac.inria.fr/~ddr/camlp5/"
+SRC_URI="http://pauillac.inria.fr/~ddr/camlp5/distrib/src/${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="doc"
+
+DEPEND=">=dev-lang/ocaml-3.09"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ ./configure \
+ -prefix /usr \
+ -bindir /usr/bin \
+ -libdir /usr/$(get_libdir)/ocaml \
+ -mandir /usr/share/man || die "configure failed"
+
+ emake -j1 world.opt || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ # findlib support
+ insinto "$(ocamlfind printconf destdir)/${PN}"
+ doins etc/META || die "failed to install META file for findlib support"
+
+ use doc && dohtml -r doc/*
+
+ dodoc CHANGES DEVEL ICHANGES README UPGRADING MODE
+}
diff --git a/dev-ml/camlp5/files/digest-camlp5-5.05 b/dev-ml/camlp5/files/digest-camlp5-5.05
new file mode 100644
index 000000000000..44ca069b9ed2
--- /dev/null
+++ b/dev-ml/camlp5/files/digest-camlp5-5.05
@@ -0,0 +1,3 @@
+MD5 03ad5c2a8a4547940f7fbf38915f934e camlp5-5.05.tgz 623925
+RMD160 c58f48c3d0e2e88bafeb19347fb392047127edbd camlp5-5.05.tgz 623925
+SHA256 1155de64044711828b7af55cd30c3b3fa8ddec3b1365a1ad41c3787eaf655628 camlp5-5.05.tgz 623925