summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2010-09-13 06:11:52 +0000
committerTorsten Veller <tove@gentoo.org>2010-09-13 06:11:52 +0000
commit7e7624032cb5a4b9788692f1c7ef1e435c8a3fa0 (patch)
tree6047d76d1a72075a3f83db534837e522d5cbe63a /dev-perl/WWW-Mechanize
parentVersion bump (diff)
downloadgentoo-2-7e7624032cb5a4b9788692f1c7ef1e435c8a3fa0.tar.gz
gentoo-2-7e7624032cb5a4b9788692f1c7ef1e435c8a3fa0.tar.bz2
gentoo-2-7e7624032cb5a4b9788692f1c7ef1e435c8a3fa0.zip
Version bump
(Portage version: 2.2_rc80/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl/WWW-Mechanize')
-rw-r--r--dev-perl/WWW-Mechanize/ChangeLog7
-rw-r--r--dev-perl/WWW-Mechanize/WWW-Mechanize-1.66.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-perl/WWW-Mechanize/ChangeLog b/dev-perl/WWW-Mechanize/ChangeLog
index 4df3e4f5f8bc..5315b41c01a8 100644
--- a/dev-perl/WWW-Mechanize/ChangeLog
+++ b/dev-perl/WWW-Mechanize/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/WWW-Mechanize
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/WWW-Mechanize/ChangeLog,v 1.70 2010/08/10 15:37:20 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/WWW-Mechanize/ChangeLog,v 1.71 2010/09/13 06:11:52 tove Exp $
+
+*WWW-Mechanize-1.66 (13 Sep 2010)
+
+ 13 Sep 2010; Torsten Veller <tove@gentoo.org> +WWW-Mechanize-1.66.ebuild:
+ Version bump
*WWW-Mechanize-1.64 (10 Aug 2010)
diff --git a/dev-perl/WWW-Mechanize/WWW-Mechanize-1.66.ebuild b/dev-perl/WWW-Mechanize/WWW-Mechanize-1.66.ebuild
new file mode 100644
index 000000000000..7b74ab0172d2
--- /dev/null
+++ b/dev-perl/WWW-Mechanize/WWW-Mechanize-1.66.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/WWW-Mechanize/WWW-Mechanize-1.66.ebuild,v 1.1 2010/09/13 06:11:52 tove Exp $
+
+EAPI=2
+
+MODULE_AUTHOR=PETDANCE
+inherit perl-module
+
+DESCRIPTION="Handy web browsing in a Perl object"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="test"
+
+# Bug in the tests - improper use of HTTP::Server
+SRC_TEST="do"
+
+# configure to run the local tests, but not the ones which access the Internet
+myconf="--local --nolive"
+
+RDEPEND="dev-perl/IO-Socket-SSL
+ >=dev-perl/libwww-perl-5.829
+ >=dev-perl/URI-1.36
+ >=dev-perl/HTML-Parser-3.34
+ dev-perl/Test-LongString"
+DEPEND="${RDEPEND}
+ test? ( dev-perl/PadWalker
+ dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage
+ dev-perl/Test-Exception
+ dev-perl/Test-NoWarnings
+ dev-perl/Test-Taint
+ >=dev-perl/Test-Warn-0.11
+ dev-perl/Test-Memory-Cycle )"
+# dev-perl/HTTP-Server-Simple )"
+
+# Remove test until the bug is fixed:
+# http://rt.cpan.org/Public/Bug/Display.html?id=41673
+src_prepare() {
+ mv "${S}"/t/cookies.t{,.disable} || die
+ sed -i "/cookies.t/d" "${S}/MANIFEST" || die
+ perl-module_src_prepare
+}