summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2003-02-18 20:30:22 +0000
committerRyan Phillips <rphillips@gentoo.org>2003-02-18 20:30:22 +0000
commit3a7144c2dbbdcd4e7b1ff9d50a67b0381a07f7a0 (patch)
treed6bd97821994af97fee59f1f70554c15e7441343 /dev-php
parentUpdate get_number_of_jobs for ARM; consolidate MIPS block. (diff)
downloadgentoo-2-3a7144c2dbbdcd4e7b1ff9d50a67b0381a07f7a0.tar.gz
gentoo-2-3a7144c2dbbdcd4e7b1ff9d50a67b0381a07f7a0.tar.bz2
gentoo-2-3a7144c2dbbdcd4e7b1ff9d50a67b0381a07f7a0.zip
GLSA fix
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/mod_php/ChangeLog7
-rw-r--r--dev-php/mod_php/files/digest-mod_php-4.3.11
-rw-r--r--dev-php/mod_php/mod_php-4.3.1.ebuild290
-rw-r--r--dev-php/php/ChangeLog7
-rw-r--r--dev-php/php/files/digest-php-4.3.11
-rw-r--r--dev-php/php/php-4.3.1.ebuild262
6 files changed, 566 insertions, 2 deletions
diff --git a/dev-php/mod_php/ChangeLog b/dev-php/mod_php/ChangeLog
index 331bc2cf2129..caa8c8f13f05 100644
--- a/dev-php/mod_php/ChangeLog
+++ b/dev-php/mod_php/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php/mod_php
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/ChangeLog,v 1.47 2003/02/12 06:29:37 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/ChangeLog,v 1.48 2003/02/18 20:27:03 rphillips Exp $
+
+*mod_php-4.3.1 (18 Feb 2003)
+
+ 18 Feb 2003; Ryan Phillips <rphillips@gentoo.org> mod_php-4.3.1.ebuild :
+ Security Fix
*mod_php-4.3.0-r2 (10 Jan 2003)
diff --git a/dev-php/mod_php/files/digest-mod_php-4.3.1 b/dev-php/mod_php/files/digest-mod_php-4.3.1
new file mode 100644
index 000000000000..da8da7df7d9d
--- /dev/null
+++ b/dev-php/mod_php/files/digest-mod_php-4.3.1
@@ -0,0 +1 @@
+MD5 bbfe584acb3549c62bb61355165e2ca6 php-4.3.1.tar.bz2 3682417
diff --git a/dev-php/mod_php/mod_php-4.3.1.ebuild b/dev-php/mod_php/mod_php-4.3.1.ebuild
new file mode 100644
index 000000000000..af797bdfb46b
--- /dev/null
+++ b/dev-php/mod_php/mod_php-4.3.1.ebuild
@@ -0,0 +1,290 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/mod_php-4.3.1.ebuild,v 1.1 2003/02/18 20:27:03 rphillips Exp $
+
+inherit flag-o-matic
+
+IUSE="png apache2 truetype postgres tiff libwww nls jpeg ssl oci8 mysql X gdbm curl imap xml2 xml cjk pdflib qt snmp crypt flash odbc ldap berkdb freetds firebird pam"
+
+MY_P=php-${PV}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Apache module for PHP"
+SRC_URI="http://us3.php.net/distributions/${MY_P}.tar.bz2"
+HOMEPAGE="http://www.php.net/"
+LICENSE="PHP"
+KEYWORDS="x86 sparc ppc alpha"
+SLOT="0"
+PROVIDE="virtual/php"
+
+#fixes bug #14067
+replace-flags "-march=k6*" "-march=i586"
+
+ # users have been having problems with compiling the gmp support... disabled for now
+ # - rphillips
+ #>=dev-libs/gmp-3.1.1
+
+DEPEND="
+ >=net-www/apache-1.3.26-r2
+ apache2? ( >=net-www/apache-2.0.43-r1 )
+ truetype? ( ~media-libs/freetype-1.3.1 >=media-libs/t1lib-1.3.1 )
+ jpeg? ( >=media-libs/jpeg-6b )
+ tiff? ( >=media-libs/tiff-3.5.5 )
+ X? ( virtual/x11 )
+ png? ( >=media-libs/libpng-1.2.5 )
+ qt? ( x11-libs/qt )
+ nls? ( sys-devel/gettext )
+ pam? ( >=sys-libs/pam-0.75 )
+ xml? ( >=net-libs/libwww-5.3.2 >=app-text/sablotron-0.96 )
+ ssl? ( >=dev-libs/openssl-0.9.5 )
+ curl? ( >=net-ftp/curl-7.10.2 )
+ snmp? ( >=net-analyzer/ucd-snmp-4.2.3 )
+ imap? ( >=net-mail/uw-imap-2001a-r1 )
+ gdbm? ( >=sys-libs/gdbm-1.8.0 )
+ ldap? ( >=net-nds/openldap-1.2.11 )
+ odbc? ( >=dev-db/unixODBC-1.8.13 )
+ xml2? ( dev-libs/libxml2 )
+ crypt? ( >=dev-libs/libmcrypt-2.4
+ >=app-crypt/mhash-0.8 )
+ mysql? ( >=dev-db/mysql-3.23.26 )
+ freetds? ( >=dev-db/freetds-0.53 )
+ flash? ( media-libs/libswf >=media-libs/ming-0.2a )
+ berkdb? ( >=sys-libs/db-3 )
+ libwww? ( >=net-libs/libwww-5.3.2 )
+ firebird? ( >=dev-db/firebird-1.0 )
+ pdflib? ( >=media-libs/pdflib-4.0.1-r2 )
+ postgres? ( >=dev-db/postgresql-7.1 )"
+ #java? ( virtual/jdk )
+# Only needed by CGI-Version
+# readline? ( >=sys-libs/ncurses-5.1
+# >=sys-libs/readline-4.1 )"
+
+RDEPEND="
+ xml? ( >=app-text/sablotron-0.95-r1 )
+ qt? ( >=x11-libs/qt-2.3.0 )"
+
+src_unpack() {
+ unpack ${MY_P}.tar.bz2
+ cd ${S}
+
+ # Configure Patch for wired uname -a
+ mv configure configure.old
+ cat configure.old | sed "s/PHP_UNAME=\`uname -a\`/PHP_UNAME=\`uname -s -n -r -v\`/g" > configure
+ chmod 755 configure
+
+ # fix PEAR installer
+ cp pear/PEAR/Registry.php pear/PEAR/Registry.old
+ sed "s:\$pear_install_dir\.:\'$D/usr/lib/php/\' . :g" pear/PEAR/Registry.old > pear/PEAR/Registry.php
+
+ #if [ "`use java`" ] ; then
+
+ # cp configure configure.orig
+ # cat configure.orig | \
+ # sed -e 's/LIBS="-lttf $LIBS"/LIBS="-lttf $LIBS"/' \
+ # > configure
+
+ # cp ext/gd/gd.c ext/gd/gd.c.orig
+ # cat ext/gd/gd.c.orig | \
+ # sed -e "s/typedef FILE gdIOCtx;//" \
+ # > ext/gd/gd.c
+ # if [ "$JAVAC" ];
+ # then
+ # cp ext/java/Makefile.in ext/java/Makefile.in.orig
+ # cat ext/java/Makefile.in.orig | \
+ # sed -e "s/^\tjavac/\t\$(JAVAC)/" \
+ # > ext/java/Makefile.in
+ # fi
+ #fi
+
+}
+
+src_compile() {
+
+ local myconf
+
+ # readline can only be used w/ CGI build, so I'll turn it off
+ #if [ "`use readline`" ] ; then
+ # myconf="--with-readline"
+ #fi
+
+ myconf="--without-readline "
+ use pam && myconf="${myconf} --with-pam"
+ use nls && myconf="${myconf} --with-gettext" || myconf="${myconf} --without-gettext"
+ use ssl && myconf="${myconf} --with-openssl"
+ use curl && myconf="${myconf} --with-curl"
+ use snmp && myconf="${myconf} --with-snmp --enable-ucd-snmp-hack"
+ use cjk && myconf="${myconf} --enable-mbstring --enable-mbregex"
+ use gdbm && myconf="${myconf} --with-gdbm=/usr"
+ use berkdb && myconf="${myconf} --with-db3=/usr"
+ use mysql && myconf="${myconf} --with-mysql=/usr" || myconf="${myconf} --without-mysql"
+ use freetds && myconf="${myconf} --with-sybase=/usr"
+ use postgres && myconf="${myconf} --with-pgsql=/usr"
+ use odbc && myconf="${myconf} --with-unixODBC=/usr"
+ use ldap && myconf="${myconf} --with-ldap"
+ use firebird && myconf="${myconf} --with-interbase=/opt/interbase"
+ use truetype && myconf="${myconf} --with-ttf --with-t1lib"
+ use pdflib && myconf="${myconf} --with-pdflib=/usr"
+ use jpeg && myconf="${myconf} --with-jpeg-dir=/usr/lib"
+ use tiff && myconf="${myconf} --with-tiff-dir=/usr"
+
+ if [ "`use png`" ] ; then
+ myconf="${myconf} --with-png-dir=/usr/lib"
+ fi
+
+ # And zlib, but we need to know if the user wants it - Quequero
+ if [ "`use zlib`" ] ; then
+ myconf="${myconf} --with-zlib"
+ myconf="${myconf} --with-zlib-dir=/usr/lib"
+ fi
+
+ # optional support for apache2
+ myconf="${myconf} --with-exec-dir=/usr/bin"
+ if [ "`use apache2`" ] ; then
+ myconf="${myconf} --with-apxs2=/usr/sbin/apxs2"
+ else
+ myconf="${myconf} --with-apxs=/usr/sbin/apxs"
+ fi
+
+
+ # optional support for oracle oci8
+ if [ "`use oci8`" ] ; then
+ if [ "$ORACLE_HOME" ] ; then
+ myconf="${myconf} --with-oci8=${ORACLE_HOME}"
+ fi
+ fi
+
+ use qt && ( \
+ export QTDIR=/usr/qt/2 #hope this helps - danarmak
+ myconf="${myconf} --with-qtdom"
+ )
+
+ if [ "`use imap`" ] ; then
+ if [ "`use ssl`" ] && [ "`strings ${ROOT}/usr/lib/c-client.a \
+ | grep ssl_onceonlyinit`" ] ; then
+ echo "Compiling imap with SSL support"
+ myconf="${myconf} --with-imap --with-imap-ssl"
+ else
+ echo "Compiling imap without SSL support"
+ myconf="${myconf} --with-imap"
+ fi
+ fi
+ use libwww && myconf="${myconf} --with-xml" || myconf="${myconf} --disable-xml"
+ use flash && myconf="${myconf} --with-swf=/usr --with-ming=/usr"
+
+ if [ "`use xml`" ] ; then
+ export LIBS="-lxmlparse -lxmltok"
+ myconf="${myconf} --with-sablot=/usr"
+ myconf="${myconf} --enable-xslt"
+ myconf="${myconf} --with-xslt-sablot"
+ myconf="${myconf} --with-xmlrpc"
+ fi
+
+ use xml2 && myconf="${myconf} --with-dom"
+ use crypt && myconf="${myconf} --with-mcrypt --with-mhash --disable-posix-threads"
+ #use java && myconf="${myconf} --with-java=${JDK_HOME}"
+
+ LDFLAGS="$LDFLAGS -ltiff -ljpeg"
+
+ if [ "`use X`" ] ; then
+ myconf="${myconf} --with-xpm-dir=/usr/X11R6"
+ LDFLAGS="$LDFLAGS -L/usr/X11R6/lib"
+ fi
+
+ # this needed moving to prevent b0rkage
+ # --with-gmp \
+
+ ./configure \
+ --prefix=/usr \
+ --with-bz2 \
+ --enable-ftp \
+ --enable-force-cgi-redirect \
+ --enable-discard-path \
+ --enable-gd-native-ttf \
+ --enable-mime-magic \
+ --enable-wddx \
+ --enable-dbase \
+ --with-zlib=yes \
+ --with-iconv \
+ --enable-bcmath \
+ --enable-sysvsem \
+ --enable-exif \
+ --with-gd \
+ --enable-sysvshm \
+ --enable-sockets \
+ --enable-calendar \
+ --enable-trans-sid \
+ --enable-safe-mode \
+ --enable-versioning \
+ --enable-track-vars \
+ --enable-inline-optimization \
+ --with-config-file-path=/etc/php4 \
+ --host=${CHOST} ${myconf} || die "bad ./configure"
+
+ make || die "compile problem"
+}
+
+
+src_install() {
+ addwrite /usr/share/snmp/mibs/.index
+
+ make INSTALL_ROOT=${D} install-pear install-headers install-programs || die
+
+ dodoc CODING_STANDARDS LICENSE EXTENSIONS
+ dodoc README.* TODO NEWS
+
+ cp php.ini-dist php.ini
+ insinto /etc/php4
+ doins php.ini
+ dosym /usr/lib/apache-extramodules /etc/php4/lib
+
+ #install scripts
+ exeinto /usr/bin
+ doexe ${S}/pear/scripts/phpize
+ doexe ${S}/pear/scripts/php-config
+ doexe ${S}/pear/scripts/phpextdist
+ doexe ${S}/ext/ext_skel
+
+
+ #revert Pear patch
+ rm ${D}/usr/lib/php/PEAR/Registry.php
+ mv ${S}/pear/PEAR/Registry.old ${D}/usr/lib/php/PEAR/Registry.php
+
+ if [ "`use apache2`" ] ; then
+ exeinto /usr/lib/apache2-extramodules
+ doexe .libs/libphp4.so
+ insinto /etc/apache2/conf/modules.d
+ doins ${FILESDIR}/70_mod_php.conf
+ dosym /etc/php4/php.ini /etc/apache2/conf/php.ini
+ else
+ exeinto /usr/lib/apache-extramodules
+ doexe .libs/libphp4.so
+ insinto /etc/apache/conf/addon-modules
+ doins ${FILESDIR}/mod_php.conf
+ dosym /etc/php4/php.ini /etc/apache/conf/php.ini
+ dosym /etc/php4/php.ini /etc/apache/conf/addon-modules/php.ini
+ fi
+}
+
+pkg_postinst() {
+ einfo
+ einfo "To have Apache run php programs, please do the following:"
+ if [ "`use apache2`" ] ; then
+ einfo "Edit /etc/conf.d/apache2 and add \"-D PHP4\""
+ einfo
+ einfo "Please note Apache 2 support in php is currently experimental"
+ else
+ einfo "1. Execute the command:"
+ einfo " \"ebuild /var/db/pkg/dev-php/${PF}/${PF}.ebuild config\""
+ einfo "2. Edit /etc/conf.d/apache and add \"-D PHP\""
+ einfo
+ einfo "That will include the php mime types in your configuration"
+ einfo "automagically and setup Apache to load php when it starts."
+ fi
+}
+
+pkg_config() {
+ ${ROOT}/usr/sbin/apacheaddmod \
+ ${ROOT}/etc/apache/conf/apache.conf \
+ extramodules/libphp4.so mod_php4.c php4_module \
+ before=perl define=PHP4 addconf=conf/addon-modules/mod_php.conf
+ :;
+}
diff --git a/dev-php/php/ChangeLog b/dev-php/php/ChangeLog
index 4ff71f0f4a52..7c5ce4f7e360 100644
--- a/dev-php/php/ChangeLog
+++ b/dev-php/php/ChangeLog
@@ -1,12 +1,17 @@
# ChangeLog for dev-php/php
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/php/ChangeLog,v 1.33 2003/02/14 21:40:22 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/php/ChangeLog,v 1.34 2003/02/18 20:30:22 rphillips Exp $
13 Jan 2003; Daniel Ahlberg <aliz@genoto.org> php-4.3.0-r2.ebuild :
Added ppc and sparc keyword becuse this is a security update.
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
+*php-4.3.1 (18 Feb 2003)
+
+ 18 Feb 2003; Ryan Phillips <rphillips@gentoo.org> php-4.3.1.ebuild:
+ GLSA fix
+
*php-4.3.0-r4 (13 Feb 2003)
14 Feb 2003; Ryan Phillips <rphillips@gentoo.org> php-4.3.0-r4.ebuild :
diff --git a/dev-php/php/files/digest-php-4.3.1 b/dev-php/php/files/digest-php-4.3.1
new file mode 100644
index 000000000000..da8da7df7d9d
--- /dev/null
+++ b/dev-php/php/files/digest-php-4.3.1
@@ -0,0 +1 @@
+MD5 bbfe584acb3549c62bb61355165e2ca6 php-4.3.1.tar.bz2 3682417
diff --git a/dev-php/php/php-4.3.1.ebuild b/dev-php/php/php-4.3.1.ebuild
new file mode 100644
index 000000000000..4c633a02a266
--- /dev/null
+++ b/dev-php/php/php-4.3.1.ebuild
@@ -0,0 +1,262 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Update: Roman Weber <gentoo@gonzo.ch>
+# $Header: /var/cvsroot/gentoo-x86/dev-php/php/php-4.3.1.ebuild,v 1.1 2003/02/18 20:30:22 rphillips Exp $
+
+IUSE="truetype postgres tiff libwww nls jpeg readline ssl oci8 mysql X gdbm curl imap xml2 xml cjk pdflib qt snmp crypt flash odbc ldap berkdb freetds firebird pam"
+
+MY_P=php-${PV}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="PHP Shell Interpreter"
+SRC_URI="http://us3.php.net/distributions/${MY_P}.tar.bz2"
+HOMEPAGE="http://www.php.net/"
+LICENSE="PHP"
+SLOT="0"
+PROVIDE="virtual/php"
+KEYWORDS="x86 ppc sparc"
+
+ # too many users not being able to compile with gmp support
+ # - rphillips
+ # >=dev-libs/gmp-3.1.1
+
+DEPEND="
+ truetype? ( ~media-libs/freetype-1.3.1 >=media-libs/t1lib-1.3.1 )
+ jpeg? ( >=media-libs/jpeg-6b )
+ tiff? ( >=media-libs/tiff-3.5.5 )
+ X? ( virtual/x11 )
+ qt? ( x11-libs/qt )
+ nls? ( sys-devel/gettext )
+ pam? ( >=sys-libs/pam-0.75 )
+ xml? ( >=net-libs/libwww-5.3.2 >=app-text/sablotron-0.95-r1 )
+ ssl? ( >=dev-libs/openssl-0.9.5 )
+ curl? ( >=net-ftp/curl-7.8.1 )
+ snmp? ( >=net-analyzer/ucd-snmp-4.2.3 )
+ imap? ( >=net-mail/uw-imap-2001a-r1 )
+ gdbm? ( >=sys-libs/gdbm-1.8.0 )
+ ldap? ( >=net-nds/openldap-1.2.11 )
+ odbc? ( >=dev-db/unixODBC-1.8.13 )
+ xml2? ( dev-libs/libxml2 )
+ crypt? ( >=dev-libs/libmcrypt-2.4 >=app-crypt/mhash-0.8 )
+ mysql? ( >=dev-db/mysql-3.23.26 )
+ freetds? ( >=dev-db/freetds-0.53 )
+ flash? ( media-libs/libswf >=media-libs/ming-0.2a )
+ berkdb? ( >=sys-libs/db-3 )
+ libwww? ( >=net-libs/libwww-5.3.2 )
+ firebird? ( >=dev-db/firebird-1.0 )
+ pdflib? ( >=media-libs/pdflib-4.0.1-r2 )
+ postgres? ( >=dev-db/postgresql-7.1 )
+ readline? ( >=sys-libs/ncurses-5.1
+ >=sys-libs/readline-4.1 )
+ java? ( virtual/jdk )"
+
+#Removed
+#java? ( virtual/jdk )
+
+RDEPEND="
+ xml? ( >=app-text/sablotron-0.95-r1 >=net-libs/libwww-5.3.2 )
+ qt? ( >=x11-libs/qt-2.3.0 )
+ java? ( virtual/jdk )"
+
+src_unpack() {
+ unpack ${MY_P}.tar.bz2
+ cd ${S}
+
+ # Configure Patch for wired uname -a
+ mv configure configure.old
+ cat configure.old | sed "s/PHP_UNAME=\`uname -a\`/PHP_UNAME=\`uname -s -n -r -v\`/g" > configure
+ chmod 755 configure
+
+ # fix PEAR installer
+ cp pear/PEAR/Registry.php pear/PEAR/Registry.old
+ sed "s:\$pear_install_dir\.:\'$D/usr/lib/php/\' . :g" pear/PEAR/Registry.old > pear/PEAR/Registry.php
+
+ # if [ "`use java`" ] ; then
+
+ # cp configure configure.orig
+ # cat configure.orig | \
+ # sed -e 's/LIBS="-lttf $LIBS"/LIBS="-lttf $LIBS"/' \
+ # > configure
+
+ # cp ext/gd/gd.c ext/gd/gd.c.orig
+ # cat ext/gd/gd.c.orig | \
+ # sed -e "s/typedef FILE gdIOCtx;//" \
+ # > ext/gd/gd.c
+ # if [ "$JAVAC" ];
+ # then
+ # cp ext/java/Makefile.in ext/java/Makefile.in.orig
+ # cat ext/java/Makefile.in.orig | \
+ # sed -e "s/^\tjavac/\t\$(JAVAC)/" \
+ # > ext/java/Makefile.in
+ # fi
+ # fi
+}
+
+src_compile() {
+
+ local myconf
+
+ use readline && myconf="${myconf} --with-readline"
+ use nls && myconf="${myconf} --with-gettext" || myconf="${myconf} --without-gettext"
+ use ssl && myconf="${myconf} --with-openssl"
+ use cjk && myconf="${myconf} --enable-mbstring"
+ use curl && myconf="${myconf} --with-curl"
+ use snmp && myconf="${myconf} --with-snmp --enable-ucd-snmp-hack"
+ use gdbm && myconf="${myconf} --with-gdbm=/usr"
+ use berkdb && myconf="${myconf} --with-db3=/usr"
+ use mysql && myconf="${myconf} --with-mysql=/usr" || myconf="${myconf} --without-mysql"
+ use freetds && myconf="${myconf} --with-sybase=/usr"
+ use postgres && myconf="${myconf} --with-pgsql=/usr"
+ use odbc && myconf="${myconf} --with-unixODBC=/usr"
+ use ldap && myconf="${myconf} --with-ldap"
+ use firebird && myconf="${myconf} --with-interbase=/opt/interbase"
+ use truetype && myconf="${myconf} --with-ttf --with-t1lib"
+ use pdflib && myconf="${myconf} --enable-pdflib=/usr"
+ use jpeg && myconf="${myconf} --with-jpeg-dir=/usr/lib" || myconf="${myconf} --without-jpeg"
+ use tiff && myconf="${myconf} --with-tiff-dir=/usr" || myconf="${myconf} --without-tiff"
+ use png || myconf="${myconf} --without-png"
+
+ # optional support for oracle oci8
+ if [ "`use oci8`" ] ; then
+ if [ "$ORACLE_HOME" ] ; then
+ myconf="${myconf} --with-oci8=${ORACLE_HOME}"
+ fi
+ fi
+
+ use qt && ( \
+ export QTDIR=/usr/qt/2 #hope this helps - danarmak
+ myconf="${myconf} --with-qtdom"
+ )
+
+ if [ "`use imap`" ] ; then
+ if [ "`use ssl`" ] && [ "`strings ${ROOT}/usr/lib/c-client.a \
+ | grep ssl_onceonlyinit`" ] ; then
+ echo "Compiling imap with SSL support"
+ myconf="${myconf} --with-imap --with-imap-ssl"
+ else
+ echo "Compiling imap without SSL support"
+ myconf="${myconf} --with-imap"
+ fi
+ fi
+ use libwww && myconf="${myconf} --with-xml" || myconf="${myconf} --disable-xml"
+ use flash && myconf="${myconf} --with-swf=/usr --with-ming=/usr"
+
+ if [ "`use xml`" ] ; then
+ export LIBS="-lxmlparse -lxmltok"
+ myconf="${myconf} --enable-xslt"
+ myconf="${myconf} --with-xslt-sablot=/usr"
+ myconf="${myconf} --with-xmlrpc"
+ fi
+
+ use xml2 && myconf="${myconf} --with-dom"
+ use crypt && myconf="${myconf} --enable-mcrypt=/usr --with-mhash"
+ use java && myconf="${myconf} --with-java=${JDK_HOME}"
+
+ LDFLAGS="$LDFLAGS -ltiff -ljpeg"
+
+ if [ "`use X`" ] ; then
+ myconf="${myconf} --with-xpm-dir=/usr/X11R6"
+ LDFLAGS="$LDFLAGS -L/usr/X11R6/lib"
+ fi
+ # --with-gmp \
+
+ ./configure \
+ --prefix=/usr \
+ --with-bz2 \
+ --enable-ftp \
+ --enable-dbase \
+ --with-zlib=yes \
+ --enable-bcmath \
+ --enable-sysvsem \
+ --enable-sysvshm \
+ --with-gd \
+ --enable-sockets \
+ --enable-pcntl \
+ --enable-cli \
+ --disable-cgi \
+ --enable-calendar \
+ --enable-trans-sid \
+ --enable-versioning \
+ --enable-track-vars \
+ --enable-inline-optimization \
+ --with-config-file-path=/etc/php4 \
+ --with-pear \
+ --host=${CHOST} ${myconf} || die "bad ./configure"
+
+ make || die "compile problem"
+}
+
+
+src_install() {
+ addwrite /usr/share/snmp/mibs/.index
+
+ make INSTALL_ROOT=${D} install-cli install-pear install-headers install-programs install-modules || die
+
+ dodoc CODING_STANDARDS LICENSE EXTENSIONS
+ dodoc RELEASE_PROCESS README.* TODO NEWS
+ dodoc ChangeLog* *.txt
+
+ # php executable is located in ./sapi/cli/
+ cp sapi/cli/php .
+ exeinto /usr/bin
+ doexe php
+
+ #install scripts
+ exeinto /usr/bin
+ doexe ${S}/pear/scripts/phpize
+ doexe ${S}/pear/scripts/php-config
+ doexe ${S}/pear/scripts/phpextdist
+
+ # Support for Java extension
+ #
+ # 1. install php_java.jar file into /etc/php4/lib directory
+ # 2. edit the php.ini file ready for installation
+ #
+ # - stuart@gnqs.org
+
+ if [ "`use java`" ] ; then
+
+ # we put these into /usr/lib so that they cannot conflict
+ # with other versions of PHP
+
+ insinto /usr/lib/php/extensions/no-debug-non-zts-20020429
+ doins ext/java/php_java.jar
+
+ cp ext/java/except.php java-test.php
+ doins java-test.php
+
+ JAVA_LIBRARY="`grep -- '-DJAVALIB' Makefile | sed -e 's/.\+-DJAVALIB=\"\([^"]*\)\".*$/\1/g;'`"
+ cat php.ini-dist | sed -e "s|;java.library .*$|java.library = $JAVA_LIBRARY|g;" > php.ini-1
+ cat php.ini-1 | sed -e "s|;java.class.path .*$|java.class.path = /etc/php4/lib/php_java.jar|g;" > php.ini-2
+ cat php.ini-2 | sed -e "s|extension_dir .*$|extension_dir = /etc/php4/lib|g;" > php.ini-3
+ cat php.ini-3 | sed -e "s|;extension=php_java.dll.*$|extension = java.so|g;" > php.ini-4
+ cat php.ini-4 | sed -e "s|;java.library.path .*$|java.library.path = /etc/php4/lib/|g;" > php.ini-5
+
+ mv php.ini-5 php.ini
+ else
+ mv php.ini-dist php.ini
+ fi
+
+ insinto /etc/php4
+ doins php.ini
+
+ if [ "`use java`" ]; then
+ # I can't find a way to make these symlinks using dosym
+ # SLH - 20030211
+
+ ( cd ${D}/usr/lib/php/extensions/no-debug-non-zts-20020429 ; ln -snf java.so libphp_java.so )
+ ( cd ${D}/etc/php4 ; ln -snf ../../usr/lib/php/extensions/no-debug-non-zts-20020429 lib )
+ fi
+
+}
+
+pkg_postinst() {
+ # This fixes the permission from world writeable to the correct one.
+ # - novell@kiruna.se
+ chmod 755 /usr/bin/pear
+
+ # This is more correct information.
+ einfo
+ einfo "This is a CLI only build."
+ einfo "You can not use it on a webserver."
+ einfo
+}