summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-06-24 06:40:12 +0000
committerIan Delaney <idella4@gentoo.org>2013-06-24 06:40:12 +0000
commit32ecf1649f36ce98e24cdb190075e6179b9cfca6 (patch)
tree3165ad5b10d8824e33f96fb9b64c75c29a629a4d /dev-python/ipaddr
parentStable for ppc, wrt bug #471692 (diff)
downloadgentoo-2-32ecf1649f36ce98e24cdb190075e6179b9cfca6.tar.gz
gentoo-2-32ecf1649f36ce98e24cdb190075e6179b9cfca6.tar.bz2
gentoo-2-32ecf1649f36ce98e24cdb190075e6179b9cfca6.zip
revbump; migrate -> distutils-r1
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/ipaddr')
-rw-r--r--dev-python/ipaddr/ChangeLog7
-rw-r--r--dev-python/ipaddr/ipaddr-2.1.9-r1.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/dev-python/ipaddr/ChangeLog b/dev-python/ipaddr/ChangeLog
index 91735276d218..8aa14edd823e 100644
--- a/dev-python/ipaddr/ChangeLog
+++ b/dev-python/ipaddr/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/ipaddr
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/ipaddr/ChangeLog,v 1.8 2013/02/24 12:22:30 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ipaddr/ChangeLog,v 1.9 2013/06/24 06:40:12 idella4 Exp $
+
+*ipaddr-2.1.9-r1 (24 Jun 2013)
+
+ 24 Jun 2013; Ian Delaney <idella4@gentoo.org> +ipaddr-2.1.9-r1.ebuild:
+ revbump; migrate -> distutils-r1
24 Feb 2013; Michał Górny <mgorny@gentoo.org> ipaddr-2.1.10-r1.ebuild:
Remove redundant 'cd' call.
diff --git a/dev-python/ipaddr/ipaddr-2.1.9-r1.ebuild b/dev-python/ipaddr/ipaddr-2.1.9-r1.ebuild
new file mode 100644
index 000000000000..75f86afaa28f
--- /dev/null
+++ b/dev-python/ipaddr/ipaddr-2.1.9-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ipaddr/ipaddr-2.1.9-r1.ebuild,v 1.1 2013/06/24 06:40:12 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2,3_3} pypy2_0 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python IP address manipulation library"
+HOMEPAGE="http://code.google.com/p/ipaddr-py/ http://pypi.python.org/pypi/ipaddr"
+SRC_URI="http://ipaddr-py.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND=""
+RDEPEND=""
+
+DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
+DOCS=( README RELEASENOTES )
+
+python_prepare_all() {
+ use test && DISTUTILS_IN_SOURCE_BUILD=1
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ pushd "${BUILD_DIR}"/../ &> /dev/null
+ if [[ "${EPYTHON}" == python3* ]]; then
+ 2to3 -nw --no-diffs ipaddr.py ipaddr_test.py
+ fi
+ "${PYTHON}" ipaddr_test.py || die "Tests failed under ${EPYTHON}"
+}