summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-01-07 07:25:27 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-01-07 07:25:27 +0000
commitaaf817c33404f8c8d064036ba2081aedb98196df (patch)
treec308de294979e9764de478a8a30ef8895df164f4 /dev-python/weasyprint
parentversion bumps for subversion-1.8.5. Fix RDEPEND, svn upgrade handling. (diff)
downloadgentoo-2-aaf817c33404f8c8d064036ba2081aedb98196df.tar.gz
gentoo-2-aaf817c33404f8c8d064036ba2081aedb98196df.tar.bz2
gentoo-2-aaf817c33404f8c8d064036ba2081aedb98196df.zip
Bump
(Portage version: 2.2.8/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/weasyprint')
-rw-r--r--dev-python/weasyprint/ChangeLog9
-rw-r--r--dev-python/weasyprint/weasyprint-0.20.2.ebuild34
2 files changed, 41 insertions, 2 deletions
diff --git a/dev-python/weasyprint/ChangeLog b/dev-python/weasyprint/ChangeLog
index b3f63f103965..b82a3be5563a 100644
--- a/dev-python/weasyprint/ChangeLog
+++ b/dev-python/weasyprint/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/weasyprint
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/weasyprint/ChangeLog,v 1.4 2013/12/17 06:33:10 patrick Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/weasyprint/ChangeLog,v 1.5 2014/01/07 07:25:27 patrick Exp $
+
+*weasyprint-0.20.2 (07 Jan 2014)
+
+ 07 Jan 2014; Patrick Lauer <patrick@gentoo.org> +weasyprint-0.20.2.ebuild:
+ Bump
*weasyprint-0.20 (17 Dec 2013)
diff --git a/dev-python/weasyprint/weasyprint-0.20.2.ebuild b/dev-python/weasyprint/weasyprint-0.20.2.ebuild
new file mode 100644
index 000000000000..1a6fe78392fe
--- /dev/null
+++ b/dev-python/weasyprint/weasyprint-0.20.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/weasyprint/weasyprint-0.20.2.ebuild,v 1.1 2014/01/07 07:25:27 patrick Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_2,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Visual rendering engine for HTML and CSS that can export to PDF."
+MY_PN="WeasyPrint"
+MY_P="${MY_PN}-${PV}"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+HOMEPAGE="http://weasyprint.org"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="x11-libs/cairo
+ x11-libs/pango
+ media-gfx/cairosvg
+ dev-python/cffi[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/cairocffi[${PYTHON_USEDEP}]
+ dev-python/tinycss[${PYTHON_USEDEP}]
+ dev-python/cssselect[${PYTHON_USEDEP}]
+ dev-python/pyphen[${PYTHON_USEDEP}]
+ "
+ # x11-libs/gdk-pixbuf # optional dep
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"