summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-10-05 10:34:05 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-10-05 10:34:05 +0000
commit6cd73be9ae9527458c83a93c46cf73262d1cf4e2 (patch)
tree39a2f6783dff07323ad4aac4a7321267ff04e39f /dev-ruby/libxml
parentAdd ruby20 target. (diff)
downloadgentoo-2-6cd73be9ae9527458c83a93c46cf73262d1cf4e2.tar.gz
gentoo-2-6cd73be9ae9527458c83a93c46cf73262d1cf4e2.tar.bz2
gentoo-2-6cd73be9ae9527458c83a93c46cf73262d1cf4e2.zip
Add ruby20 target.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/libxml')
-rw-r--r--dev-ruby/libxml/ChangeLog7
-rw-r--r--dev-ruby/libxml/libxml-2.7.0-r1.ebuild71
2 files changed, 77 insertions, 1 deletions
diff --git a/dev-ruby/libxml/ChangeLog b/dev-ruby/libxml/ChangeLog
index 5339642a2b9b..844d1a754d65 100644
--- a/dev-ruby/libxml/ChangeLog
+++ b/dev-ruby/libxml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/libxml
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/libxml/ChangeLog,v 1.85 2013/08/08 15:43:48 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/libxml/ChangeLog,v 1.86 2013/10/05 10:34:05 mrueg Exp $
+
+*libxml-2.7.0-r1 (05 Oct 2013)
+
+ 05 Oct 2013; Manuel Rüger <mrueg@gentoo.org> +libxml-2.7.0-r1.ebuild:
+ Add ruby20 target.
*libxml-2.7.0 (08 Aug 2013)
diff --git a/dev-ruby/libxml/libxml-2.7.0-r1.ebuild b/dev-ruby/libxml/libxml-2.7.0-r1.ebuild
new file mode 100644
index 000000000000..8cbcdcf6cf50
--- /dev/null
+++ b/dev-ruby/libxml/libxml-2.7.0-r1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/libxml/libxml-2.7.0-r1.ebuild,v 1.1 2013/10/05 10:34:05 mrueg Exp $
+
+EAPI=5
+
+USE_RUBY="ruby18 ruby19 ruby20"
+
+RUBY_FAKEGEM_NAME="libxml-ruby"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc HISTORY"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby libxml with a user friendly API, akin to REXML, but feature complete and significantly faster."
+HOMEPAGE="https://github.com/xml4r/libxml-ruby"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="${RDEPEND} dev-libs/libxml2"
+DEPEND="${DEPEND} dev-libs/libxml2"
+
+ruby_add_bdepend "doc? ( dev-ruby/rdoc )"
+
+all_ruby_prepare() {
+ # Remove grancher tasks only needed for publishing the website
+ sed -i -e '/grancher/d' -e '/Grancher/,$d' Rakefile || die
+
+ # We don't have the hanna template available.
+ sed -i -e 's/hanna/rake/' Rakefile || die
+
+ # Remove rake-compiler bits since we don't use it
+ sed -i -e '/extensiontask/d' -e '/ExtensionTask/,/end/d' -e '/GemPackageTask/,/end/d' Rakefile || die
+
+ # replace ulimit -n output as it does not work with Ruby 1.9
+ sed -i -e 's:`ulimit -n`:"'`ulimit -n`'":' test/tc_parser.rb || die
+
+ # Avoid test failing due to different semantics in libxml 2.8.
+ # https://github.com/xml4r/libxml-ruby/issues/43
+ sed -i -e '/test_invalid_encoding/,/^ end/ s:^:#:' test/tc_reader.rb || die
+
+ # Ignore two test failures on ruby18 for now given that older
+ # versions no longer compile.
+ sed -i -e '/test_schema_type/,/end/ s:^:#:' \
+ -e '/test_schema_element/,/end/ s:^:#:' test/tc_schema.rb || die
+
+ # Remove the pregenerated extconf.h. It should not be included, but
+ # it also confuses our hardlink-based duplication scheme.
+ rm ext/libxml/extconf.h || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -C ext/libxml extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -C ext/libxml V=1
+ cp ext/libxml/libxml_ruby.so lib/ || die
+}
+
+each_ruby_test() {
+ # The test suite needs to load its files in alphabetical order but
+ # this is not guaranteed. See bug 370501.
+ ${RUBY} -Ilib -r ./test/test_helper.rb test/test_suite.rb || die
+}