summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-12-13 00:57:51 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-12-13 00:57:51 +0000
commit0cca407e7f3db618544647f8dfb662221aa64ea4 (patch)
tree5885b9d54a66aa630d240f0205bc288b70527501 /dev-ruby/pg
parentautomatically create a tarball of all config.log files when we fail, and tell... (diff)
downloadgentoo-2-0cca407e7f3db618544647f8dfb662221aa64ea4.tar.gz
gentoo-2-0cca407e7f3db618544647f8dfb662221aa64ea4.tar.bz2
gentoo-2-0cca407e7f3db618544647f8dfb662221aa64ea4.zip
Version bump.
(Portage version: 2.2.0_alpha80/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/pg')
-rw-r--r--dev-ruby/pg/ChangeLog7
-rw-r--r--dev-ruby/pg/pg-0.12.0.ebuild60
2 files changed, 66 insertions, 1 deletions
diff --git a/dev-ruby/pg/ChangeLog b/dev-ruby/pg/ChangeLog
index c1164a58db8f..97028099824d 100644
--- a/dev-ruby/pg/ChangeLog
+++ b/dev-ruby/pg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/pg
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pg/ChangeLog,v 1.40 2011/11/27 15:17:11 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pg/ChangeLog,v 1.41 2011/12/13 00:57:51 flameeyes Exp $
+
+*pg-0.12.0 (13 Dec 2011)
+
+ 13 Dec 2011; Diego E. Pettenò <flameeyes@gentoo.org> +pg-0.12.0.ebuild:
+ Version bump.
27 Nov 2011; Raúl Porcel <armin76@gentoo.org> pg-0.11.0.ebuild:
ia64/sparc stable wrt #387915
diff --git a/dev-ruby/pg/pg-0.12.0.ebuild b/dev-ruby/pg/pg-0.12.0.ebuild
new file mode 100644
index 000000000000..a0552268c4db
--- /dev/null
+++ b/dev-ruby/pg/pg-0.12.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pg/pg-0.12.0.ebuild,v 1.1 2011/12/13 00:57:51 flameeyes Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 ruby19"
+
+RUBY_FAKEGEM_TEST_TASK=""
+
+RUBY_FAKEGEM_TASK_DOC="apidocs"
+RUBY_FAKEGEM_DOCDIR="docs/api"
+RUBY_FAKEGEM_EXTRADOC="ChangeLog Contributors.rdoc README.rdoc History.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby extension library providing an API to PostgreSQL"
+HOMEPAGE="http://bitbucket.org/ged/ruby-pg/"
+
+LICENSE="|| ( GPL-2 Ruby )"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+RDEPEND="${RDEPEND}
+ dev-db/postgresql-base"
+DEPEND="${DEPEND}
+ dev-db/postgresql-base
+ test? ( dev-db/postgresql-server )"
+
+ruby_add_bdepend "
+ doc? (
+ dev-ruby/hoe
+ dev-ruby/rake-compiler
+ || ( >=dev-ruby/yard-0.6.1 dev-ruby/rdoc ) )
+ test? ( dev-ruby/rspec:2 )"
+
+each_ruby_configure() {
+ pushd ext
+ ${RUBY} extconf.rb || die "extconf.rb failed"
+ popd
+}
+
+each_ruby_compile() {
+ pushd ext
+ emake CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}" || die "emake failed"
+ popd
+ cp ext/*.so lib || die
+}
+
+each_ruby_test() {
+ if [[ "${EUID}" -ne "0" ]]; then
+ # Make the rspec call explicit, this way we don't have to depend
+ # on rake-compiler (nor rubygems) _and_ we don't have to rebuild
+ # the whole extension from scratch.
+ ${RUBY} -Ilib -S rspec -fs spec/*_spec.rb || die "spec failed"
+ else
+ ewarn "The userpriv feature must be enabled to run tests."
+ eerror "Testsuite will not be run."
+ fi
+}