summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-05-29 15:47:51 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-05-29 15:47:51 +0000
commitfd059e02b45288c764b7c6912fe1e09c46d457d9 (patch)
tree12435cc4c0a362802683d7f75df2f678da32161d /dev-ruby
parentMarking hdf5-1.8.8-r1 ppc64 for bug 417607 (diff)
downloadgentoo-2-fd059e02b45288c764b7c6912fe1e09c46d457d9.tar.gz
gentoo-2-fd059e02b45288c764b7c6912fe1e09c46d457d9.tar.bz2
gentoo-2-fd059e02b45288c764b7c6912fe1e09c46d457d9.zip
Version bump.
(Portage version: 2.2.0_alpha108/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/best_in_place/ChangeLog8
-rw-r--r--dev-ruby/best_in_place/best_in_place-1.1.2.ebuild62
2 files changed, 69 insertions, 1 deletions
diff --git a/dev-ruby/best_in_place/ChangeLog b/dev-ruby/best_in_place/ChangeLog
index 04abc226c309..35b957edcc92 100644
--- a/dev-ruby/best_in_place/ChangeLog
+++ b/dev-ruby/best_in_place/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/best_in_place
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/best_in_place/ChangeLog,v 1.6 2012/05/14 18:14:00 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/best_in_place/ChangeLog,v 1.7 2012/05/29 15:47:51 flameeyes Exp $
+
+*best_in_place-1.1.2 (29 May 2012)
+
+ 29 May 2012; Diego E. Pettenò <flameeyes@gentoo.org>
+ +best_in_place-1.1.2.ebuild:
+ Version bump.
*best_in_place-1.1.0 (14 May 2012)
diff --git a/dev-ruby/best_in_place/best_in_place-1.1.2.ebuild b/dev-ruby/best_in_place/best_in_place-1.1.2.ebuild
new file mode 100644
index 000000000000..ab3b77dbfc6c
--- /dev/null
+++ b/dev-ruby/best_in_place/best_in_place-1.1.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/best_in_place/best_in_place-1.1.2.ebuild,v 1.1 2012/05/29 15:47:51 flameeyes Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ree18 ruby19"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+# if ever needed
+#GITHUB_USER="bernat"
+#GITHUB_PROJECT="${PN}"
+#RUBY_S="${GITHUB_USER}-${GITHUB_PROJECT}-*"
+
+inherit virtualx ruby-fakegem
+
+DESCRIPTION="In-place editor helper for Rails 3o"
+HOMEPAGE="http://github.com/bernat/best_in_place"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/rails-3.1
+ dev-ruby/jquery-rails"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/rspec-rails
+ >=dev-ruby/nokogiri-1.5.0
+ >=dev-ruby/capybara-1.0.1
+ dev-ruby/rails:3.2
+ >=dev-ruby/sqlite3-ruby-1.3.4-r1
+ dev-ruby/kramdown
+ )"
+
+DEPEND+=" test? ( www-client/firefox )"
+
+all_ruby_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.1.0-kramdown.patch
+
+ sed -i \
+ -e '/git ls-files/d' \
+ -e '/rspec-rails/s:,.*::' \
+ ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ sed -i \
+ -e '/gem .rails/s:3.2: ~> 3.2.0:' \
+ -e '/group :assets/,/^end/ d' \
+ test_app/Gemfile || die
+}
+
+each_ruby_test() {
+ RAILS_ENV=test ${RUBY} -C test_app -S rake db:migrate || die "test_app migration failed"
+ VIRTUALX_COMMAND="${RUBY}" virtualmake -S rake spec || die "Specs failed"
+}