summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-12-13 15:43:27 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-12-13 15:43:27 +0000
commit8a802477bfc9dac614b3380fd45355a7b17c2870 (patch)
tree444a79d6a6ad5c726a36607923963247e5e71c8b /games-action/supertuxkart
parentAdd splitdebug (diff)
downloadgentoo-2-8a802477bfc9dac614b3380fd45355a7b17c2870.tar.gz
gentoo-2-8a802477bfc9dac614b3380fd45355a7b17c2870.tar.bz2
gentoo-2-8a802477bfc9dac614b3380fd45355a7b17c2870.zip
fix use debug logic (bug #447060)
(Portage version: 2.1.11.31/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-action/supertuxkart')
-rw-r--r--games-action/supertuxkart/ChangeLog6
-rw-r--r--games-action/supertuxkart/supertuxkart-0.8.ebuild5
2 files changed, 7 insertions, 4 deletions
diff --git a/games-action/supertuxkart/ChangeLog b/games-action/supertuxkart/ChangeLog
index 24e4f8b9dc78..380213ac7d9f 100644
--- a/games-action/supertuxkart/ChangeLog
+++ b/games-action/supertuxkart/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-action/supertuxkart
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/supertuxkart/ChangeLog,v 1.30 2012/12/13 14:41:53 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/supertuxkart/ChangeLog,v 1.31 2012/12/13 15:43:27 mr_bones_ Exp $
+
+ 13 Dec 2012; Michael Sterrett <mr_bones_@gentoo.org> supertuxkart-0.8.ebuild:
+ fix use debug logic (bug #447060)
13 Dec 2012; Sergey Popov <pinkbyte@gentoo.org> supertuxkart-0.8.ebuild:
Remove CCPL-Sampling+ from LICENSE, wrt bug #447094. Thanks to Andrius
@@ -123,4 +126,3 @@
28 Sep 2006; Michael Sterrett <mr_bones_@gentoo.org> +metadata.xml,
+supertuxkart-0.2.ebuild:
initial commit - ebuild submitted by Mikel Olasagasti via bug #75416
-
diff --git a/games-action/supertuxkart/supertuxkart-0.8.ebuild b/games-action/supertuxkart/supertuxkart-0.8.ebuild
index db2b6c9e5a8f..c90dbee32079 100644
--- a/games-action/supertuxkart/supertuxkart-0.8.ebuild
+++ b/games-action/supertuxkart/supertuxkart-0.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/supertuxkart/supertuxkart-0.8.ebuild,v 1.2 2012/12/13 14:41:53 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/supertuxkart/supertuxkart-0.8.ebuild,v 1.3 2012/12/13 15:43:27 mr_bones_ Exp $
EAPI=2
inherit cmake-utils eutils games
@@ -44,10 +44,11 @@ src_prepare() {
# inconsistent handling of debug definition
# avoid using Debug build type
- use debug &&
+ if use debug ; then
sed -i \
-e 's/add_definitions(-DNDEBUG)/add_definitions(-DDEBUG)/' \
CMakeLists.txt || die
+ fi
}
src_configure() {