summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2008-07-20 20:49:15 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2008-07-20 20:49:15 +0000
commit3c5c5a3ce6aaa7fd554cae2b174102ef24207170 (patch)
treefee894f81fb1819ac326c2c5500cd2d8734bfabe /games-board/pouetchess
parentMarked ~hppa too. (diff)
downloadgentoo-2-3c5c5a3ce6aaa7fd554cae2b174102ef24207170.tar.gz
gentoo-2-3c5c5a3ce6aaa7fd554cae2b174102ef24207170.tar.bz2
gentoo-2-3c5c5a3ce6aaa7fd554cae2b174102ef24207170.zip
Fix for gcc-4.3, bug 226663. Thanks to Marek Miller <mlm@shells.pl>.
(Portage version: 2.2_rc1/cvs/Linux 2.6.25.8 i686)
Diffstat (limited to 'games-board/pouetchess')
-rw-r--r--games-board/pouetchess/ChangeLog6
-rw-r--r--games-board/pouetchess/files/pouetchess-0.2.0-gcc43.patch12
-rw-r--r--games-board/pouetchess/pouetchess-0.2.0-r1.ebuild16
3 files changed, 25 insertions, 9 deletions
diff --git a/games-board/pouetchess/ChangeLog b/games-board/pouetchess/ChangeLog
index da60044401aa..82018337cc14 100644
--- a/games-board/pouetchess/ChangeLog
+++ b/games-board/pouetchess/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-board/pouetchess
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/pouetchess/ChangeLog,v 1.10 2008/07/17 21:52:15 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/pouetchess/ChangeLog,v 1.11 2008/07/20 20:49:15 loki_val Exp $
+
+ 20 Jul 2008; Peter Alfredsen <loki_val@gentoo.org>
+ +files/pouetchess-0.2.0-gcc43.patch, pouetchess-0.2.0-r1.ebuild:
+ Fix for gcc-4.3, bug 226663. Thanks to Marek Miller <mlm@shells.pl>.
17 Jul 2008; Michael Sterrett <mr_bones_@gentoo.org>
pouetchess-0.2.0-r1.ebuild:
diff --git a/games-board/pouetchess/files/pouetchess-0.2.0-gcc43.patch b/games-board/pouetchess/files/pouetchess-0.2.0-gcc43.patch
new file mode 100644
index 000000000000..0a60c2117da8
--- /dev/null
+++ b/games-board/pouetchess/files/pouetchess-0.2.0-gcc43.patch
@@ -0,0 +1,12 @@
+--- src/sxmlgui/XMLUtils.h.orig 2008-06-14 14:50:16.000000000 +0000
++++ src/sxmlgui/XMLUtils.h 2008-06-14 14:50:33.000000000 +0000
+@@ -38,6 +38,8 @@
+ #include <stdio.h>
+ #include <assert.h>
+ #include <fstream>
++#include <cstring>
++
+
+ // Help out windows:
+ #if defined( _DEBUG ) && !defined( DEBUG )
+
diff --git a/games-board/pouetchess/pouetchess-0.2.0-r1.ebuild b/games-board/pouetchess/pouetchess-0.2.0-r1.ebuild
index 8099de04cb65..038048ef524d 100644
--- a/games-board/pouetchess/pouetchess-0.2.0-r1.ebuild
+++ b/games-board/pouetchess/pouetchess-0.2.0-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/pouetchess/pouetchess-0.2.0-r1.ebuild,v 1.5 2008/07/17 23:03:35 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/pouetchess/pouetchess-0.2.0-r1.ebuild,v 1.6 2008/07/20 20:49:15 loki_val Exp $
-inherit eutils toolchain-funcs games
+inherit base eutils toolchain-funcs games
MY_PN=${PN/c/C}
DESCRIPTION="3D and open source chess game"
@@ -22,6 +22,10 @@ DEPEND="${RDEPEND}
dev-util/scons"
S=${WORKDIR}/${PN}_src_${PV}
+PATCHES=( "${FILESDIR}/${P}-sconstruct-sandbox.patch"
+ "${FILESDIR}/${P}-nvidia_glext.patch"
+ "${FILESDIR}/${P}-segfaults.patch"
+ "${FILESDIR}/${P}-gcc43.patch" )
pkg_setup() {
games_pkg_setup
@@ -33,13 +37,9 @@ pkg_setup() {
}
src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch \
- "${FILESDIR}"/${P}-sconstruct-sandbox.patch \
- "${FILESDIR}"/${P}-nvidia_glext.patch \
- "${FILESDIR}"/${P}-segfaults.patch
+ base_src_unpack
+ cd "${S}"
# Fix for LibSDL >= 1.2.10 detection
sed -i \
-e "s:sdlver.split('.') >= \['1','2','8'\]:sdlver.split('.') >= [1,2,8]:" \