summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-10 06:26:50 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-10 06:26:50 +0000
commit1190b5814f7da41ef46d6f5758aa44b80e0e954f (patch)
tree410895ca938ddb9b4166f4850349a53245129e10 /games-rpg/adonthell
parentinitial import. buig 26371 (diff)
downloadgentoo-2-1190b5814f7da41ef46d6f5758aa44b80e0e954f.tar.gz
gentoo-2-1190b5814f7da41ef46d6f5758aa44b80e0e954f.tar.bz2
gentoo-2-1190b5814f7da41ef46d6f5758aa44b80e0e954f.zip
i lub rpgs
Diffstat (limited to 'games-rpg/adonthell')
-rw-r--r--games-rpg/adonthell/ChangeLog22
-rw-r--r--games-rpg/adonthell/Manifest4
-rw-r--r--games-rpg/adonthell/adonthell-0.3.3-r1.ebuild45
-rw-r--r--games-rpg/adonthell/files/0.3.3-configure.in.patch11
-rw-r--r--games-rpg/adonthell/files/digest-adonthell-0.3.3-r11
5 files changed, 83 insertions, 0 deletions
diff --git a/games-rpg/adonthell/ChangeLog b/games-rpg/adonthell/ChangeLog
new file mode 100644
index 000000000000..51c5894fa85a
--- /dev/null
+++ b/games-rpg/adonthell/ChangeLog
@@ -0,0 +1,22 @@
+# ChangeLog for app-games/adonthell
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/adonthell/ChangeLog,v 1.1 2003/09/10 06:26:50 vapier Exp $
+
+*adonthell-0.3.3-r1 (20 Mar 2003)
+
+ 21 Jun 2003; Mike Frysinger <vapier@gentoo.org> :
+ Added a small patch back ported from 0.3.4-cvs #17281.
+
+ 27 Mar 2003; Michael Nazaroff <naz@gentoo.org> adonthell-0.3.3-r1.ebuild:
+ Added a License to the ebuild.
+
+ 20 Mar 2003; Graham Forest <vladimir@gentoo.org> adonthell-0.3.3-r1.ebuild:
+ Removed usage of pic USE flag
+
+*adonthell-0.3.3 (02 Mar 2003)
+
+ 27 Mar 2003; Michael Nazaroff <naz@gentoo.org> adonthell-3.3.ebuild:
+ Added a License to the ebuild.
+
+ 02 Mar 2003; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by Luca Barbato <lu_zero@gentoo.org> #11875.
diff --git a/games-rpg/adonthell/Manifest b/games-rpg/adonthell/Manifest
new file mode 100644
index 000000000000..a59c58aff7f5
--- /dev/null
+++ b/games-rpg/adonthell/Manifest
@@ -0,0 +1,4 @@
+MD5 6211b46f79a2bbaea936f30e64a83713 files/0.3.3-configure.in.patch 528
+MD5 55d668981b78a8cde872051ff3a056c9 files/digest-adonthell-0.3.3-r1 68
+MD5 7aea7973778e5d622206c31e1e381f17 ChangeLog 860
+MD5 1ad2f047368991c9256be901c6c90860 adonthell-0.3.3-r1.ebuild 1040
diff --git a/games-rpg/adonthell/adonthell-0.3.3-r1.ebuild b/games-rpg/adonthell/adonthell-0.3.3-r1.ebuild
new file mode 100644
index 000000000000..c24fa2ff244e
--- /dev/null
+++ b/games-rpg/adonthell/adonthell-0.3.3-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/adonthell/adonthell-0.3.3-r1.ebuild,v 1.1 2003/09/10 06:26:50 vapier Exp $
+
+inherit games eutils
+
+DESCRIPTION="roleplaying game engine"
+HOMEPAGE="http://adonthell.linuxgames.com/"
+SRC_URI="http://savannah.nongnu.org/download/adonthell/src/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="oggvorbis gtk nls doc"
+
+DEPEND="dev-lang/python
+ media-libs/libsdl
+ oggvorbis? ( media-libs/libvorbis
+ media-libs/libogg )
+ sys-libs/zlib
+ gtk? ( =x11-libs/gtk+-1* )
+ doc? ( app-doc/doxygen )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-configure.in.patch
+ autoconf || die
+}
+
+src_compile() {
+ egamesconf \
+ `use_enable nls` \
+ `use_enable doc` \
+ --with-gnu-ld \
+ || die
+ touch doc/items/{footer,header}.html
+ emake || die
+}
+
+src_install() {
+ emake install DESTDIR=${D} || die
+ dodoc README AUTHORS ChangeLog FULLSCREEN.howto NEWBIE NEWS
+ prepgamesdirs
+}
diff --git a/games-rpg/adonthell/files/0.3.3-configure.in.patch b/games-rpg/adonthell/files/0.3.3-configure.in.patch
new file mode 100644
index 000000000000..ca6d5d1edcc5
--- /dev/null
+++ b/games-rpg/adonthell/files/0.3.3-configure.in.patch
@@ -0,0 +1,11 @@
+--- configure.in.orig 2003-03-10 19:34:50.000000000 -0800
++++ configure.in 2003-03-10 19:35:31.000000000 -0800
+@@ -216,7 +216,7 @@
+
+ if test x$haveldd != x ; then
+ changequote(<<, >>)
+- py_deps=`ldd $PYPACKAGE | sed 's/\( *lib\([^\/]*\)\.so.*=.*$\)/-l\2/p; d'`
++ py_deps=`ldd $PYPACKAGE | sed 's/\( *.*lib\([^\/]*\)\.so.*=.*$\)/-l\2/p; d' | grep -v sandbox`
+ for py_lib in $py_deps ; do
+ if test "$py_lib" != "-lm" && test "$py_lib" != "-lc" ; then
+ PY_DEPS="$PY_DEPS $py_lib"
diff --git a/games-rpg/adonthell/files/digest-adonthell-0.3.3-r1 b/games-rpg/adonthell/files/digest-adonthell-0.3.3-r1
new file mode 100644
index 000000000000..d66cb68c860c
--- /dev/null
+++ b/games-rpg/adonthell/files/digest-adonthell-0.3.3-r1
@@ -0,0 +1 @@
+MD5 8ed4a8b02ea24fd393b67bca355cc70b adonthell-0.3.3.tar.gz 1042278