summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-03-14 02:19:36 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-03-14 02:19:36 +0000
commitf0aaae9db6a8ab06beda17dcf2e822e990279e3a (patch)
treee0940679773083749de3df7fa7070c3cd459bb09 /games-util
parentDrop dead USE flags. (diff)
downloadgentoo-2-f0aaae9db6a8ab06beda17dcf2e822e990279e3a.tar.gz
gentoo-2-f0aaae9db6a8ab06beda17dcf2e822e990279e3a.tar.bz2
gentoo-2-f0aaae9db6a8ab06beda17dcf2e822e990279e3a.zip
EAPI=5
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-util')
-rw-r--r--games-util/biounzip/ChangeLog8
-rw-r--r--games-util/biounzip/biounzip-1.1a.ebuild16
2 files changed, 14 insertions, 10 deletions
diff --git a/games-util/biounzip/ChangeLog b/games-util/biounzip/ChangeLog
index 2fc6b5052272..fda9b18e1459 100644
--- a/games-util/biounzip/ChangeLog
+++ b/games-util/biounzip/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-util/biounzip
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/biounzip/ChangeLog,v 1.5 2008/12/06 14:06:16 nyhm Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/biounzip/ChangeLog,v 1.6 2015/03/14 02:19:36 mr_bones_ Exp $
+
+ 14 Mar 2015; Michael Sterrett <mr_bones_@gentoo.org> biounzip-1.1a.ebuild:
+ EAPI=5
06 Dec 2008; Tristan Heaven <nyhm@gentoo.org> biounzip-1.1a.ebuild:
Respect CC and LDFLAGS, bug #244118
@@ -22,4 +25,3 @@
09 Jan 2006; Chris Gianelloni <wolf31o2@gentoo.org> +metadata.xml,
+biounzip-1.1a.ebuild:
Initial import. Ebuild by Constantin Bergemann <tony@knueppelcore.de>.
-
diff --git a/games-util/biounzip/biounzip-1.1a.ebuild b/games-util/biounzip/biounzip-1.1a.ebuild
index c22c9ce0d5c4..da64332bd339 100644
--- a/games-util/biounzip/biounzip-1.1a.ebuild
+++ b/games-util/biounzip/biounzip-1.1a.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/biounzip/biounzip-1.1a.ebuild,v 1.8 2008/12/06 14:41:51 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/biounzip/biounzip-1.1a.ebuild,v 1.9 2015/03/14 02:19:36 mr_bones_ Exp $
+EAPI=5
inherit eutils toolchain-funcs
DESCRIPTION="Unpacks BioZip archives"
@@ -13,19 +14,20 @@ SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
+DEPEND="sys-libs/zlib"
+RDEPEND=${DEPEND}
+
S=${WORKDIR}/${P/a/}
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}"/${P}-64bit.patch
}
src_compile() {
- $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o ${PN} *.c -lz || die "cc failed"
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o ${PN} *.c -lz || die
}
src_install() {
- dobin ${PN} || die "dobin failed"
+ dobin ${PN}
dodoc biozip.txt
}