summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2014-03-04 19:14:09 +0000
committerJohannes Huber <johu@gentoo.org>2014-03-04 19:14:09 +0000
commitb635da4d6a5d3adc02954e54eac873b1ccef912d (patch)
tree20c5621fa841bba0ea00b22c0f7164dbce35a9b2 /kde-base/kstars
parentAdd missing DEPEND. #501740 (diff)
downloadgentoo-2-b635da4d6a5d3adc02954e54eac873b1ccef912d.tar.gz
gentoo-2-b635da4d6a5d3adc02954e54eac873b1ccef912d.tar.bz2
gentoo-2-b635da4d6a5d3adc02954e54eac873b1ccef912d.zip
Version bump KDE SC 4.12.3
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'kde-base/kstars')
-rw-r--r--kde-base/kstars/ChangeLog7
-rw-r--r--kde-base/kstars/kstars-4.12.3.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/kde-base/kstars/ChangeLog b/kde-base/kstars/ChangeLog
index e93284e0d7ae..95c35883bdd8 100644
--- a/kde-base/kstars/ChangeLog
+++ b/kde-base/kstars/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kstars
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kstars/ChangeLog,v 1.317 2014/02/23 10:01:45 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kstars/ChangeLog,v 1.318 2014/03/04 19:13:57 johu Exp $
+
+*kstars-4.12.3 (04 Mar 2014)
+
+ 04 Mar 2014; Johannes Huber <johu@gentoo.org> +kstars-4.12.3.ebuild:
+ Version bump KDE SC 4.12.3
23 Feb 2014; Agostino Sarubbo <ago@gentoo.org> -kstars-4.11.2.ebuild:
Remove old
diff --git a/kde-base/kstars/kstars-4.12.3.ebuild b/kde-base/kstars/kstars-4.12.3.ebuild
new file mode 100644
index 000000000000..10190526235f
--- /dev/null
+++ b/kde-base/kstars/kstars-4.12.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kstars/kstars-4.12.3.ebuild,v 1.1 2014/03/04 19:13:57 johu Exp $
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+inherit flag-o-matic kde4-base
+
+DESCRIPTION="KDE Desktop Planetarium"
+HOMEPAGE="http://www.kde.org/applications/education/kstars http://edu.kde.org/kstars"
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug fits indi"
+
+DEPEND="
+ dev-cpp/eigen:2
+ $(add_kdebase_dep libkdeedu)
+ fits? ( >=sci-libs/cfitsio-0.390 )
+ indi? ( >=sci-libs/indilib-0.9.1 )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ # Bug 308903
+ use ppc64 && append-flags -mminimal-toc
+
+ mycmakeargs=(
+ $(cmake-utils_use_with fits CFitsio)
+ $(cmake-utils_use_with indi)
+ )
+
+ kde4-base_src_configure
+}