summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-06-03 23:04:54 +0000
committerManuel Rüger <mrueg@gentoo.org>2015-06-03 23:04:54 +0000
commit0c93075e937ba5c2a7cbedac1fdd56415483da7d (patch)
tree381cbf46e9bf141548eabf78ce48416685189a44 /kde-base/ksysguard
parentSync verbosely with overlay. Add support for kde4 localization package kde-ap... (diff)
downloadgentoo-2-0c93075e937ba5c2a7cbedac1fdd56415483da7d.tar.gz
gentoo-2-0c93075e937ba5c2a7cbedac1fdd56415483da7d.tar.bz2
gentoo-2-0c93075e937ba5c2a7cbedac1fdd56415483da7d.zip
Version bump.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'kde-base/ksysguard')
-rw-r--r--kde-base/ksysguard/ChangeLog7
-rw-r--r--kde-base/ksysguard/ksysguard-4.11.20.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/kde-base/ksysguard/ChangeLog b/kde-base/ksysguard/ChangeLog
index 687c939688c4..a92cf5fba44b 100644
--- a/kde-base/ksysguard/ChangeLog
+++ b/kde-base/ksysguard/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/ksysguard
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ksysguard/ChangeLog,v 1.353 2015/05/15 15:53:06 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksysguard/ChangeLog,v 1.354 2015/06/03 23:04:53 mrueg Exp $
+
+*ksysguard-4.11.20 (03 Jun 2015)
+
+ 03 Jun 2015; Manuel Rüger <mrueg@gentoo.org> +ksysguard-4.11.20.ebuild:
+ Version bump.
*ksysguard-4.11.19 (15 May 2015)
diff --git a/kde-base/ksysguard/ksysguard-4.11.20.ebuild b/kde-base/ksysguard/ksysguard-4.11.20.ebuild
new file mode 100644
index 000000000000..2a2bac74e492
--- /dev/null
+++ b/kde-base/ksysguard/ksysguard-4.11.20.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksysguard/ksysguard-4.11.20.ebuild,v 1.1 2015/06/03 23:04:53 mrueg Exp $
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+KMNAME="kde-workspace"
+CPPUNIT_REQUIRED="optional"
+VIRTUALX_REQUIRED="test"
+inherit kde4-meta
+
+DESCRIPTION="KSysguard is a network enabled task manager and system monitor application"
+HOMEPAGE+=" http://userbase.kde.org/KSysGuard"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug lm_sensors test"
+
+DEPEND="
+ sys-libs/zlib
+ x11-libs/libX11
+ x11-libs/libXres
+ lm_sensors? ( sys-apps/lm_sensors )
+"
+RDEPEND="${DEPEND}"
+
+RESTRICT="test"
+# bug 393091
+
+KMEXTRA="
+ libs/ksysguard/
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with lm_sensors Sensors)
+ )
+
+ kde4-meta_src_configure
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+ ewarn "Note that ksysguard has powerful features; one of these is the executing of arbitrary"
+ ewarn "programs with elevated privileges (as data sources). So be careful opening worksheets"
+ ewarn "from untrusted sources!"
+}