summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2011-09-04 10:45:05 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2011-09-04 10:45:05 +0000
commit9f5f5c0ddd2a2743012f4775654d086244f831b4 (patch)
tree7cdba98916a913dd34304f7f0bed851d565da314 /media-gfx/mandelbulber
parentpymsn-t: fix deprecations in python and init-script, port to eapi 3 (diff)
downloadgentoo-2-9f5f5c0ddd2a2743012f4775654d086244f831b4.tar.gz
gentoo-2-9f5f5c0ddd2a2743012f4775654d086244f831b4.tar.bz2
gentoo-2-9f5f5c0ddd2a2743012f4775654d086244f831b4.zip
Version bump wrt #380327 by Tim Harder <radhermit@gentoo.org>, drop old
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/mandelbulber')
-rw-r--r--media-gfx/mandelbulber/ChangeLog11
-rw-r--r--media-gfx/mandelbulber/files/mandelbulber-1.00-gcc46.patch12
-rw-r--r--media-gfx/mandelbulber/files/mandelbulber-1.05-overflow.patch11
-rw-r--r--media-gfx/mandelbulber/files/mandelbulber-1.08-qa.patch (renamed from media-gfx/mandelbulber/files/mandelbulber-1.00-qa.patch)16
-rw-r--r--media-gfx/mandelbulber/mandelbulber-1.00.ebuild47
-rw-r--r--media-gfx/mandelbulber/mandelbulber-1.08.ebuild (renamed from media-gfx/mandelbulber/mandelbulber-1.05.ebuild)8
6 files changed, 19 insertions, 86 deletions
diff --git a/media-gfx/mandelbulber/ChangeLog b/media-gfx/mandelbulber/ChangeLog
index a2cba0f4b391..900a54c8dd5d 100644
--- a/media-gfx/mandelbulber/ChangeLog
+++ b/media-gfx/mandelbulber/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for media-gfx/mandelbulber
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/mandelbulber/ChangeLog,v 1.4 2011/07/16 09:27:41 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/mandelbulber/ChangeLog,v 1.5 2011/09/04 10:45:04 xarthisius Exp $
+
+*mandelbulber-1.08 (04 Sep 2011)
+
+ 04 Sep 2011; Kacper Kowalik <xarthisius@gentoo.org>
+ -mandelbulber-1.00.ebuild, -files/mandelbulber-1.00-gcc46.patch,
+ -files/mandelbulber-1.00-qa.patch, -mandelbulber-1.05.ebuild,
+ -files/mandelbulber-1.05-overflow.patch, +mandelbulber-1.08.ebuild,
+ +files/mandelbulber-1.08-qa.patch:
+ Version bump wrt #380327 by Tim Harder <radhermit@gentoo.org>, drop old
*mandelbulber-1.05 (16 Jul 2011)
diff --git a/media-gfx/mandelbulber/files/mandelbulber-1.00-gcc46.patch b/media-gfx/mandelbulber/files/mandelbulber-1.00-gcc46.patch
deleted file mode 100644
index 2a4e6657864e..000000000000
--- a/media-gfx/mandelbulber/files/mandelbulber-1.00-gcc46.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-Fix building with GCC 4.6
-
---- src/fractal.h
-+++ src/fractal.h
-@@ -9,6 +9,7 @@
- #define FRACTAL_H_
-
- #include <vector>
-+#include <cstddef>
- #include "common_math.h"
- #include "fractparams.h"
-
diff --git a/media-gfx/mandelbulber/files/mandelbulber-1.05-overflow.patch b/media-gfx/mandelbulber/files/mandelbulber-1.05-overflow.patch
deleted file mode 100644
index af4170fa65a2..000000000000
--- a/media-gfx/mandelbulber/files/mandelbulber-1.05-overflow.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/callbacks.cpp
-+++ src/callbacks.cpp
-@@ -1663,7 +1663,7 @@
- {
- const char *filename = gtk_file_chooser_get_preview_filename(file_chooser);
-
-- char string[12];
-+ char string[13];
-
- FILE *fileSettings = fopen(filename, "r");
- if (fileSettings)
diff --git a/media-gfx/mandelbulber/files/mandelbulber-1.00-qa.patch b/media-gfx/mandelbulber/files/mandelbulber-1.08-qa.patch
index 447bea5fdad8..e94c97fbbd32 100644
--- a/media-gfx/mandelbulber/files/mandelbulber-1.00-qa.patch
+++ b/media-gfx/mandelbulber/files/mandelbulber-1.08-qa.patch
@@ -1,20 +1,16 @@
-Respect CXX,CXXFLAGS, fix as-needed
-
-Patch written by Kacper Kowalik <xarthisius@gentoo.org>
-
---- a/makefiles/makefile
-+++ b/makefiles/makefile
+--- makefiles/makefile.orig 2011-09-04 12:36:07.388901054 +0200
++++ makefiles/makefile 2011-09-04 12:37:15.301900642 +0200
@@ -44,7 +44,7 @@
mandelbulber: $(OBJS) $(USER_OBJS)
@echo 'Building target: $@'
@echo 'Invoking: GCC C++ Linker'
-- g++ `pkg-config --libs gtk+-2.0 gthread-2.0` -o"mandelbulber" $(OBJS) $(USER_OBJS) $(LIBS)
-+ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o "mandelbulber" $(OBJS) $(USER_OBJS) `pkg-config --libs gtk+-2.0 gthread-2.0` $(LIBS)
+- g++ `pkg-config --libs gtk+-2.0 gthread-2.0` -o"mandelbulber"$(OBJS) $(USER_OBJS) $(LIBS)
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $@ $(OBJS) $(USER_OBJS) `pkg-config --libs gtk+-2.0 gthread-2.0` $(LIBS)
@echo 'Finished building target: $@'
@echo ' '
---- a/makefiles/src/subdir.mk
-+++ b/makefiles/src/subdir.mk
+--- makefiles/src/subdir.mk.orig 2011-09-04 12:37:21.200901233 +0200
++++ makefiles/src/subdir.mk 2011-09-04 12:37:57.896900659 +0200
@@ -65,7 +65,7 @@
src/%.o: ../src/%.cpp
@echo 'Building file: $<'
diff --git a/media-gfx/mandelbulber/mandelbulber-1.00.ebuild b/media-gfx/mandelbulber/mandelbulber-1.00.ebuild
deleted file mode 100644
index 7359403094a8..000000000000
--- a/media-gfx/mandelbulber/mandelbulber-1.00.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/mandelbulber/mandelbulber-1.00.ebuild,v 1.1 2011/04/27 20:19:08 xarthisius Exp $
-
-EAPI=3
-
-inherit eutils toolchain-funcs
-
-MY_P=${PN}${PV}
-
-DESCRIPTION="Tool to render 3D fractals"
-HOMEPAGE="http://sites.google.com/site/mandelbulber/home"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="x11-libs/gtk+:2
- >=media-libs/libsndfile-1
- >=media-libs/libpng-1.4
- virtual/jpeg"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-qa.patch \
- "${FILESDIR}"/${P}-gcc46.patch
-}
-
-src_compile() {
- emake CXX="$(tc-getCXX)" -C makefiles all || die
-}
-
-src_install() {
- dobin makefiles/${PN} || die
- dodoc README NEWS || die
- insinto /usr/share/${PN}
- doins -r .${PN}/* || die
-}
-
-pkg_postinst() {
- elog "Before you run ${PN} please copy /usr/share/${PN}/* to \${HOME}/.${PN}"
-}
diff --git a/media-gfx/mandelbulber/mandelbulber-1.05.ebuild b/media-gfx/mandelbulber/mandelbulber-1.08.ebuild
index 859633c3c720..f9de8de4b3c6 100644
--- a/media-gfx/mandelbulber/mandelbulber-1.05.ebuild
+++ b/media-gfx/mandelbulber/mandelbulber-1.08.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/mandelbulber/mandelbulber-1.05.ebuild,v 1.1 2011/07/16 09:27:41 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/mandelbulber/mandelbulber-1.08.ebuild,v 1.1 2011/09/04 10:45:04 xarthisius Exp $
EAPI=4
@@ -28,13 +28,11 @@ S=${WORKDIR}/${MY_P}
src_prepare() {
# https://sourceforge.net/tracker/?func=detail&aid=3368617&group_id=303080&atid=1277701
- # https://sourceforge.net/tracker/?func=detail&aid=3368618&group_id=303080&atid=1277701
- epatch "${FILESDIR}"/${PN}-1.00-qa.patch \
- "${FILESDIR}"/${P}-overflow.patch
+ epatch "${FILESDIR}"/${P}-qa.patch
}
src_compile() {
- emake CXX="$(tc-getCXX)" -C makefiles all || die
+ emake CXX="$(tc-getCXX)" -C makefiles all
}
src_install() {