summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2010-12-26 17:15:34 +0000
committerAlexis Ballier <aballier@gentoo.org>2010-12-26 17:15:34 +0000
commit6b857e41ba9ab3df801af32ea2c3b34dfd86d196 (patch)
tree6387de17f28cbc141d979df74420031e4124b246 /media-libs/libxtract/libxtract-0.6.3.ebuild
parentFix dependencies. Set SUPPORT_PYTHON_ABIS. (diff)
downloadgentoo-2-6b857e41ba9ab3df801af32ea2c3b34dfd86d196.tar.gz
gentoo-2-6b857e41ba9ab3df801af32ea2c3b34dfd86d196.tar.bz2
gentoo-2-6b857e41ba9ab3df801af32ea2c3b34dfd86d196.zip
version bump
(Portage version: 2.2.0_alpha10/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/libxtract/libxtract-0.6.3.ebuild')
-rw-r--r--media-libs/libxtract/libxtract-0.6.3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/media-libs/libxtract/libxtract-0.6.3.ebuild b/media-libs/libxtract/libxtract-0.6.3.ebuild
new file mode 100644
index 000000000000..993517acd813
--- /dev/null
+++ b/media-libs/libxtract/libxtract-0.6.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libxtract/libxtract-0.6.3.ebuild,v 1.1 2010/12/26 17:15:34 aballier Exp $
+
+DESCRIPTION="A simple, portable, lightweight library of audio feature extraction functions"
+HOMEPAGE="http://libxtract.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="debug doc fftw"
+
+RDEPEND="fftw? ( =sci-libs/fftw-3* )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_compile() {
+ local myconf=""
+ use debug && myconf="${myconf} --enable-debug"
+ econf $(use_enable fftw fft) ${myconf} || die "configure failed"
+ # Prevent doc from being generated automagically
+ use doc || touch doc/doxygen-build.stamp
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc README TODO AUTHORS
+ use doc && dohtml doc/html/*
+}