summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2007-03-19 18:53:21 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2007-03-19 18:53:21 +0000
commit3ff2e17af0b3c997278c3e294c6f753fa088d7da (patch)
tree0bd9677112328b9cb91f4479900f4dda96f3f51a /media-sound/esound
parentUpdated early-rules for scsi-wait, like upstream. Created 95-udev-late.rules,... (diff)
downloadgentoo-2-3ff2e17af0b3c997278c3e294c6f753fa088d7da.tar.gz
gentoo-2-3ff2e17af0b3c997278c3e294c6f753fa088d7da.tar.bz2
gentoo-2-3ff2e17af0b3c997278c3e294c6f753fa088d7da.zip
Fix building with debug; bug #170971
(Portage version: 2.1.2.2)
Diffstat (limited to 'media-sound/esound')
-rw-r--r--media-sound/esound/ChangeLog6
-rw-r--r--media-sound/esound/esound-0.2.37.ebuild4
-rw-r--r--media-sound/esound/files/esound-0.2.37-debug.patch20
3 files changed, 28 insertions, 2 deletions
diff --git a/media-sound/esound/ChangeLog b/media-sound/esound/ChangeLog
index 2d3cddde78cb..ee546d306170 100644
--- a/media-sound/esound/ChangeLog
+++ b/media-sound/esound/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/esound
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/esound/ChangeLog,v 1.92 2007/03/14 17:22:43 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/esound/ChangeLog,v 1.93 2007/03/19 18:53:21 dang Exp $
+
+ 19 Mar 2007; Daniel Gryniewicz <dang@gentoo.org>
+ +files/esound-0.2.37-debug.patch, esound-0.2.37.ebuild:
+ Fix building with debug; bug #170971
*esound-0.2.37 (14 Mar 2007)
diff --git a/media-sound/esound/esound-0.2.37.ebuild b/media-sound/esound/esound-0.2.37.ebuild
index 1f13d77e1dc8..545791cd680d 100644
--- a/media-sound/esound/esound-0.2.37.ebuild
+++ b/media-sound/esound/esound-0.2.37.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/esound/esound-0.2.37.ebuild,v 1.1 2007/03/14 17:22:43 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/esound/esound-0.2.37.ebuild,v 1.2 2007/03/19 18:53:21 dang Exp $
WANT_AUTOMAKE=1.10
inherit libtool gnome.org eutils autotools flag-o-matic
@@ -35,6 +35,8 @@ src_unpack() {
epatch "${FILESDIR}/${PN}-0.2.36-mode_t.patch"
epatch "${FILESDIR}/${PN}-0.2.36-asneeded.patch"
+ # Fix compile with debug; bug #170971
+ epatch "${FILESDIR}/${PN}-0.2.37-debug.patch"
AT_M4DIR="m4" eautomake
diff --git a/media-sound/esound/files/esound-0.2.37-debug.patch b/media-sound/esound/files/esound-0.2.37-debug.patch
new file mode 100644
index 000000000000..66f5502a7e34
--- /dev/null
+++ b/media-sound/esound/files/esound-0.2.37-debug.patch
@@ -0,0 +1,20 @@
+diff --exclude-from=/home/dang/bin/scripts/diffrc -up -ruN esound-0.2.37.orig/players.c esound-0.2.37/players.c
+--- esound-0.2.37.orig/players.c 2007-01-01 18:56:06.000000000 -0500
++++ esound-0.2.37/players.c 2007-03-19 14:47:06.000000000 -0400
+@@ -303,14 +303,13 @@ int read_player( esd_player_t *player )
+ &rd_fds, NULL, NULL, &timeout ) ;
+ if ( can_read > 0 )
+ {
+- int bytes_read;
+ player->actual_length = 0;
+ do {
+- bytes_read = ESD_READ_BIN( player->source_id,
++ ESD_READ_BIN( player->source_id,
+ player->data_buffer + player->actual_length,
+ player->buffer_length - player->actual_length,
+ actual, "str rd" );
+- if (bytes_read < player->buffer_length - player->actual_length)
++ if (actual < player->buffer_length - player->actual_length)
+ break;
+
+ /* check for end of stream */