summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNguyen Thai Ngoc Duy <pclouds@gentoo.org>2006-12-03 03:29:47 +0000
committerNguyen Thai Ngoc Duy <pclouds@gentoo.org>2006-12-03 03:29:47 +0000
commitccbdcf4435182af23d1beb6de26b971dd57fc849 (patch)
treea34fcc6e4cc853eefc734f1e42175cf07094bd2e /media-sound/lastfm-ripper/lastfm-ripper-1.2.1-r3.ebuild
parentarm/ia64/s390/sh stable (diff)
downloadgentoo-2-ccbdcf4435182af23d1beb6de26b971dd57fc849.tar.gz
gentoo-2-ccbdcf4435182af23d1beb6de26b971dd57fc849.tar.bz2
gentoo-2-ccbdcf4435182af23d1beb6de26b971dd57fc849.zip
Fixed #155152. Patch contributed by Alessandro Di Marco <dmr@gmx.it>
(Portage version: 2.1.1)
Diffstat (limited to 'media-sound/lastfm-ripper/lastfm-ripper-1.2.1-r3.ebuild')
-rw-r--r--media-sound/lastfm-ripper/lastfm-ripper-1.2.1-r3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/media-sound/lastfm-ripper/lastfm-ripper-1.2.1-r3.ebuild b/media-sound/lastfm-ripper/lastfm-ripper-1.2.1-r3.ebuild
new file mode 100644
index 000000000000..4e3c16e1bfc1
--- /dev/null
+++ b/media-sound/lastfm-ripper/lastfm-ripper-1.2.1-r3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lastfm-ripper/lastfm-ripper-1.2.1-r3.ebuild,v 1.1 2006/12/03 03:29:47 pclouds Exp $
+
+inherit perl-module eutils
+
+DESCRIPTION="save last.fm radio to mp3 files"
+HOMEPAGE="http://search.cpan.org/src/JOCHEN/last.fm-ripper-1.2/README"
+SRC_URI="mirror://cpan/authors/id/J/JO/JOCHEN/last.fm-ripper-${PV}.tar.gz"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="amazon tagwriting minimal"
+
+DEPEND="perl-core/Getopt-Long
+ perl-core/Digest-MD5
+ !minimal? ( dev-perl/Term-ReadPassword )
+ tagwriting? ( dev-perl/MP3-Tag )
+ amazon? ( dev-perl/MP3-Tag dev-perl/Net-Amazon )"
+
+S="${WORKDIR}/last.fm-ripper-${PV}"
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/UnescapedVariableFix.patch
+ epatch ${FILESDIR}/CoverOutputDirectoryFix.patch
+ epatch ${FILESDIR}/HandleSlashCharFix.patch
+ epatch ${FILESDIR}/URL-Handling-fix.patch
+}