summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-03-27 07:16:01 +0000
committerJustin Lecher <jlec@gentoo.org>2014-03-27 07:16:01 +0000
commitd17fababad88f9d2c4375f1f29d08c7fa9b09812 (patch)
tree4931d0c4c1b24b5483a7193573b2121f07107ca5 /media-sound
parentmedia-sound/lastfm-desktop: Backport patch for missing cast, #494190 (diff)
downloadgentoo-2-d17fababad88f9d2c4375f1f29d08c7fa9b09812.tar.gz
gentoo-2-d17fababad88f9d2c4375f1f29d08c7fa9b09812.tar.bz2
gentoo-2-d17fababad88f9d2c4375f1f29d08c7fa9b09812.zip
media-sound/lastfm-desktop: Backport patch for missing cast, #494190
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/lastfm-desktop/ChangeLog8
-rw-r--r--media-sound/lastfm-desktop/files/lastfm-desktop-2.1.36-missing-cast.patch25
-rw-r--r--media-sound/lastfm-desktop/lastfm-desktop-2.1.36.ebuild6
3 files changed, 35 insertions, 4 deletions
diff --git a/media-sound/lastfm-desktop/ChangeLog b/media-sound/lastfm-desktop/ChangeLog
index 4cbd247cd97f..8cc5829558d5 100644
--- a/media-sound/lastfm-desktop/ChangeLog
+++ b/media-sound/lastfm-desktop/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/lastfm-desktop
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lastfm-desktop/ChangeLog,v 1.3 2013/12/16 12:23:35 jlec Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lastfm-desktop/ChangeLog,v 1.4 2014/03/27 07:16:01 jlec Exp $
+
+ 27 Mar 2014; Justin Lecher <jlec@gentoo.org> lastfm-desktop-2.1.36.ebuild,
+ +files/lastfm-desktop-2.1.36-missing-cast.patch:
+ Backport patch for missing cast, #494190
16 Dec 2013; Justin Lecher <jlec@gentoo.org> lastfm-desktop-2.1.36.ebuild:
Add missing USE dep
diff --git a/media-sound/lastfm-desktop/files/lastfm-desktop-2.1.36-missing-cast.patch b/media-sound/lastfm-desktop/files/lastfm-desktop-2.1.36-missing-cast.patch
new file mode 100644
index 000000000000..12d19d36d3e9
--- /dev/null
+++ b/media-sound/lastfm-desktop/files/lastfm-desktop-2.1.36-missing-cast.patch
@@ -0,0 +1,25 @@
+From 192b979c57aa0b9a2df4f11ad4851ce4fbf5d38b Mon Sep 17 00:00:00 2001
+From: Spiek <spiek@ymail.com>
+Date: Fri, 27 Dec 2013 13:27:11 +0100
+Subject: [PATCH] Fix missing Cast
+
+---
+ app/client/Services/RadioService/RadioService.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/app/client/Services/RadioService/RadioService.cpp b/app/client/Services/RadioService/RadioService.cpp
+index 05f22c8..10094b6 100644
+--- a/app/client/Services/RadioService/RadioService.cpp
++++ b/app/client/Services/RadioService/RadioService.cpp
+@@ -307,7 +307,7 @@
+ void
+ RadioService::onPhononStateChanged( Phonon::State newstate, Phonon::State oldstate )
+ {
+- qDebug() << oldstate << " -> " << newstate;
++ qDebug() << (int)oldstate << " -> " << (int)newstate;
+ if (m_mediaObject == 0) {
+ qDebug() << "m_mediaObject is null!";
+ return;
+--
+1.8.5.5
+
diff --git a/media-sound/lastfm-desktop/lastfm-desktop-2.1.36.ebuild b/media-sound/lastfm-desktop/lastfm-desktop-2.1.36.ebuild
index 48044de17f48..6103ab2d6a2b 100644
--- a/media-sound/lastfm-desktop/lastfm-desktop-2.1.36.ebuild
+++ b/media-sound/lastfm-desktop/lastfm-desktop-2.1.36.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lastfm-desktop/lastfm-desktop-2.1.36.ebuild,v 1.2 2013/12/16 12:23:35 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lastfm-desktop/lastfm-desktop-2.1.36.ebuild,v 1.3 2014/03/27 07:16:01 jlec Exp $
EAPI=5
@@ -27,6 +27,8 @@ RDEPEND="
|| ( dev-qt/qtphonon:4 kde-base/phonon-kde:4 )"
DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}"/${P}-missing-cast.patch )
+
src_configure() {
eqmake4 Last.fm.pro PREFIX="${EPREFIX}"/usr
}