summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2009-02-11 20:32:01 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2009-02-11 20:32:01 +0000
commitc951728ba89b92b8a889ed9bf392e1cedef161da (patch)
treeeaf9ec4bd35af1eff5198d12df49b8f2c359edb1 /media-video/kplayer
parentFixes for #235410. (diff)
downloadgentoo-2-c951728ba89b92b8a889ed9bf392e1cedef161da.tar.gz
gentoo-2-c951728ba89b92b8a889ed9bf392e1cedef161da.tar.bz2
gentoo-2-c951728ba89b92b8a889ed9bf392e1cedef161da.zip
initial import of the KDE4 version, bug 254998
thanks to Marcel Hasler and Alex Alexander (Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'media-video/kplayer')
-rw-r--r--media-video/kplayer/ChangeLog9
-rw-r--r--media-video/kplayer/kplayer-0.7.ebuild39
2 files changed, 46 insertions, 2 deletions
diff --git a/media-video/kplayer/ChangeLog b/media-video/kplayer/ChangeLog
index 1c4bb133b3c6..42463f93fd33 100644
--- a/media-video/kplayer/ChangeLog
+++ b/media-video/kplayer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/kplayer
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/kplayer/ChangeLog,v 1.34 2008/01/12 00:25:32 carlo Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/kplayer/ChangeLog,v 1.35 2009/02/11 20:32:01 tampakrap Exp $
+
+*kplayer-0.7 (11 Feb 2009)
+
+ 11 Feb 2009; Theo Chatzimichos <tampakrap@gentoo.org> +kplayer-0.7.ebuild:
+ initial import of the KDE4 version
12 Jan 2008; Carsten Lohrke <carlo@gentoo.org>
+files/kplayer-0.6.3-desktop-entry.diff, kplayer-0.6.3.ebuild:
diff --git a/media-video/kplayer/kplayer-0.7.ebuild b/media-video/kplayer/kplayer-0.7.ebuild
new file mode 100644
index 000000000000..46bf0730e4ee
--- /dev/null
+++ b/media-video/kplayer/kplayer-0.7.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/kplayer/kplayer-0.7.ebuild,v 1.1 2009/02/11 20:32:01 tampakrap Exp $
+
+EAPI="2"
+
+KDE_LINGUAS="be br ca cs cy da de el en_GB es et eu fi fr ga gl he hu it ja nb
+ nds nl oc pa pl pt pt_BR ru sr sv tr zh_CN"
+inherit kde4-base
+
+DESCRIPTION="KPlayer is a KDE media player based on mplayer."
+HOMEPAGE="http://kplayer.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0.7"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=media-video/mplayer-1.0_rc1"
+DEPEND="${DEPEND}"
+
+src_prepare() {
+ # doc not working
+ sed -i \
+ -e "s:set(CMAKE_VERBOSE_MAKEFILE ON):#nada:g" \
+ -e "s:add_subdirectory(doc):#nada:g" \
+ "${S}"/CMakeLists.txt
+
+ # linking against X11 libraries
+ sed -i "s:target_link_libraries(kplayerpart :target_link_libraries(kplayerpart \${X11_LIBRARIES} :" \
+ "${S}"/kplayer/CMakeLists.txt
+
+ kde4-base_src_prepare
+}
+
+src_configure() {
+ cmake-utils_src_configurein
+}