summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-10-23 13:00:58 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-10-23 13:00:58 +0000
commit40178cc544a3df75be4b917d00f0eb25b754ad71 (patch)
tree5ad06469483ebefc1d8d121cf0216e042cf8bd16 /media-video/motion
parentamd64 stable wrt #289339 (diff)
downloadgentoo-2-40178cc544a3df75be4b917d00f0eb25b754ad71.tar.gz
gentoo-2-40178cc544a3df75be4b917d00f0eb25b754ad71.tar.bz2
gentoo-2-40178cc544a3df75be4b917d00f0eb25b754ad71.zip
amd64 stable wrt #288276
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'media-video/motion')
-rw-r--r--media-video/motion/ChangeLog6
-rw-r--r--media-video/motion/files/motion-3.2.11-offsett.patch13
-rw-r--r--media-video/motion/motion-3.2.11.1.ebuild4
-rw-r--r--media-video/motion/motion-3.2.11.ebuild69
4 files changed, 7 insertions, 85 deletions
diff --git a/media-video/motion/ChangeLog b/media-video/motion/ChangeLog
index 286ef6f21d98..3ef38c9e4dca 100644
--- a/media-video/motion/ChangeLog
+++ b/media-video/motion/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/motion
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/motion/ChangeLog,v 1.26 2009/10/09 09:40:37 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/motion/ChangeLog,v 1.27 2009/10/23 13:00:57 ssuominen Exp $
+
+ 23 Oct 2009; Samuli Suominen <ssuominen@gentoo.org>
+ motion-3.2.11.1.ebuild:
+ amd64 stable wrt #288276
*motion-3.2.11.1 (09 Oct 2009)
diff --git a/media-video/motion/files/motion-3.2.11-offsett.patch b/media-video/motion/files/motion-3.2.11-offsett.patch
deleted file mode 100644
index f3116abbc816..000000000000
--- a/media-video/motion/files/motion-3.2.11-offsett.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: motion-3.2.11/ffmpeg.c
-===================================================================
---- motion-3.2.11.orig/ffmpeg.c
-+++ motion-3.2.11/ffmpeg.c
-@@ -164,7 +164,7 @@ static int file_write(URLContext *h, uns
- return write(fd, buf, size);
- }
-
--static offset_t file_seek(URLContext *h, offset_t pos, int whence)
-+static int64_t file_seek(URLContext *h, int64_t pos, int whence)
- {
- int fd = (size_t)h->priv_data;
- return lseek(fd, pos, whence);
diff --git a/media-video/motion/motion-3.2.11.1.ebuild b/media-video/motion/motion-3.2.11.1.ebuild
index 907dab26ec1d..f364d4497e5a 100644
--- a/media-video/motion/motion-3.2.11.1.ebuild
+++ b/media-video/motion/motion-3.2.11.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/motion/motion-3.2.11.1.ebuild,v 1.1 2009/10/09 09:40:37 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/motion/motion-3.2.11.1.ebuild,v 1.2 2009/10/23 13:00:57 ssuominen Exp $
EAPI=2
inherit eutils
@@ -11,7 +11,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+KEYWORDS="~alpha amd64 ~ppc ~x86"
IUSE="ffmpeg mysql postgres v4l"
RDEPEND="sys-libs/zlib
diff --git a/media-video/motion/motion-3.2.11.ebuild b/media-video/motion/motion-3.2.11.ebuild
deleted file mode 100644
index 9f3d41da3dcd..000000000000
--- a/media-video/motion/motion-3.2.11.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/motion/motion-3.2.11.ebuild,v 1.5 2008/12/19 17:07:40 pva Exp $
-
-inherit eutils
-
-DESCRIPTION="Motion is a video motion detector with tracking-support for webcams."
-HOMEPAGE="http://www.lavrsen.dk/twiki/bin/view/Motion/WebHome"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~ppc ~x86"
-IUSE="ffmpeg mysql postgres v4l"
-
-DEPEND="sys-libs/zlib
- media-libs/jpeg
- ffmpeg? ( media-video/ffmpeg )
- mysql? ( virtual/mysql )
- postgres? ( virtual/postgresql-server )"
-
-pkg_setup() {
- enewuser motion -1 -1 -1 "video"
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/${P}-offsett.patch"
-}
-
-src_compile() {
- econf --without-optimizecpu \
- $(use_with v4l) \
- $(use_with mysql) \
- $(use_with postgres pgsql) \
- $(use_with ffmpeg)
-
- emake || die "emake failed."
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed."
-
- # Install init script.
- newinitd "${FILESDIR}"/motion.init-r1 motion
- newconfd "${FILESDIR}"/motion.confd motion
-
- # Create correct dir for motion.pid
- dodir /var/run/motion
- fowners motion:video /var/run/motion
- fperms 750 /var/run/motion
- keepdir /var/run/motion
-
- # Rename configuration file.
- mv "${D}"/etc/motion-dist.conf "${D}"/etc/motion.conf
-
- # Remove dummy documentation and install it using ebuild functions.
- rm -rf "${D}"/usr/share/doc/${P}
- dodoc CHANGELOG CODE_STANDARD CREDITS FAQ README README.FreeBSD *.conf
- dohtml *.html
-}
-
-pkg_postinst() {
- elog "You need to setup /etc/motion.conf before running"
- elog "motion for the first time. You can install motion"
- elog "detection as a service, use:"
- elog "rc-update add motion default"
-}