summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-08-10 10:41:26 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-08-10 10:41:26 +0000
commit71c0c0097292c3cd867d9bca7b32759b5e3a27e9 (patch)
treeaf831f6720d6e746a6a29fe845572167f043c3d4 /media-video/rtmpdump
parentMake dev-util/gtk-doc-am dependency mandatory (diff)
downloadgentoo-2-71c0c0097292c3cd867d9bca7b32759b5e3a27e9.tar.gz
gentoo-2-71c0c0097292c3cd867d9bca7b32759b5e3a27e9.tar.bz2
gentoo-2-71c0c0097292c3cd867d9bca7b32759b5e3a27e9.zip
Version bump per bug #376551 and live ebuild inclusion
(Portage version: 2.2.0_alpha46/cvs/Linux x86_64)
Diffstat (limited to 'media-video/rtmpdump')
-rw-r--r--media-video/rtmpdump/ChangeLog9
-rw-r--r--media-video/rtmpdump/rtmpdump-2.4.ebuild64
-rw-r--r--media-video/rtmpdump/rtmpdump-9999.ebuild64
3 files changed, 136 insertions, 1 deletions
diff --git a/media-video/rtmpdump/ChangeLog b/media-video/rtmpdump/ChangeLog
index 48d9ec1e1d04..3d37ee00ff7b 100644
--- a/media-video/rtmpdump/ChangeLog
+++ b/media-video/rtmpdump/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-video/rtmpdump
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/rtmpdump/ChangeLog,v 1.18 2011/07/07 03:57:22 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/rtmpdump/ChangeLog,v 1.19 2011/08/10 10:41:25 hwoarang Exp $
+
+*rtmpdump-9999 (10 Aug 2011)
+*rtmpdump-2.4 (10 Aug 2011)
+
+ 10 Aug 2011; Markos Chandras <hwoarang@gentoo.org> +rtmpdump-2.4.ebuild,
+ +rtmpdump-9999.ebuild:
+ Version bump per bug #376551 and live ebuild inclusion
07 Jul 2011; Alexis Ballier <aballier@gentoo.org> rtmpdump-2.3.ebuild:
keyword ~x86-fbsd
diff --git a/media-video/rtmpdump/rtmpdump-2.4.ebuild b/media-video/rtmpdump/rtmpdump-2.4.ebuild
new file mode 100644
index 000000000000..e9895814370f
--- /dev/null
+++ b/media-video/rtmpdump/rtmpdump-2.4.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/rtmpdump/rtmpdump-2.4.ebuild,v 1.1 2011/08/10 10:41:26 hwoarang Exp $
+
+EAPI="4"
+
+inherit multilib toolchain-funcs
+
+DESCRIPTION="Open source command-line RTMP client intended to stream audio or video flash content"
+HOMEPAGE="http://rtmpdump.mplayerhq.hu/"
+SRC_URI="http://dev.gentoo.org/~hwoarang/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="gnutls polarssl ssl"
+
+DEPEND="ssl? (
+ gnutls? ( net-libs/gnutls )
+ polarssl? ( !gnutls? ( >=net-libs/polarssl-0.14.0 ) )
+ !gnutls? ( !polarssl? ( dev-libs/openssl ) )
+ )
+ sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ if ! use ssl && ( use gnutls || use polarssl ) ; then
+ ewarn "USE='gnutls polarssl' are ignored without USE='ssl'."
+ ewarn "Please review the local USE flags for this package."
+ fi
+}
+
+src_prepare() {
+ # fix Makefile ( bug #298535 , bug #318353 and bug #324513 )
+ sed -i 's/\$(MAKEFLAGS)//g' Makefile \
+ || die "failed to fix Makefile"
+ sed -i -e 's:OPT=:&-fPIC :' \
+ -e 's:OPT:OPTS:' \
+ -e 's:CFLAGS=.*:& $(OPT):' librtmp/Makefile \
+ || die "failed to fix Makefile"
+}
+
+src_compile() {
+ if use ssl ; then
+ if use gnutls ; then
+ crypto="GNUTLS"
+ elif use polarssl ; then
+ crypto="POLARSSL"
+ else
+ crypto="OPENSSL"
+ fi
+ fi
+ #fix multilib-script support. Bug #327449
+ sed -i "/^libdir/s:lib$:$(get_libdir)$:" librtmp/Makefile
+ emake CC=$(tc-getCC) LD=$(tc-getLD) \
+ OPT="${CFLAGS}" XLDFLAGS="${LDFLAGS}" CRYPTO="${crypto}" SYS=posix
+}
+
+src_install() {
+ mkdir -p "${D}"/${DESTTREE}/$(get_libdir)
+ emake DESTDIR="${D}" prefix="${DESTTREE}" mandir="${DESTTREE}/share/man" \
+ CRYPTO="${crypto}" install
+ dodoc README ChangeLog rtmpdump.1.html rtmpgw.8.html
+}
diff --git a/media-video/rtmpdump/rtmpdump-9999.ebuild b/media-video/rtmpdump/rtmpdump-9999.ebuild
new file mode 100644
index 000000000000..b5fbfa90d8cf
--- /dev/null
+++ b/media-video/rtmpdump/rtmpdump-9999.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/rtmpdump/rtmpdump-9999.ebuild,v 1.1 2011/08/10 10:41:26 hwoarang Exp $
+
+EAPI="4"
+
+inherit git-2 multilib toolchain-funcs
+
+DESCRIPTION="Open source command-line RTMP client intended to stream audio or video flash content"
+HOMEPAGE="http://rtmpdump.mplayerhq.hu/"
+EGIT_REPO_URI="git://git.ffmpeg.org/rtmpdump"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="gnutls polarssl ssl"
+
+DEPEND="ssl? (
+ gnutls? ( net-libs/gnutls )
+ polarssl? ( !gnutls? ( >=net-libs/polarssl-0.14.0 ) )
+ !gnutls? ( !polarssl? ( dev-libs/openssl ) )
+ )
+ sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ if ! use ssl && ( use gnutls || use polarssl ) ; then
+ ewarn "USE='gnutls polarssl' are ignored without USE='ssl'."
+ ewarn "Please review the local USE flags for this package."
+ fi
+}
+
+src_prepare() {
+ # fix Makefile ( bug #298535 , bug #318353 and bug #324513 )
+ sed -i 's/\$(MAKEFLAGS)//g' Makefile \
+ || die "failed to fix Makefile"
+ sed -i -e 's:OPT=:&-fPIC :' \
+ -e 's:OPT:OPTS:' \
+ -e 's:CFLAGS=.*:& $(OPT):' librtmp/Makefile \
+ || die "failed to fix Makefile"
+}
+
+src_compile() {
+ if use ssl ; then
+ if use gnutls ; then
+ crypto="GNUTLS"
+ elif use polarssl ; then
+ crypto="POLARSSL"
+ else
+ crypto="OPENSSL"
+ fi
+ fi
+ #fix multilib-script support. Bug #327449
+ sed -i "/^libdir/s:lib$:$(get_libdir)$:" librtmp/Makefile
+ emake CC=$(tc-getCC) LD=$(tc-getLD) \
+ OPT="${CFLAGS}" XLDFLAGS="${LDFLAGS}" CRYPTO="${crypto}" SYS=posix
+}
+
+src_install() {
+ mkdir -p "${D}"/${DESTTREE}/$(get_libdir)
+ emake DESTDIR="${D}" prefix="${DESTTREE}" mandir="${DESTTREE}/share/man" \
+ CRYPTO="${crypto}" install
+ dodoc README ChangeLog rtmpdump.1.html rtmpgw.8.html
+}