summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2009-11-22 23:31:34 +0000
committerJeroen Roovers <jer@gentoo.org>2009-11-22 23:31:34 +0000
commitad73b8b54e2d9856d2365b4675452e9c9d8de1c4 (patch)
tree4dad9974f70ed4c8c1e90f0c5ac766077397c4b1 /net-analyzer/netwox
parentadd initial ebuild based on qemu-0.11.0 (diff)
downloadgentoo-2-ad73b8b54e2d9856d2365b4675452e9c9d8de1c4.tar.gz
gentoo-2-ad73b8b54e2d9856d2365b4675452e9c9d8de1c4.tar.bz2
gentoo-2-ad73b8b54e2d9856d2365b4675452e9c9d8de1c4.zip
Version bump. Respect LDFLAGS. Support parallel make. Run genemake in src_configure, and through sh (bug #294069). Use emake to install. Marked ~hppa too.
(Portage version: 2.2_rc51/cvs/Linux i686)
Diffstat (limited to 'net-analyzer/netwox')
-rw-r--r--net-analyzer/netwox/ChangeLog11
-rw-r--r--net-analyzer/netwox/netwox-5.36.0.ebuild62
2 files changed, 71 insertions, 2 deletions
diff --git a/net-analyzer/netwox/ChangeLog b/net-analyzer/netwox/ChangeLog
index bcfedd15b61e..b8efdd9ad24c 100644
--- a/net-analyzer/netwox/ChangeLog
+++ b/net-analyzer/netwox/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/netwox
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netwox/ChangeLog,v 1.27 2007/04/16 08:31:09 welp Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netwox/ChangeLog,v 1.28 2009/11/22 23:31:34 jer Exp $
+
+*netwox-5.36.0 (22 Nov 2009)
+
+ 22 Nov 2009; Jeroen Roovers <jer@gentoo.org> +netwox-5.36.0.ebuild:
+ Version bump. Respect LDFLAGS. Support parallel make. Run genemake in
+ src_configure, and through sh (bug #294069). Use emake to install. Marked
+ ~hppa too.
16 Apr 2007; <welp@gentoo.org> netwox-5.33.0.ebuild:
Keyworded ~amd64
diff --git a/net-analyzer/netwox/netwox-5.36.0.ebuild b/net-analyzer/netwox/netwox-5.36.0.ebuild
new file mode 100644
index 000000000000..9feb6a97e188
--- /dev/null
+++ b/net-analyzer/netwox/netwox-5.36.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netwox/netwox-5.36.0.ebuild,v 1.1 2009/11/22 23:31:34 jer Exp $
+
+# NOTE: netwib, netwox and netwag go together, bump all or bump none
+
+EAPI="2"
+
+inherit toolchain-funcs multilib
+
+DESCRIPTION="Toolbox of 217 utilities for testing Ethernet/IP networks"
+HOMEPAGE="http://www.laurentconstantin.com/en/netw/netwox/"
+BASEURI="http://www.laurentconstantin.com/common/netw/${PN}/download/"
+SRC_URI="
+ ${BASEURI}v${PV/.*}/${P}-src.tgz
+ doc? ( ${BASEURI}v${PV/.*}/${P}-doc_html.tgz )
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="doc"
+
+RDEPEND=">=net-libs/libnet-1.1.1"
+
+DEPEND="net-libs/libpcap
+ ~net-libs/netwib-${PV}
+ ${RDEPEND}"
+
+S="${WORKDIR}/${P}-src/src"
+
+src_prepare() {
+ sed -i \
+ -e 's:/man$:/share/man:g' \
+ -e "s:/lib:/$(get_libdir):" \
+ -e "s:/usr/local:/usr:" \
+ -e "s:=ar:=$(tc-getAR):" \
+ -e "s:=ranlib:=$(tc-getRANLIB):" \
+ -e "s:=gcc:=$(tc-getCC):" \
+ -e "s:-O2:${CFLAGS}:" \
+ config.dat || die "patching config.dat failed"
+ sed -i \
+ -e "s:\$(GCCOPT):& \${LDFLAGS}:g" \
+ -e 's: ; make: ; \\$(MAKE):g' \
+ genemake || die "patching genemake failed"
+}
+
+src_configure() {
+ sh genemake || die "problem creating Makefile"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "install failed"
+ dodoc ../README.TXT
+ if use doc;
+ then
+ mv "${WORKDIR}"/${P}-doc_html "${D}"/usr/share/doc/${PF}/html
+ else
+ dodoc "${S}"/../doc/{changelog.txt,credits.txt} \
+ "${S}"/../doc/{problemreport.txt,problemusageunix.txt,todo.txt}
+ fi
+}