summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-06-01 02:28:58 +0000
committerJeroen Roovers <jer@gentoo.org>2011-06-01 02:28:58 +0000
commit59879003583f12595930bfa6ec5b919e5b1acc8b (patch)
tree4cca3bf8823eced554fca6ce77d4d9a7979901c9 /net-analyzer/rrdtool
parentVersion bump. (diff)
downloadgentoo-2-59879003583f12595930bfa6ec5b919e5b1acc8b.tar.gz
gentoo-2-59879003583f12595930bfa6ec5b919e5b1acc8b.tar.bz2
gentoo-2-59879003583f12595930bfa6ec5b919e5b1acc8b.zip
Version bump.
(Portage version: 2.2.0_alpha37/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/rrdtool')
-rw-r--r--net-analyzer/rrdtool/ChangeLog7
-rw-r--r--net-analyzer/rrdtool/rrdtool-1.4.5.ebuild97
2 files changed, 103 insertions, 1 deletions
diff --git a/net-analyzer/rrdtool/ChangeLog b/net-analyzer/rrdtool/ChangeLog
index 5ba3aaeb5f29..9a221e5671c1 100644
--- a/net-analyzer/rrdtool/ChangeLog
+++ b/net-analyzer/rrdtool/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/rrdtool
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/ChangeLog,v 1.208 2011/01/10 18:15:47 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/ChangeLog,v 1.209 2011/06/01 02:28:58 jer Exp $
+
+*rrdtool-1.4.5 (01 Jun 2011)
+
+ 01 Jun 2011; Jeroen Roovers <jer@gentoo.org> +rrdtool-1.4.5.ebuild:
+ Version bump.
10 Jan 2011; Hans de Graaff <graaff@gentoo.org> rrdtool-1.4.4.ebuild:
Keyword ~x86-macos.
diff --git a/net-analyzer/rrdtool/rrdtool-1.4.5.ebuild b/net-analyzer/rrdtool/rrdtool-1.4.5.ebuild
new file mode 100644
index 000000000000..0ea6be6ccf4b
--- /dev/null
+++ b/net-analyzer/rrdtool/rrdtool-1.4.5.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/rrdtool-1.4.5.ebuild,v 1.1 2011/06/01 02:28:58 jer Exp $
+
+EAPI="3"
+
+GENTOO_DEPEND_ON_PERL="no"
+inherit eutils flag-o-matic multilib perl-module autotools
+
+DESCRIPTION="A system to store and display time-series data"
+HOMEPAGE="http://oss.oetiker.ch/rrdtool/"
+SRC_URI="http://oss.oetiker.ch/rrdtool/pub/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos ~x86-solaris"
+IUSE="doc lua perl python ruby rrdcgi tcl"
+
+# This versions are minimal versions upstream tested with.
+RDEPEND="
+ >=media-libs/libpng-1.2.10
+ >=dev-libs/libxml2-2.6.31
+ >=x11-libs/cairo-1.4.6[svg]
+ >=dev-libs/glib-2.12.12
+ >=x11-libs/pango-1.17
+ lua? ( dev-lang/lua )
+ perl? ( dev-lang/perl )
+ python? ( dev-lang/python )
+ ruby? ( >=dev-lang/ruby-1.8.6_p287-r13 !dev-ruby/ruby-rrd )
+ tcl? ( dev-lang/tcl )"
+
+DEPEND="${RDEPEND}
+ sys-apps/gawk"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.3.8-configure.ac.patch"
+# epatch "${FILESDIR}/${PN}-1.4.3-ruby-ldflags.patch"
+ epatch "${FILESDIR}/${PN}-1.4.4-dont-link-system-lib.patch"
+ sed -i '/PERLLD/s:same as PERLCC:same-as-PERLCC:' configure.ac #281694
+ eautoreconf
+}
+
+src_configure() {
+ filter-flags -ffast-math
+
+ export RRDDOCDIR=${EPREFIX}/usr/share/doc/${PF}
+
+ # to solve bug #260380
+ [[ ${CHOST} == *-solaris* ]] && append-flags -D__EXTENSIONS__
+
+ econf $(use_enable rrdcgi) \
+ $(use_enable lua) \
+ $(use_enable lua lua-site-install) \
+ $(use_enable ruby) \
+ $(use_enable ruby ruby-site-install) \
+ $(use_enable perl) \
+ $(use_enable perl perl-site-install) \
+ --with-perl-options=INSTALLDIRS=vendor \
+ $(use_enable tcl) \
+ $(use_with tcl tcllib "${EPREFIX}"/usr/$(get_libdir)) \
+ $(use_enable python)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ if ! use doc ; then
+ rm -rf "${ED}"usr/share/doc/${PF}/{html,txt}
+ fi
+
+ if use !rrdcgi ; then
+ # uses rrdcgi, causes invalid shebang error in Prefix, useless
+ # without rrdcgi installed
+ rm -f "${ED}"usr/share/${PN}/examples/cgi-demo.cgi
+ fi
+
+ if use perl ; then
+ perl_delete_localpod
+ perl_delete_packlist
+ fi
+
+ dodoc CHANGES CONTRIBUTORS NEWS README THREADS TODO
+}
+
+pkg_postinst() {
+ ewarn "rrdtool dump 1.3 does emit completely legal xml. Basically this means that"
+ ewarn "it contains an xml header and a DOCTYPE definition. Unfortunately this"
+ ewarn "causes older versions of rrdtool restore to be unhappy."
+ ewarn
+ ewarn "To restore a new dump with an old rrdtool restore version, either remove"
+ ewarn "the xml header and the doctype by hand (both on the first line of the dump)"
+ ewarn "or use rrdtool dump --no-header."
+ ewarn
+ ewarn "Note: rrdtool-1.3.x doesn't have any default font bundled. Thus if you've"
+ ewarn "upgraded from rrdtool-1.2.x and don't have any font installed to make"
+ ewarn "lables visible, please, install some font, e.g. media-fonts/dejavu."
+}