summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2006-11-29 21:25:16 +0000
committerCédric Krier <cedk@gentoo.org>2006-11-29 21:25:16 +0000
commit48281654024e44ca53dfaafe8e05627828d55500 (patch)
treee3aa38332146dcadc8c569f2a6948a3eee238d03 /net-analyzer
parentFinally add (hopefully) working PIC-patches, Bug #121871. (diff)
downloadgentoo-2-48281654024e44ca53dfaafe8e05627828d55500.tar.gz
gentoo-2-48281654024e44ca53dfaafe8e05627828d55500.tar.bz2
gentoo-2-48281654024e44ca53dfaafe8e05627828d55500.zip
Fix autotools for bug #151140
(Portage version: 2.1.1-r1)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/nagios-plugins/ChangeLog6
-rw-r--r--net-analyzer/nagios-plugins/nagios-plugins-1.4.2-r1.ebuild29
-rw-r--r--net-analyzer/nagios-plugins/nagios-plugins-1.4.2.ebuild12
-rw-r--r--net-analyzer/nagios-plugins/nagios-plugins-1.4.3-r1.ebuild30
4 files changed, 50 insertions, 27 deletions
diff --git a/net-analyzer/nagios-plugins/ChangeLog b/net-analyzer/nagios-plugins/ChangeLog
index 8c5435cf681e..d6593352caf8 100644
--- a/net-analyzer/nagios-plugins/ChangeLog
+++ b/net-analyzer/nagios-plugins/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/nagios-plugins
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-plugins/ChangeLog,v 1.54 2006/11/23 19:51:53 vivo Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-plugins/ChangeLog,v 1.55 2006/11/29 21:25:16 cedk Exp $
+
+ 29 Nov 2006; Cedric Krier <cedk@gentoo.org> nagios-plugins-1.4.2.ebuild,
+ nagios-plugins-1.4.2-r1.ebuild, nagios-plugins-1.4.3-r1.ebuild:
+ Fix autotools for bug #151140
23 Nov 2006; Francesco Riosa <vivo@gentoo.org>
nagios-plugins-1.3.1-r1.ebuild, nagios-plugins-1.4.ebuild,
diff --git a/net-analyzer/nagios-plugins/nagios-plugins-1.4.2-r1.ebuild b/net-analyzer/nagios-plugins/nagios-plugins-1.4.2-r1.ebuild
index 63f867b51afc..7a1c03b9a1f7 100644
--- a/net-analyzer/nagios-plugins/nagios-plugins-1.4.2-r1.ebuild
+++ b/net-analyzer/nagios-plugins/nagios-plugins-1.4.2-r1.ebuild
@@ -1,8 +1,11 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-plugins/nagios-plugins-1.4.2-r1.ebuild,v 1.6 2006/11/23 19:51:53 vivo Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-plugins/nagios-plugins-1.4.2-r1.ebuild,v 1.7 2006/11/29 21:25:16 cedk Exp $
-inherit eutils
+WANT_AUTOCONF=2.58
+WANT_AUTOMAKE=1.8
+
+inherit eutils autotools
DESCRIPTION="Nagios $PV plugins - Pack of plugins to make Nagios work properly"
HOMEPAGE="http://www.nagios.org/"
@@ -44,26 +47,32 @@ pkg_setup() {
src_unpack() {
unpack ${A}
+ cd "${S}"
if ! use radius; then
- EPATCH_OPTS="-p0 -d ${S}" epatch ${FILESDIR}/nagios-plugins-1.4-noradius.patch
+ EPATCH_OPTS="-p0 -d ${S}" epatch ${FILESDIR}/nagios-plugins-1.4-noradius.patch \
+ "${FILESDIR}"/nagios-plugins-1.4-autoconf-fix.patch
fi
if ! use radius; then
- export WANT_AUTOCONF=2.5
- export WANT_AUTMAKE=1.8
- cd ${S}
- aclocal -I m4 || die "Failed to run aclocal"
- autoconf || die "Failed to run autoconf"
- automake || die "Failed to run automake"
+ eaclocal -I m4 || die "eaclocal failed"
+ eautoconf || die "eautoconf failed"
+ automake || die "automake failed"
fi
}
src_compile() {
+ local conf
+ if use ssl; then
+ conf="${conf} --with-openssl=/usr"
+ else
+ conf="${conf} --without-openssl"
+ fi
+
econf \
$(use_with mysql) \
$(use_with postgres) \
- $(use_with ssl openssl) \
$(use_with ipv6) \
+ ${conf} \
--host=${CHOST} \
--prefix=/usr/nagios \
--with-nagios-user=nagios \
diff --git a/net-analyzer/nagios-plugins/nagios-plugins-1.4.2.ebuild b/net-analyzer/nagios-plugins/nagios-plugins-1.4.2.ebuild
index af03d75a12ed..43e7869dfd48 100644
--- a/net-analyzer/nagios-plugins/nagios-plugins-1.4.2.ebuild
+++ b/net-analyzer/nagios-plugins/nagios-plugins-1.4.2.ebuild
@@ -1,8 +1,11 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-plugins/nagios-plugins-1.4.2.ebuild,v 1.8 2006/11/23 19:51:53 vivo Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-plugins/nagios-plugins-1.4.2.ebuild,v 1.9 2006/11/29 21:25:16 cedk Exp $
-inherit eutils
+WANT_AUTOCONF=2.58
+WANT_AUTOMAKE=1.8
+
+inherit eutils autotools
DESCRIPTION="Nagios $PV plugins - Pack of plugins to make Nagios work properly"
HOMEPAGE="http://www.nagios.org/"
@@ -44,11 +47,10 @@ pkg_setup() {
src_unpack() {
unpack ${A}
if ! use radius; then
- EPATCH_OPTS="-p0 -d ${S}" epatch ${FILESDIR}/nagios-plugins-1.4-noradius.patch
+ EPATCH_OPTS="-p0 -d ${S}" epatch ${FILESDIR}/nagios-plugins-1.4-noradius.patch \
+ "${FILESDIR}"/nagios-plugins-1.4-autoconf-fix.patch
fi
if ! use radius; then
- export WANT_AUTOCONF=2.5
- export WANT_AUTMAKE=1.8
cd ${S}
aclocal -I m4 || die "Failed to run aclocal"
autoconf || die "Failed to run autoconf"
diff --git a/net-analyzer/nagios-plugins/nagios-plugins-1.4.3-r1.ebuild b/net-analyzer/nagios-plugins/nagios-plugins-1.4.3-r1.ebuild
index 4fff72b37e33..523e5497c524 100644
--- a/net-analyzer/nagios-plugins/nagios-plugins-1.4.3-r1.ebuild
+++ b/net-analyzer/nagios-plugins/nagios-plugins-1.4.3-r1.ebuild
@@ -1,8 +1,11 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-plugins/nagios-plugins-1.4.3-r1.ebuild,v 1.4 2006/11/23 19:51:53 vivo Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-plugins/nagios-plugins-1.4.3-r1.ebuild,v 1.5 2006/11/29 21:25:16 cedk Exp $
-inherit eutils
+WANT_AUTOCONF=2.58
+WANT_AUTOMAKE=1.8
+
+inherit eutils autotools
DESCRIPTION="Nagios $PV plugins - Pack of plugins to make Nagios work properly"
HOMEPAGE="http://www.nagios.org/"
@@ -44,6 +47,7 @@ pkg_setup() {
src_unpack() {
unpack ${A}
+ cd "${S}"
if ! use radius; then
EPATCH_OPTS="-p0 -d ${S}" epatch \
${FILESDIR}/nagios-plugins-1.4-noradius.patch \
@@ -55,23 +59,27 @@ src_unpack() {
${FILESDIR}/nagios-plugins-1.4.3-check_disk-fix.patch
if ! use radius; then
- export WANT_AUTOCONF=2.5
- export WANT_AUTMAKE=1.8
- cd ${S}
- aclocal -I m4 || die "Failed to run aclocal"
- autoconf || die "Failed to run autoconf"
- automake || die "Failed to run automake"
- libtoolize --copy --force
+ eaclocal -I m4 || die "eaclocal failed"
+ eautoconf || die "eautoconf failed"
+ automake || die "automake failed"
+ libtoolize --copy --force || die "libtoolize failed"
fi
}
src_compile() {
+ local conf
+ if use ssl; then
+ conf="${conf} --with-openssl=/usr"
+ else
+ conf="${conf} --without-openssl"
+ fi
+
econf \
$(use_with mysql) \
$(use_with postgres) \
- $(use_with ssl openssl) \
$(use_with ipv6) \
+ ${conf} \
--host=${CHOST} \
--prefix=/usr/nagios \
--with-nagios-user=nagios \
@@ -96,7 +104,7 @@ src_install() {
dodoc ABOUT-NLS ACKNOWLEDGEMENTS AUTHORS BUGS CHANGES CODING COPYING \
Changelog FAQ INSTALL LEGAL NEWS README REQUIREMENTS SUPPORT
- make DESTDIR="${D}" install || die "make install failed"
+ emake DESTDIR="${D}" install || die "make install failed"
if use mysql || use postgres; then
dodir /usr/nagios/libexec