summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-07-03 14:11:48 +0000
committerJeroen Roovers <jer@gentoo.org>2013-07-03 14:11:48 +0000
commit4de3bb325fd59f11c856dfea1f3ded49ec37a574 (patch)
tree3f45c85007a9f4c680de9bf7ecbe164012954c8a /net-analyzer
parentVersion bump. (diff)
downloadgentoo-2-4de3bb325fd59f11c856dfea1f3ded49ec37a574.tar.gz
gentoo-2-4de3bb325fd59f11c856dfea1f3ded49ec37a574.tar.bz2
gentoo-2-4de3bb325fd59f11c856dfea1f3ded49ec37a574.zip
Version bump.
(Portage version: 2.2.0_alpha186/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/argus-clients/ChangeLog8
-rw-r--r--net-analyzer/argus-clients/argus-clients-3.0.7.10.ebuild64
2 files changed, 70 insertions, 2 deletions
diff --git a/net-analyzer/argus-clients/ChangeLog b/net-analyzer/argus-clients/ChangeLog
index 50a323027f4d..30651f895eae 100644
--- a/net-analyzer/argus-clients/ChangeLog
+++ b/net-analyzer/argus-clients/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/argus-clients
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/argus-clients/ChangeLog,v 1.54 2013/07/03 14:03:54 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/argus-clients/ChangeLog,v 1.55 2013/07/03 14:11:48 jer Exp $
+
+*argus-clients-3.0.7.10 (03 Jul 2013)
+
+ 03 Jul 2013; Jeroen Roovers <jer@gentoo.org> +argus-clients-3.0.7.10.ebuild:
+ Version bump.
*argus-clients-3.0.7.9 (03 Jul 2013)
@@ -271,4 +276,3 @@
08 Jan 2006; Marcelo Goes <vanquirius@gentoo.org> +metadata.xml,
+argus-clients-2.0.6.ebuild:
Initial commit. Fixes bug 112157. Thanks to aqu <aqu3l at go2 dot pl>.
-
diff --git a/net-analyzer/argus-clients/argus-clients-3.0.7.10.ebuild b/net-analyzer/argus-clients/argus-clients-3.0.7.10.ebuild
new file mode 100644
index 000000000000..89eda5a51591
--- /dev/null
+++ b/net-analyzer/argus-clients/argus-clients-3.0.7.10.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/argus-clients/argus-clients-3.0.7.10.ebuild,v 1.1 2013/07/03 14:11:48 jer Exp $
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="Clients for net-analyzer/argus"
+HOMEPAGE="http://www.qosient.com/argus/"
+SRC_URI="http://qosient.com/argus/dev/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug ft geoip mysql sasl tcpd"
+
+MY_CDEPEND="
+ net-analyzer/rrdtool[perl]
+ net-libs/libpcap
+ sys-libs/ncurses
+ sys-libs/readline
+ ft? ( net-analyzer/flow-tools )
+ geoip? ( dev-libs/geoip )
+ mysql? ( virtual/mysql )
+ sasl? ( dev-libs/cyrus-sasl )
+"
+
+RDEPEND="
+ ${MY_CDEPEND}
+"
+
+DEPEND="
+ ${MY_CDEPEND}
+ sys-devel/bison
+ sys-devel/flex
+"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-3.0.4.1-disable-tcp-wrappers-automagic.patch \
+ "${FILESDIR}"/${PN}-3.0.7.4-overflow.patch
+ eautoreconf
+}
+
+src_configure() {
+ use debug && touch .debug
+ econf \
+ $(use_with ft libft) \
+ $(use_with geoip GeoIP /usr/) \
+ $(use_with sasl) \
+ $(use_with tcpd wrappers) \
+ $(use_with mysql)
+}
+
+src_compile() {
+ emake CCOPT="${CFLAGS} ${LDFLAGS}"
+}
+
+src_install() {
+ # argus_parse.a and argus_common.a are supplied by net-analyzer/argus
+ dobin bin/ra*
+ dodoc ChangeLog CREDITS README CHANGES
+ doman man/man{1,5}/*
+}