summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-07-03 14:07:32 +0000
committerJeroen Roovers <jer@gentoo.org>2013-07-03 14:07:32 +0000
commit7791b41889f4faace1e5148b637b3e85769ae83a (patch)
treef431b0284c16b735c5c084fb78fe7c502f744a43 /net-analyzer
parentVersion bump. (diff)
downloadgentoo-2-7791b41889f4faace1e5148b637b3e85769ae83a.tar.gz
gentoo-2-7791b41889f4faace1e5148b637b3e85769ae83a.tar.bz2
gentoo-2-7791b41889f4faace1e5148b637b3e85769ae83a.zip
Version bump.
(Portage version: 2.2.0_alpha186/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/argus/ChangeLog8
-rw-r--r--net-analyzer/argus/argus-3.0.7.3.ebuild78
-rw-r--r--net-analyzer/argus/files/argus-3.0.7.3-DLT_IPNET.patch17
3 files changed, 102 insertions, 1 deletions
diff --git a/net-analyzer/argus/ChangeLog b/net-analyzer/argus/ChangeLog
index fc7df3096536..74f634ebfcce 100644
--- a/net-analyzer/argus/ChangeLog
+++ b/net-analyzer/argus/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/argus
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/argus/ChangeLog,v 1.56 2013/03/10 14:57:13 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/argus/ChangeLog,v 1.57 2013/07/03 14:07:32 jer Exp $
+
+*argus-3.0.7.3 (03 Jul 2013)
+
+ 03 Jul 2013; Jeroen Roovers <jer@gentoo.org> +argus-3.0.7.3.ebuild,
+ +files/argus-3.0.7.3-DLT_IPNET.patch:
+ Version bump.
*argus-3.0.7.2 (10 Mar 2013)
diff --git a/net-analyzer/argus/argus-3.0.7.3.ebuild b/net-analyzer/argus/argus-3.0.7.3.ebuild
new file mode 100644
index 000000000000..61ba9ab99de6
--- /dev/null
+++ b/net-analyzer/argus/argus-3.0.7.3.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/argus/argus-3.0.7.3.ebuild,v 1.1 2013/07/03 14:07:32 jer Exp $
+
+EAPI="4"
+inherit autotools eutils user
+
+DESCRIPTION="network Audit Record Generation and Utilization System"
+HOMEPAGE="http://www.qosient.com/argus/"
+SRC_URI="http://qosient.com/argus/dev/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="debug sasl tcpd"
+
+RDEPEND="
+ net-libs/libpcap
+ sys-libs/zlib
+ sasl? ( dev-libs/cyrus-sasl )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
+"
+
+DEPEND="
+ ${RDEPEND}
+ >=sys-devel/bison-1.28
+ >=sys-devel/flex-2.4.6
+"
+
+src_prepare() {
+ sed -e 's:/etc/argus.conf:/etc/argus/argus.conf:' \
+ -i argus/argus.c \
+ -i support/Config/argus.conf \
+ -i man/man8/argus.8 \
+ -i man/man5/argus.conf.5 || die
+
+ sed -e 's:#\(ARGUS_SETUSER_ID=\).*:\1argus:' \
+ -e 's:#\(ARGUS_SETGROUP_ID=\).*:\1argus:' \
+ -e 's:\(#ARGUS_CHROOT_DIR=\).*:\1/var/lib/argus:' \
+ -i support/Config/argus.conf || die
+ epatch \
+ "${FILESDIR}"/${PN}-3.0.4-disable-tcp-wrappers-automagic.patch \
+ "${FILESDIR}"/${PN}-3.0.5-Makefile.patch \
+ "${FILESDIR}"/${P}-DLT_IPNET.patch
+ eautoreconf
+}
+
+src_configure() {
+ use debug && touch .debug # enable debugging
+ econf $(use_with tcpd wrappers) $(use_with sasl)
+}
+
+src_compile() {
+ emake CCOPT="${CFLAGS} ${LDFLAGS}"
+}
+
+src_install () {
+ doman man/man5/* man/man8/*
+ dosbin bin/argus{,bug}
+
+ dodoc ChangeLog CREDITS README
+
+ insinto /etc/argus
+ doins support/Config/argus.conf
+
+ newinitd "${FILESDIR}/argus.initd" argus
+ dodir /var/lib/argus
+}
+
+pkg_preinst() {
+ enewgroup argus
+ enewuser argus -1 -1 /var/lib/argus argus
+}
+
+pkg_postinst() {
+ elog "Note, if you modify ARGUS_DAEMON value in argus.conf it's quite"
+ elog "possible that init script will fail to work."
+}
diff --git a/net-analyzer/argus/files/argus-3.0.7.3-DLT_IPNET.patch b/net-analyzer/argus/files/argus-3.0.7.3-DLT_IPNET.patch
new file mode 100644
index 000000000000..f7b4bfa4cc6c
--- /dev/null
+++ b/net-analyzer/argus/files/argus-3.0.7.3-DLT_IPNET.patch
@@ -0,0 +1,17 @@
+In file included from ./ArgusModeler.h:330:0,
+ from ./argus.h:40,
+ from ArgusSource.c:67:
+./ArgusSource.h:893:6: error: ‘ArgusIpNetPacket’ undeclared here (not in a function)
+
+--- a/argus/ArgusSource.h
++++ b/argus/ArgusSource.h
+@@ -889,9 +889,6 @@
+ #ifdef DLT_JUNIPER_ETHER
+ { ArgusJuniperPacket, DLT_JUNIPER_ETHER, "ArgusJuniperPacket()" },
+ #endif
+-#ifdef DLT_IPNET
+- { ArgusIpNetPacket, DLT_IPNET, "ArgusIpNetPacket()" },
+-#endif
+ { NULL, DLT_NULL, "" },
+ #endif
+ { NULL, 0, NULL},