summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2011-02-05 13:45:38 +0000
committerChristian Ruppert <idl0r@gentoo.org>2011-02-05 13:45:38 +0000
commitea57a53499284251e920cf558cf87466c0a85c95 (patch)
tree49b49c1ccb506f5278cf97795e1ac536d33b4a0a /net-dns/bind-tools
parentVersion bump to 9.6.3. (diff)
downloadgentoo-2-ea57a53499284251e920cf558cf87466c0a85c95.tar.gz
gentoo-2-ea57a53499284251e920cf558cf87466c0a85c95.tar.bz2
gentoo-2-ea57a53499284251e920cf558cf87466c0a85c95.zip
Version bump to 9.6.3.
(Portage version: 2.2.0_alpha20/cvs/Linux x86_64)
Diffstat (limited to 'net-dns/bind-tools')
-rw-r--r--net-dns/bind-tools/ChangeLog7
-rw-r--r--net-dns/bind-tools/bind-tools-9.6.3.ebuild98
2 files changed, 104 insertions, 1 deletions
diff --git a/net-dns/bind-tools/ChangeLog b/net-dns/bind-tools/ChangeLog
index 1ea9a6432ee3..a0df344bb4bd 100644
--- a/net-dns/bind-tools/ChangeLog
+++ b/net-dns/bind-tools/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dns/bind-tools
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/bind-tools/ChangeLog,v 1.180 2011/01/13 21:37:50 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/bind-tools/ChangeLog,v 1.181 2011/02/05 13:45:38 idl0r Exp $
+
+*bind-tools-9.6.3 (05 Feb 2011)
+
+ 05 Feb 2011; Christian Ruppert <idl0r@gentoo.org> +bind-tools-9.6.3.ebuild:
+ Version bump to 9.6.3.
13 Jan 2011; Brent Baude <ranger@gentoo.org>
bind-tools-9.6.2_p2-r2.ebuild, bind-tools-9.7.2_p2-r2.ebuild:
diff --git a/net-dns/bind-tools/bind-tools-9.6.3.ebuild b/net-dns/bind-tools/bind-tools-9.6.3.ebuild
new file mode 100644
index 000000000000..e523a57e419c
--- /dev/null
+++ b/net-dns/bind-tools/bind-tools-9.6.3.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/bind-tools/bind-tools-9.6.3.ebuild,v 1.1 2011/02/05 13:45:38 idl0r Exp $
+
+EAPI="3"
+
+inherit eutils autotools flag-o-matic
+
+MY_PN=${PN//-tools}
+MY_PV=${PV/_p/-P}
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="bind tools: dig, nslookup, host, nsupdate, dnssec-keygen"
+HOMEPAGE="http://www.isc.org/software/bind"
+SRC_URI="ftp://ftp.isc.org/isc/bind9/${MY_PV}/${MY_P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc idn ipv6 ssl urandom xml"
+
+DEPEND="ssl? ( dev-libs/openssl )
+ xml? ( dev-libs/libxml2 )
+ idn? (
+ || ( sys-libs/glibc dev-libs/libiconv )
+ net-dns/idnkit
+ )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # bug 122597
+ use idn && {
+ cd "${S}"/contrib/idn/idnkit-1.0-src
+ epatch "${FILESDIR}"/${PN}-configure.patch
+ cd "${S}"
+ }
+
+ # bug 231247
+ epatch "${FILESDIR}"/${PN}-9.5.0_p1-lwconfig.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=
+
+ has_version sys-libs/glibc || myconf="${myconf} --with-iconv"
+
+ if use urandom; then
+ myconf="${myconf} --with-randomdev=/dev/urandom"
+ else
+ myconf="${myconf} --with-randomdev=/dev/random"
+ fi
+
+ # bug 344029
+ append-cflags "-DDIG_SIGCHASE"
+
+ econf \
+ $(use_enable ipv6) \
+ $(use_with idn) \
+ $(use_with ssl openssl) \
+ $(use_with xml libxml2) \
+ ${myconf}
+
+ # bug #151839
+ echo '#undef SO_BSDCOMPAT' >> config.h
+}
+
+src_compile() {
+ emake -C lib/ || die "emake lib failed"
+ emake -C bin/dig/ || die "emake bin/dig failed"
+ emake -C bin/nsupdate/ || die "emake bin/nsupdate failed"
+ emake -C bin/dnssec/ || die "emake bin/dnssec failed"
+}
+
+src_install() {
+ dodoc README CHANGES FAQ || die
+
+ cd "${S}"/bin/dig
+ dobin dig host nslookup || die
+ doman {dig,host,nslookup}.1 || die
+
+ cd "${S}"/bin/nsupdate
+ dobin nsupdate || die
+ doman nsupdate.1 || die
+ if use doc; then
+ dohtml nsupdate.html || die
+ fi
+
+ cd "${S}"/bin/dnssec
+ dobin dnssec-keygen || die
+ doman dnssec-keygen.8 || die
+ if use doc; then
+ dohtml dnssec-keygen.html || die
+ fi
+}