summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2009-07-30 12:49:01 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2009-07-30 12:49:01 +0000
commitc03962b87b6a8132a76c11c47ec57d8a29ab8df6 (patch)
tree680d836658ac447d625d08ac75762c2d2d38c3f8 /net-im
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-c03962b87b6a8132a76c11c47ec57d8a29ab8df6.tar.gz
gentoo-2-c03962b87b6a8132a76c11c47ec57d8a29ab8df6.tar.bz2
gentoo-2-c03962b87b6a8132a76c11c47ec57d8a29ab8df6.zip
Version bump
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/qtwitter/ChangeLog8
-rw-r--r--net-im/qtwitter/qtwitter-0.8.2.ebuild72
2 files changed, 79 insertions, 1 deletions
diff --git a/net-im/qtwitter/ChangeLog b/net-im/qtwitter/ChangeLog
index 624a471a1e52..69743fe81dc6 100644
--- a/net-im/qtwitter/ChangeLog
+++ b/net-im/qtwitter/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-im/qtwitter
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/qtwitter/ChangeLog,v 1.11 2009/07/20 04:10:21 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/qtwitter/ChangeLog,v 1.12 2009/07/30 12:49:01 tampakrap Exp $
+
+*qtwitter-0.8.2 (30 Jul 2009)
+
+ 30 Jul 2009; Theo Chatzimichos <tampakrap@gentoo.org>
+ +qtwitter-0.8.2.ebuild:
+ Version bump
20 Jul 2009; Jeremy Olexa <darkside@gentoo.org> qtwitter-0.7.1.ebuild:
amd64 stable, bug 275552
diff --git a/net-im/qtwitter/qtwitter-0.8.2.ebuild b/net-im/qtwitter/qtwitter-0.8.2.ebuild
new file mode 100644
index 000000000000..6ba2c3fc02e9
--- /dev/null
+++ b/net-im/qtwitter/qtwitter-0.8.2.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/qtwitter/qtwitter-0.8.2.ebuild,v 1.1 2009/07/30 12:49:01 tampakrap Exp $
+
+EAPI="2"
+
+inherit qt4
+
+DESCRIPTION="A Qt-based client for Twitter and Identi.ca"
+HOMEPAGE="http://www.qt-apps.org/content/show.php/qTwitter?content=99087"
+SRC_URI="http://files.ayoy.net/qtwitter/release/${PV}/src/${P}-src.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +oauth"
+
+DEPEND="x11-libs/qt-gui:4
+ oauth? ( dev-libs/qoauth )"
+RDEPEND="${DEPEND}"
+
+QTWITTER_LANGS="pt_BR"
+QTWITTER_NOLONGLANGS="ca_ES de_DE es_ES fr_FR ja_JP pl_PL"
+
+for L in $QTWITTER_LANGS; do
+ IUSE="$IUSE linguas_$L"
+done
+for L in $QTWITTER_NOLONGLANGS; do
+ IUSE="$IUSE linguas_${L%_*}"
+done
+
+src_prepare() {
+ qt4_src_prepare
+ echo "CONFIG += nostrip" >> "${S}"/${PN}.pro
+
+ local langs=
+ for lingua in $LINGUAS; do
+ if has $lingua $QTWITTER_LANGS; then
+ langs="$langs loc/${PN}_${lingua}.ts"
+ else
+ for a in $QTWITTER_NOLONGLANGS; do
+ if [[ $lingua == ${a%_*} ]]; then
+ langs="$langs loc/${PN}_${a}.ts"
+ fi
+ done
+ fi
+ done
+
+ # remove translations and add only the selected ones
+ sed -i -e '/^ *loc.*\.ts/d' \
+ -e "/^TRANSLATIONS/s:loc.*:${langs}:" \
+ qtwitter-app/qtwitter-app.pro || die "sed failed"
+ # first line fixes bug about unsecure runpaths
+ # second disables docs installation by make (done by dodoc in install)
+ sed -i -e '/-Wl,-rpath,\$\${TOP}/d' \
+ -e '/doc \\/d' \
+ qtwitter-app/qtwitter-app.pro || die "sed failed"
+
+ sed -i "s!\(\$\${INSTALL_PREFIX}\)/lib!\1/$(get_libdir)!" \
+ twitterapi/twitterapi.pro urlshortener/urlshortener.pro || die "sed failed"
+
+ use oauth || sed -i '/DEFINES += OAUTH/d' ${PN}.pri
+}
+
+src_configure() {
+ eqmake4
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die "emake install failed"
+ dodoc README CHANGELOG || die "dodoc failed"
+}