summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2008-01-08 21:13:08 +0000
committerMarkus Ullmann <jokey@gentoo.org>2008-01-08 21:13:08 +0000
commit9eea7c66d84e4e5d58e3998bcf3decae8f84050f (patch)
tree344db48c9712e6552172fff333c6b168906bbc57 /net-irc/anope
parentStable for HPPA (bug #204290). (diff)
downloadgentoo-2-9eea7c66d84e4e5d58e3998bcf3decae8f84050f.tar.gz
gentoo-2-9eea7c66d84e4e5d58e3998bcf3decae8f84050f.tar.bz2
gentoo-2-9eea7c66d84e4e5d58e3998bcf3decae8f84050f.zip
Version bump
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'net-irc/anope')
-rw-r--r--net-irc/anope/ChangeLog9
-rw-r--r--net-irc/anope/anope-1.7.20.ebuild145
-rw-r--r--net-irc/anope/files/digest-anope-1.7.203
3 files changed, 155 insertions, 2 deletions
diff --git a/net-irc/anope/ChangeLog b/net-irc/anope/ChangeLog
index a054c757a386..334302ceb48f 100644
--- a/net-irc/anope/ChangeLog
+++ b/net-irc/anope/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/anope
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/anope/ChangeLog,v 1.9 2007/12/27 22:25:55 jokey Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/anope/ChangeLog,v 1.10 2008/01/08 21:13:08 jokey Exp $
+
+*anope-1.7.20 (08 Jan 2008)
+
+ 08 Jan 2008; Markus Ullmann <jokey@gentoo.org> +anope-1.7.20.ebuild:
+ Version bump
27 Dec 2007; Markus Ullmann <jokey@gentoo.org> anope-1.7.19.ebuild:
Install services.conf as services.conf.example to avoid overwriting
diff --git a/net-irc/anope/anope-1.7.20.ebuild b/net-irc/anope/anope-1.7.20.ebuild
new file mode 100644
index 000000000000..bf78ceb29ee7
--- /dev/null
+++ b/net-irc/anope/anope-1.7.20.ebuild
@@ -0,0 +1,145 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/anope/anope-1.7.20.ebuild,v 1.1 2008/01/08 21:13:08 jokey Exp $
+
+inherit eutils
+
+DESCRIPTION="Anope IRC Services"
+HOMEPAGE="http://www.anope.org"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="mysql"
+
+DEPEND="mysql? ( virtual/mysql )"
+
+INSTALL_DIR="/opt/anope"
+
+pkg_setup() {
+ enewgroup anope
+ enewuser anope -1 -1 "${INSTALL_DIR}" anope
+ if has_version net-irc/anope ; then
+ ewarn
+ ewarn "Make backups before updating as they will be overwritten"
+ ewarn
+ ebeep 10
+ fi
+}
+
+src_compile() {
+ local myconf
+ if ! use mysql; then
+ myconf="${myconf} --without-mysql"
+ fi
+
+ epatch "${FILESDIR}"/pid-patch.diff
+
+ econf \
+ ${myconf} \
+ --bindir ${INSTALL_DIR} \
+ --with-bindir=${INSTALL_DIR} \
+ --with-datadir=${INSTALL_DIR}/data \
+ --with-modules=${INSTALL_DIR}/modules \
+ --with-encryption \
+ --with-rungroup=anope \
+ --with-permissions=077 \
+ || die "Configuration failed."
+
+ sed -i -e "/^build:/s:$: language:g" "${S}"/Makefile || die "sed failed"
+
+ emake || die "Make failed."
+}
+
+src_install() {
+ dodir ${INSTALL_DIR}
+ dodir ${INSTALL_DIR}/data
+ dodir ${INSTALL_DIR}/data/logs
+ dodir ${INSTALL_DIR}/data/languages
+ dodir ${INSTALL_DIR}/data/modules
+ dodir ${INSTALL_DIR}/data/modules/runtime
+ dodir ${INSTALL_DIR}/modules
+
+ dodir /var/run/anope
+ fowners anope:anope /var/run/anope
+ keepdir /var/run/anope
+
+ fowners anope:anope ${INSTALL_DIR}
+ fowners anope:anope ${INSTALL_DIR}/data
+ fowners anope:anope ${INSTALL_DIR}/data/logs
+ fowners anope:anope ${INSTALL_DIR}/data/languages
+ fowners anope:anope ${INSTALL_DIR}/data/modules
+ fowners anope:anope ${INSTALL_DIR}/data/modules/runtime
+ fowners anope:anope ${INSTALL_DIR}/modules
+
+ exeinto ${INSTALL_DIR}
+ doexe src/services
+ insinto ${INSTALL_DIR}/data
+ newins data/example.conf services.conf.example
+
+ newinitd "${FILESDIR}"/anope.initd anope
+ newconfd "${FILESDIR}"/anope.confd anope
+
+ insinto ${INSTALL_DIR}/modules
+ doins src/modules/*.so
+
+ keepdir ${INSTALL_DIR}/data/logs
+
+ insinto ${INSTALL_DIR}/data/languages
+ doins lang/cat
+ doins lang/de
+ doins lang/en_us
+ doins lang/es
+ doins lang/fr
+ doins lang/gr
+ doins lang/hun
+ doins lang/it
+ doins lang/nl
+ doins lang/pl
+ doins lang/pt
+ doins lang/ru
+ doins lang/tr
+
+ keepdir ${INSTALL_DIR}/data/modules/runtime
+
+ insinto ${INSTALL_DIR}/data/modules
+ doins src/protocol/*.so
+ doins src/core/*.so
+
+ fowners anope:anope ${INSTALL_DIR}/services
+ fowners anope:anope ${INSTALL_DIR}/data/services.conf
+ fowners anope:anope ${INSTALL_DIR}/data/languages/cat
+ fowners anope:anope ${INSTALL_DIR}/data/languages/de
+ fowners anope:anope ${INSTALL_DIR}/data/languages/en_us
+ fowners anope:anope ${INSTALL_DIR}/data/languages/fr
+ fowners anope:anope ${INSTALL_DIR}/data/languages/gr
+ fowners anope:anope ${INSTALL_DIR}/data/languages/hun
+ fowners anope:anope ${INSTALL_DIR}/data/languages/it
+ fowners anope:anope ${INSTALL_DIR}/data/languages/nl
+ fowners anope:anope ${INSTALL_DIR}/data/languages/pl
+ fowners anope:anope ${INSTALL_DIR}/data/languages/pt
+ fowners anope:anope ${INSTALL_DIR}/data/languages/ru
+ fowners anope:anope ${INSTALL_DIR}/data/languages/tr
+
+ dodoc Changes Changes.conf Changes.lang Changes.mysql docs/*
+}
+
+pkg_preinst() {
+ if has_version net-irc/anope ; then
+ elog "Making a backup of your config to data/pre-update"
+ mkdir "${ROOT}"opt/anope/data/pre-update
+ cp "${ROOT}"opt/anope/data/* "${ROOT}"opt/anope/data/pre-update
+ fi
+}
+
+pkg_postinst() {
+ echo
+ ewarn "Anope won't run out of the box, you still have to configure it to match your IRCDs configuration."
+ ewarn "Edit ${INSTALL_DIR}/data/services.conf to configure Anope."
+ echo
+ ewarn "!!! ATTENTION !!!"
+ ewarn "Be sure to read Changes.mysql to update your MySQL"
+ ewarn "tables or anope will break after restart"
+ ewarn "!!! ATTENTION !!!"
+}
diff --git a/net-irc/anope/files/digest-anope-1.7.20 b/net-irc/anope/files/digest-anope-1.7.20
new file mode 100644
index 000000000000..d3f1162814e7
--- /dev/null
+++ b/net-irc/anope/files/digest-anope-1.7.20
@@ -0,0 +1,3 @@
+MD5 74527060698338a0bc8100e8907dfd09 anope-1.7.20.tar.gz 1520238
+RMD160 9f59a90237a4fea07898ec1e3631393edcca3652 anope-1.7.20.tar.gz 1520238
+SHA256 392b8c26a9d0362383f2289fb55a818048c2ba6e214851e73ae5a22fc414919a anope-1.7.20.tar.gz 1520238