summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-11-05 13:31:39 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-11-05 13:31:39 +0000
commit5cd8f7523e76ece98b03cf7502296837857b3a3b (patch)
tree14882712a5b683f7cc680accaf305ec4cebaa83c /net-libs
parentVersion bump. (diff)
downloadgentoo-2-5cd8f7523e76ece98b03cf7502296837857b3a3b.tar.gz
gentoo-2-5cd8f7523e76ece98b03cf7502296837857b3a3b.tar.bz2
gentoo-2-5cd8f7523e76ece98b03cf7502296837857b3a3b.zip
Version bump.
(Portage version: 2.2.7/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libosmocore/ChangeLog8
-rw-r--r--net-libs/libosmocore/libosmocore-0.6.4.ebuild38
-rw-r--r--net-libs/libosmocore/libosmocore-9999.ebuild4
3 files changed, 47 insertions, 3 deletions
diff --git a/net-libs/libosmocore/ChangeLog b/net-libs/libosmocore/ChangeLog
index 5c314a20dac0..7aae13c068e3 100644
--- a/net-libs/libosmocore/ChangeLog
+++ b/net-libs/libosmocore/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/libosmocore
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libosmocore/ChangeLog,v 1.9 2013/08/26 19:50:06 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libosmocore/ChangeLog,v 1.10 2013/11/05 13:31:39 chithanh Exp $
+
+*libosmocore-0.6.4 (05 Nov 2013)
+
+ 05 Nov 2013; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +libosmocore-0.6.4.ebuild, libosmocore-9999.ebuild:
+ Version bump.
*libosmocore-0.6.3 (26 Aug 2013)
diff --git a/net-libs/libosmocore/libosmocore-0.6.4.ebuild b/net-libs/libosmocore/libosmocore-0.6.4.ebuild
new file mode 100644
index 000000000000..5e43e1c3ea63
--- /dev/null
+++ b/net-libs/libosmocore/libosmocore-0.6.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libosmocore/libosmocore-0.6.4.ebuild,v 1.1 2013/11/05 13:31:39 chithanh Exp $
+
+EAPI=5
+
+inherit autotools eutils
+
+DESCRIPTION="Utility functions for OsmocomBB, OpenBSC and related projects"
+HOMEPAGE="http://bb.osmocom.org/trac/wiki/libosmocore"
+SRC_URI="http://cgit.osmocom.org/cgit/libosmocore/snapshot/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="embedded"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ app-doc/doxygen"
+
+src_prepare() {
+ # set correct version in pkgconfig files
+ sed -i "s/UNKNOWN/${PV}/" git-version-gen || die
+
+ epatch "${FILESDIR}"/${PN}-0.6.0-automake-1.13.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable embedded)
+}
+
+src_install() {
+ default
+ # install to correct documentation directory
+ mv "${ED}"/usr/share/doc/${PN} "${ED}"/usr/share/doc/${PF} || die
+}
diff --git a/net-libs/libosmocore/libosmocore-9999.ebuild b/net-libs/libosmocore/libosmocore-9999.ebuild
index 6eeedf5ac4a7..6cf9a98f384b 100644
--- a/net-libs/libosmocore/libosmocore-9999.ebuild
+++ b/net-libs/libosmocore/libosmocore-9999.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libosmocore/libosmocore-9999.ebuild,v 1.4 2013/05/24 07:57:52 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libosmocore/libosmocore-9999.ebuild,v 1.5 2013/11/05 13:31:39 chithanh Exp $
-EAPI="4"
+EAPI=5
inherit autotools eutils git-2