summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Knoblich <stkn@gentoo.org>2006-09-05 19:34:10 +0000
committerStefan Knoblich <stkn@gentoo.org>2006-09-05 19:34:10 +0000
commit968a01b148a39dafd1f5980fc88294590ae5dc0b (patch)
tree02cf331f38c6fb0ffef53748f144d2b3851760ad /net-misc/asterisk-addons
parentVersion bump (diff)
downloadgentoo-2-968a01b148a39dafd1f5980fc88294590ae5dc0b.tar.gz
gentoo-2-968a01b148a39dafd1f5980fc88294590ae5dc0b.tar.bz2
gentoo-2-968a01b148a39dafd1f5980fc88294590ae5dc0b.zip
Version bump.
(Portage version: 2.1-r2)
Diffstat (limited to 'net-misc/asterisk-addons')
-rw-r--r--net-misc/asterisk-addons/ChangeLog11
-rw-r--r--net-misc/asterisk-addons/asterisk-addons-1.2.4.ebuild177
-rw-r--r--net-misc/asterisk-addons/files/asterisk-addons-1.2.2-gentoo-format_mp3.diff11
-rw-r--r--net-misc/asterisk-addons/files/asterisk-addons-1.2.2-uclibc.diff30
-rw-r--r--net-misc/asterisk-addons/files/asterisk-addons-1.2.3-gentoo-ooh323c.diff30
-rw-r--r--net-misc/asterisk-addons/files/digest-asterisk-addons-1.2.04
-rw-r--r--net-misc/asterisk-addons/files/digest-asterisk-addons-1.2.14
-rw-r--r--net-misc/asterisk-addons/files/digest-asterisk-addons-1.2.46
8 files changed, 272 insertions, 1 deletions
diff --git a/net-misc/asterisk-addons/ChangeLog b/net-misc/asterisk-addons/ChangeLog
index 59586388b3a2..8e27c336ec97 100644
--- a/net-misc/asterisk-addons/ChangeLog
+++ b/net-misc/asterisk-addons/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-misc/asterisk-addons
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk-addons/ChangeLog,v 1.4 2006/02/28 03:04:12 stkn Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk-addons/ChangeLog,v 1.5 2006/09/05 19:34:10 stkn Exp $
+
+*asterisk-addons-1.2.4 (06 Sep 2006)
+
+ 06 Sep 2006; Stefan Knoblich <stkn@gentoo.org>
+ +files/asterisk-addons-1.2.2-gentoo-format_mp3.diff,
+ +files/asterisk-addons-1.2.2-uclibc.diff,
+ +files/asterisk-addons-1.2.3-gentoo-ooh323c.diff,
+ +asterisk-addons-1.2.4.ebuild:
+ Version bump.
*asterisk-addons-1.2.1 (28 Feb 2006)
diff --git a/net-misc/asterisk-addons/asterisk-addons-1.2.4.ebuild b/net-misc/asterisk-addons/asterisk-addons-1.2.4.ebuild
new file mode 100644
index 000000000000..0a4579047745
--- /dev/null
+++ b/net-misc/asterisk-addons/asterisk-addons-1.2.4.ebuild
@@ -0,0 +1,177 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk-addons/asterisk-addons-1.2.4.ebuild,v 1.1 2006/09/05 19:34:10 stkn Exp $
+
+IUSE="elibc_uclibc mysql sqlite h323"
+
+inherit eutils flag-o-matic
+
+SQLITE_PV="3.2.1"
+
+MY_P="${P/_/-}"
+
+DESCRIPTION="Additional Plugins for Asterisk"
+HOMEPAGE="http://www.asterisk.org/"
+SRC_URI="http://ftp.digium.com/pub/asterisk/${MY_P}.tar.gz
+ sqlite? ( http://www.sqlite.org/sqlite-${SQLITE_PV}.tar.gz )"
+
+S=${WORKDIR}/${MY_P}
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND=">=net-misc/asterisk-1.2.0
+ mysql? ( dev-db/mysql )"
+
+pkg_setup() {
+ local n dosleep=0
+ einfo "Running pre-flight checks..."
+
+ if use h323 && built_with_use net-misc/asterisk h323; then
+ echo
+ ewarn "h323: Emerging ${PN} with the h323 flag enabled will overwrite asterisk's chan_h323.so!"
+ ewarn "h323: Be sure to upgrade ${ROOT}etc/asterisk/h323.conf afterwards!"
+ dosleep=1
+ fi
+
+ if use sqlite && built_with_use net-misc/asterisk sqlite; then
+ echo
+ ewarn "sqlite: Emerging ${PN} with the sqlite flag enabled will overwrite asterisk's res_sqlite.so!"
+ ewarn "sqlite: Be sure to upgrade ${ROOT}etc/asterisk/res_sqlite.conf afterwards!"
+ dosleep=1
+ fi
+
+ echo
+ if [[ $dosleep -gt 0 ]]; then
+ ebeep
+ n=10
+ while [[ $n -gt 0 ]]; do
+ echo -en " Waiting $n seconds...\r"
+ sleep 1
+ (( n-- ))
+ done
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ #
+ # gentoo patchset
+ #
+ epatch ${FILESDIR}/${PN}-1.2.0-gentoo-base.diff
+ epatch ${FILESDIR}/${PN}-1.2.0-gentoo-res_sqlite3.diff
+ epatch ${FILESDIR}/${PN}-1.2.2-gentoo-format_mp3.diff
+ epatch ${FILESDIR}/${PN}-1.2.3-gentoo-ooh323c.diff
+
+ # patch from jaervosz for uclibc
+ use elibc_uclibc && \
+ epatch ${FILESDIR}/${PN}-1.2.2-uclibc.diff
+
+ # patch sqlite
+ if use sqlite; then
+ cd ${WORKDIR}/sqlite-${SQLITE_PV}
+
+ epatch ${FILESDIR}/sqlite-${SQLITE_PV}-data-corruption.patch
+ epunt_cxx
+ fi
+
+ # rebuild ooh323c configure
+ if use h323; then
+ cd ${S}/asterisk-ooh323c
+ libtoolize --copy --force || die "libtoolize failed"
+ fi
+}
+
+src_compile() {
+ append-flags -fPIC
+
+ emake -j1 OPTIMIZE="${CFLAGS}" || die "Make failed"
+
+ if use sqlite; then
+ cd ${WORKDIR}/sqlite-${SQLITE_PV}
+ econf --enable-threadsafe || die ""
+ emake || die ""
+
+ cd ${S}
+ emake -j1 -C res_sqlite3 \
+ SQLITEDIR=${WORKDIR}/sqlite-${SQLITE_PV} || die "Make res_sqlite failed"
+ fi
+
+ if use h323; then
+ cd ${S}/asterisk-ooh323c
+ econf || die "econf failed"
+ emake || die "emake failed"
+ fi
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "Make install failed"
+
+ if use sqlite; then
+ make -C res_sqlite3 \
+ DESTDIR=${D} install || die "Make install res_sqlite3 failed"
+ fi
+
+ if use h323; then
+ make -C asterisk-ooh323c \
+ DESTDIR=${D} install || die "Make instal ooh323c failed"
+ fi
+
+ # install standard docs...
+ dodoc README
+ dodoc doc/cdr_mysql.txt
+
+ insinto /usr/share/doc/${PF}
+ doins configs/*.sample
+
+ if use sqlite; then
+ cd ${S}/res_sqlite3
+ docinto res_sqlite3
+ dodoc README
+ insinto /usr/share/doc/${PF}/res_sqlite3
+ doins res_sqlite.conf dialplan.sql
+ keepdir /var/lib/asterisk/sqlite
+ fi
+
+ if use h323; then
+ cd ${S}/asterisk-ooh323c
+ docinto chan_ooh323c
+ dodoc AUTHORS INSTALL NEWS README COPYING ChangeLog
+ dodoc h323.conf.sample extensions.conf.sample
+
+ insinto /etc/asterisk
+ newins h323.conf.sample h323.conf
+ fi
+
+ cd ${S}
+
+ if use mysql; then
+ insinto /etc/asterisk
+ newins configs/cdr_mysql.conf.sample cdr_mysql.conf
+ newins configs/res_mysql.conf.sample res_mysql.conf
+ fi
+
+ einfo "Fixing permissions"
+ chown -R root:asterisk ${D}etc/asterisk
+ chmod -R u=rwX,g=rX,o= ${D}etc/asterisk
+
+# chown -R asterisk:asterisk ${D}var/lib/asterisk
+# chmod -R u=rwX,g=rX,o= ${D}var/lib/asterisk
+}
+
+pkg_postinst() {
+ #
+ # Announcements, warnings, reminders...
+ #
+ einfo "********* Some notes from the asterisk-addons-1.2.4 readme: **********"
+ echo
+ ewarn "\"Using res_config_mysql at the same time as res_config_odbc can create"
+ ewarn "system instability on some systems. Please load only one or the other.\""
+ echo
+ ewarn "\"format_mp3 can cause Asterisk to crash on certain mp3 files (notably"
+ ewarn "8k files made with lame) due to bugs in mpglib. If you must use this"
+ ewarn "module, use it only with mp3's you know will work with it.\""
+}
diff --git a/net-misc/asterisk-addons/files/asterisk-addons-1.2.2-gentoo-format_mp3.diff b/net-misc/asterisk-addons/files/asterisk-addons-1.2.2-gentoo-format_mp3.diff
new file mode 100644
index 000000000000..bb20fa65e7b0
--- /dev/null
+++ b/net-misc/asterisk-addons/files/asterisk-addons-1.2.2-gentoo-format_mp3.diff
@@ -0,0 +1,11 @@
+--- asterisk-addons-1.2.2/format_mp3/Makefile.orig 2006-03-07 14:30:18.000000000 +0100
++++ asterisk-addons-1.2.2/format_mp3/Makefile 2006-03-07 14:31:03.000000000 +0100
+@@ -55,7 +55,7 @@
+ endif
+
+ #Tell gcc to optimize the asterisk's code
+-OPTIMIZE+=-O6
++OPTIMIZE?=-O2
+
+ CFLAGS+=$(OPTIMIZE)
+ CFLAGS+= $(OPTIONS)
diff --git a/net-misc/asterisk-addons/files/asterisk-addons-1.2.2-uclibc.diff b/net-misc/asterisk-addons/files/asterisk-addons-1.2.2-uclibc.diff
new file mode 100644
index 000000000000..b0c93b13dc22
--- /dev/null
+++ b/net-misc/asterisk-addons/files/asterisk-addons-1.2.2-uclibc.diff
@@ -0,0 +1,30 @@
+--- cdr_addon_mysql.c.orig 2006-05-17 17:55:28.000000000 +0200
++++ cdr_addon_mysql.c 2006-05-17 17:56:10.000000000 +0200
+@@ -19,6 +19,13 @@
+ *
+ */
+
++#include <stdio.h>
++#include <string.h>
++
++#include <stdlib.h>
++#include <unistd.h>
++#include <time.h>
++
+ #include <sys/types.h>
+ #include <asterisk/config.h>
+ #include <asterisk/options.h>
+@@ -28,13 +35,6 @@
+ #include <asterisk/logger.h>
+ #include <asterisk/cli.h>
+
+-#include <stdio.h>
+-#include <string.h>
+-
+-#include <stdlib.h>
+-#include <unistd.h>
+-#include <time.h>
+-
+ #include <mysql.h>
+ #include <errmsg.h>
+
diff --git a/net-misc/asterisk-addons/files/asterisk-addons-1.2.3-gentoo-ooh323c.diff b/net-misc/asterisk-addons/files/asterisk-addons-1.2.3-gentoo-ooh323c.diff
new file mode 100644
index 000000000000..8a4d14653e7f
--- /dev/null
+++ b/net-misc/asterisk-addons/files/asterisk-addons-1.2.3-gentoo-ooh323c.diff
@@ -0,0 +1,30 @@
+--- asterisk-addons-1.2.3/asterisk-ooh323c/Makefile.am.orig 2006-04-30 17:08:32.000000000 +0200
++++ asterisk-addons-1.2.3/asterisk-ooh323c/Makefile.am 2006-06-05 15:19:59.000000000 +0200
+@@ -22,10 +22,10 @@
+ $(MAKE) "CFLAGS = -g -DGNU -D_GNU_SOURCE -D_REENTRANT $(DEBUG_THREADS)" all
+
+ install:
+- cp .libs/libchan_h323.so.1.0.1 $(DESTDIR)/usr/lib/asterisk/modules/chan_ooh323.so
++ $(INSTALL) -D -m755 .libs/libchan_h323.so.1.0.1 $(DESTDIR)/usr/lib/asterisk/modules/chan_ooh323.so
+
+ sample:
+- cp h323.conf.sample $(DESTDIR)/etc/asterisk/ooh323.conf
++ $(INSTALL) -D -m644 h323.conf.sample $(DESTDIR)/etc/asterisk/ooh323.conf
+
+
+ EXTRA_DIST = extensions.conf h323.conf README COPYING
+--- asterisk-addons-1.2.3/asterisk-ooh323c/Makefile.in.orig 2006-05-31 18:50:32.000000000 +0200
++++ asterisk-addons-1.2.3/asterisk-ooh323c/Makefile.in 2006-06-05 15:20:52.000000000 +0200
+@@ -1239,10 +1239,10 @@
+ $(MAKE) "CFLAGS = -g -DGNU -D_GNU_SOURCE -D_REENTRANT $(DEBUG_THREADS)" all
+
+ install:
+- cp .libs/libchan_h323.so.1.0.1 $(DESTDIR)/usr/lib/asterisk/modules/chan_ooh323.so
++ $(INSTALL) -D -m755 .libs/libchan_h323.so.1.0.1 $(DESTDIR)/usr/lib/asterisk/modules/chan_ooh323.so
+
+ sample:
+- cp h323.conf.sample $(DESTDIR)/etc/asterisk/ooh323.conf
++ $(INSTALL) -D -m644 h323.conf.sample $(DESTDIR)/etc/asterisk/ooh323.conf
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
+ .NOEXPORT:
diff --git a/net-misc/asterisk-addons/files/digest-asterisk-addons-1.2.0 b/net-misc/asterisk-addons/files/digest-asterisk-addons-1.2.0
index 77217a857bd4..ad03f6b1fa70 100644
--- a/net-misc/asterisk-addons/files/digest-asterisk-addons-1.2.0
+++ b/net-misc/asterisk-addons/files/digest-asterisk-addons-1.2.0
@@ -1,2 +1,6 @@
MD5 c49f3e816eb4ec6602a98fbdb2a76ff1 asterisk-addons-1.2.0.tar.gz 750149
+RMD160 69a2c1fb86f7dc5ccec9246be621f10ab6eb6633 asterisk-addons-1.2.0.tar.gz 750149
+SHA256 aecb1bce5d3d695b475ee3c758308a5d983bbee41edf192f50bd55d6f146a25b asterisk-addons-1.2.0.tar.gz 750149
MD5 ccf3831c2f67452d444c5e5e2c7ca6f0 sqlite-3.2.1.tar.gz 1351842
+RMD160 3b4cfc1fca27d4df369220d15eb5e28777bd99da sqlite-3.2.1.tar.gz 1351842
+SHA256 daba70d5d7666ff8091a7a9322a1a2d88889043d50e136ed7d3e726d751001a7 sqlite-3.2.1.tar.gz 1351842
diff --git a/net-misc/asterisk-addons/files/digest-asterisk-addons-1.2.1 b/net-misc/asterisk-addons/files/digest-asterisk-addons-1.2.1
index 8710bc556d67..fe39118283cc 100644
--- a/net-misc/asterisk-addons/files/digest-asterisk-addons-1.2.1
+++ b/net-misc/asterisk-addons/files/digest-asterisk-addons-1.2.1
@@ -1,2 +1,6 @@
MD5 28bdfb79835e223cdff8bfa8365d1720 asterisk-addons-1.2.1.tar.gz 748237
+RMD160 1d2512aa87e0a1544dacf4465e1dab8890f8676a asterisk-addons-1.2.1.tar.gz 748237
+SHA256 4932ed32ed0896eb73c4291bf74d59422d3d6aec44fb289f904ec9620719db07 asterisk-addons-1.2.1.tar.gz 748237
MD5 ccf3831c2f67452d444c5e5e2c7ca6f0 sqlite-3.2.1.tar.gz 1351842
+RMD160 3b4cfc1fca27d4df369220d15eb5e28777bd99da sqlite-3.2.1.tar.gz 1351842
+SHA256 daba70d5d7666ff8091a7a9322a1a2d88889043d50e136ed7d3e726d751001a7 sqlite-3.2.1.tar.gz 1351842
diff --git a/net-misc/asterisk-addons/files/digest-asterisk-addons-1.2.4 b/net-misc/asterisk-addons/files/digest-asterisk-addons-1.2.4
new file mode 100644
index 000000000000..2b0c7c10c8cb
--- /dev/null
+++ b/net-misc/asterisk-addons/files/digest-asterisk-addons-1.2.4
@@ -0,0 +1,6 @@
+MD5 1a6d641572d35bb22d52c9d074fbfba8 asterisk-addons-1.2.4.tar.gz 755656
+RMD160 30418aa6e6dbfe26b841e96e352a1acf0049fbca asterisk-addons-1.2.4.tar.gz 755656
+SHA256 e32d11bf19d01ef01d4017f1e98c5701b94683e05ce51f3d45abe24598f692af asterisk-addons-1.2.4.tar.gz 755656
+MD5 ccf3831c2f67452d444c5e5e2c7ca6f0 sqlite-3.2.1.tar.gz 1351842
+RMD160 3b4cfc1fca27d4df369220d15eb5e28777bd99da sqlite-3.2.1.tar.gz 1351842
+SHA256 daba70d5d7666ff8091a7a9322a1a2d88889043d50e136ed7d3e726d751001a7 sqlite-3.2.1.tar.gz 1351842