summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-06-24 10:31:21 +0000
committerManuel Rüger <mrueg@gentoo.org>2015-06-24 10:31:21 +0000
commit3c68593ac7cdc3b34a5be55ac02c3cb80bd05e1c (patch)
treef6bd5bade57b8c735986bd4e585f48c59f8e4bbf /net-misc
parentDrop old; Bump EAPI (diff)
downloadgentoo-2-3c68593ac7cdc3b34a5be55ac02c3cb80bd05e1c.tar.gz
gentoo-2-3c68593ac7cdc3b34a5be55ac02c3cb80bd05e1c.tar.bz2
gentoo-2-3c68593ac7cdc3b34a5be55ac02c3cb80bd05e1c.zip
Upstream reverted the bash-completion fix.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/mosh/ChangeLog5
-rw-r--r--net-misc/mosh/mosh-9999.ebuild9
2 files changed, 10 insertions, 4 deletions
diff --git a/net-misc/mosh/ChangeLog b/net-misc/mosh/ChangeLog
index d9377fbb7164..264db80b9312 100644
--- a/net-misc/mosh/ChangeLog
+++ b/net-misc/mosh/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-misc/mosh
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/mosh/ChangeLog,v 1.48 2015/06/22 07:45:48 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/mosh/ChangeLog,v 1.49 2015/06/24 10:31:21 mrueg Exp $
+
+ 24 Jun 2015; Manuel Rüger <mrueg@gentoo.org> mosh-9999.ebuild:
+ Upstream reverted the bash-completion fix.
22 Jun 2015; Manuel Rüger <mrueg@gentoo.org> mosh-9999.ebuild:
Migrate to git-r3, upstream respects bash-completion dir.
diff --git a/net-misc/mosh/mosh-9999.ebuild b/net-misc/mosh/mosh-9999.ebuild
index f4652821351a..09e52660ce49 100644
--- a/net-misc/mosh/mosh-9999.ebuild
+++ b/net-misc/mosh/mosh-9999.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/mosh/mosh-9999.ebuild,v 1.15 2015/06/22 07:45:48 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/mosh/mosh-9999.ebuild,v 1.16 2015/06/24 10:31:21 mrueg Exp $
EAPI=5
-inherit autotools git-r3
+inherit autotools bash-completion-r1 git-r3
DESCRIPTION="Mobile shell that supports roaming and intelligent local echo"
HOMEPAGE="http://mosh.mit.edu"
@@ -33,7 +33,7 @@ src_prepare() {
src_configure() {
econf \
- --enable-completion \
+ --disable-completion \
$(use_enable client) \
$(use_enable server) \
$(use_enable examples) \
@@ -53,4 +53,7 @@ src_install() {
newbin ${myprog} ${PN}-$(basename ${myprog})
elog "${myprog} installed as ${PN}-$(basename ${myprog})"
done
+
+ # bug 477384
+ dobashcomp conf/bash_completion.d/mosh
}