summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-10-07 18:22:57 +0000
committerMike Frysinger <vapier@gentoo.org>2009-10-07 18:22:57 +0000
commitbef6d75223d5931cad2443d871329ecf16a9931b (patch)
treede0f849c97fa4178edefa6618ca673be27204a0d /net-misc
parentppc stable #286653 (diff)
downloadgentoo-2-bef6d75223d5931cad2443d871329ecf16a9931b.tar.gz
gentoo-2-bef6d75223d5931cad2443d871329ecf16a9931b.tar.bz2
gentoo-2-bef6d75223d5931cad2443d871329ecf16a9931b.zip
Fix static_use_with handling when there is one option #287292 by Jaak Ristioja.
(Portage version: 2.2_rc42/cvs/Linux x86_64)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/openssh/ChangeLog7
-rw-r--r--net-misc/openssh/openssh-5.2_p1-r2.ebuild4
-rw-r--r--net-misc/openssh/openssh-5.2_p1-r3.ebuild4
-rw-r--r--net-misc/openssh/openssh-5.3_p1.ebuild4
4 files changed, 12 insertions, 7 deletions
diff --git a/net-misc/openssh/ChangeLog b/net-misc/openssh/ChangeLog
index 2e7846b09a92..668be0e17e4d 100644
--- a/net-misc/openssh/ChangeLog
+++ b/net-misc/openssh/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/openssh
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/ChangeLog,v 1.362 2009/10/03 16:25:41 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/ChangeLog,v 1.363 2009/10/07 18:22:57 vapier Exp $
+
+ 07 Oct 2009; Mike Frysinger <vapier@gentoo.org> openssh-5.2_p1-r2.ebuild,
+ openssh-5.2_p1-r3.ebuild, openssh-5.3_p1.ebuild:
+ Fix static_use_with handling when there is one option #287292 by Jaak
+ Ristioja.
03 Oct 2009; Jeroen Roovers <jer@gentoo.org> openssh-5.2_p1-r3.ebuild:
Stable for HPPA (bug #287292).
diff --git a/net-misc/openssh/openssh-5.2_p1-r2.ebuild b/net-misc/openssh/openssh-5.2_p1-r2.ebuild
index caf0d6dd8e9c..dc9734bd8fdd 100644
--- a/net-misc/openssh/openssh-5.2_p1-r2.ebuild
+++ b/net-misc/openssh/openssh-5.2_p1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-5.2_p1-r2.ebuild,v 1.12 2009/08/13 06:30:33 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-5.2_p1-r2.ebuild,v 1.13 2009/10/07 18:22:57 vapier Exp $
inherit eutils flag-o-matic multilib autotools pam
@@ -130,8 +130,8 @@ static_use_with() {
# rebuild args so that we invert the first one (USE flag)
# but otherwise leave everything else working so we can
# just leverage use_with
- [[ -z $1 ]] && flag="${flag} ${flag}"
shift
+ [[ -z $1 ]] && flag="${flag} ${flag}"
set -- !${flag} "$@"
fi
use_with "$@"
diff --git a/net-misc/openssh/openssh-5.2_p1-r3.ebuild b/net-misc/openssh/openssh-5.2_p1-r3.ebuild
index 7e94853c16d6..4ab15be00ff0 100644
--- a/net-misc/openssh/openssh-5.2_p1-r3.ebuild
+++ b/net-misc/openssh/openssh-5.2_p1-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-5.2_p1-r3.ebuild,v 1.4 2009/10/03 16:25:41 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-5.2_p1-r3.ebuild,v 1.5 2009/10/07 18:22:57 vapier Exp $
inherit eutils flag-o-matic multilib autotools pam
@@ -126,8 +126,8 @@ static_use_with() {
# rebuild args so that we invert the first one (USE flag)
# but otherwise leave everything else working so we can
# just leverage use_with
- [[ -z $1 ]] && flag="${flag} ${flag}"
shift
+ [[ -z $1 ]] && flag="${flag} ${flag}"
set -- !${flag} "$@"
fi
use_with "$@"
diff --git a/net-misc/openssh/openssh-5.3_p1.ebuild b/net-misc/openssh/openssh-5.3_p1.ebuild
index 20e92ec22b62..ff70d771f5c9 100644
--- a/net-misc/openssh/openssh-5.3_p1.ebuild
+++ b/net-misc/openssh/openssh-5.3_p1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-5.3_p1.ebuild,v 1.1 2009/10/03 07:41:38 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-5.3_p1.ebuild,v 1.2 2009/10/07 18:22:57 vapier Exp $
inherit eutils flag-o-matic multilib autotools pam
@@ -124,8 +124,8 @@ static_use_with() {
# rebuild args so that we invert the first one (USE flag)
# but otherwise leave everything else working so we can
# just leverage use_with
- [[ -z $1 ]] && flag="${flag} ${flag}"
shift
+ [[ -z $1 ]] && flag="${flag} ${flag}"
set -- !${flag} "$@"
fi
use_with "$@"