summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2012-05-09 19:19:57 +0000
committerChristian Ruppert <idl0r@gentoo.org>2012-05-09 19:19:57 +0000
commitdeb065f772caef7ae38b3d52cc1285994db1545d (patch)
treeb215d47f9292cbada9a0aa1a773a4e33b618a5bb /net-proxy/haproxy
parentSet base kde_minimal to 4.8. (diff)
downloadgentoo-2-deb065f772caef7ae38b3d52cc1285994db1545d.tar.gz
gentoo-2-deb065f772caef7ae38b3d52cc1285994db1545d.tar.bz2
gentoo-2-deb065f772caef7ae38b3d52cc1285994db1545d.zip
Version bump + cleanup
(Portage version: 2.2.0_alpha102/cvs/Linux x86_64)
Diffstat (limited to 'net-proxy/haproxy')
-rw-r--r--net-proxy/haproxy/ChangeLog8
-rw-r--r--net-proxy/haproxy/files/haproxy.initd44
-rw-r--r--net-proxy/haproxy/haproxy-1.4.15.ebuild75
-rw-r--r--net-proxy/haproxy/haproxy-1.4.20.ebuild (renamed from net-proxy/haproxy/haproxy-1.4.18.ebuild)9
4 files changed, 12 insertions, 124 deletions
diff --git a/net-proxy/haproxy/ChangeLog b/net-proxy/haproxy/ChangeLog
index cc76a244adff..76bfa11b39c3 100644
--- a/net-proxy/haproxy/ChangeLog
+++ b/net-proxy/haproxy/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-proxy/haproxy
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/ChangeLog,v 1.61 2012/02/28 22:41:06 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/ChangeLog,v 1.62 2012/05/09 19:19:57 idl0r Exp $
+
+*haproxy-1.4.20 (09 May 2012)
+
+ 09 May 2012; Christian Ruppert <idl0r@gentoo.org> -haproxy-1.4.15.ebuild,
+ -haproxy-1.4.18.ebuild, +haproxy-1.4.20.ebuild, -files/haproxy.initd:
+ Version bump + cleanup
28 Feb 2012; Brent Baude <ranger@gentoo.org> haproxy-1.4.18-r1.ebuild:
Marking haproxy-1.4.18-r1 ppc for bug 375111
diff --git a/net-proxy/haproxy/files/haproxy.initd b/net-proxy/haproxy/files/haproxy.initd
deleted file mode 100644
index 412fcbd9362e..000000000000
--- a/net-proxy/haproxy/files/haproxy.initd
+++ /dev/null
@@ -1,44 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/files/haproxy.initd,v 1.4 2011/12/04 10:32:32 swegener Exp $
-
-extra_started_commands="reload"
-
-CONFFILE=/etc/${SVCNAME}.cfg
-PIDFILE=/var/run/${SVCNAME}.pid
-
-checkconfig() {
- if [ ! -f "${CONFFILE}" ]; then
- eerror "${CONFFILE} does not exist!"
- return 1
- fi
- /usr/bin/haproxy -c -f "${CONFFILE}" >/dev/null
-}
-
-depend() {
- need net
- use dns logger
-}
-
-start() {
- checkconfig || return 1
-
- ebegin "Starting ${SVCNAME}"
- start-stop-daemon --start --quiet \
- --exec /usr/bin/haproxy \
- -- -D -p "${PIDFILE}" -f "${CONFFILE}"
- eend ${?}
-}
-
-stop() {
- ebegin "Stopping ${SVCNAME}"
- start-stop-daemon --stop --quiet --pidfile "${PIDFILE}"
- eend ${?}
-}
-
-reload() {
- ebegin "Reloading ${SVCNAME}"
- /usr/bin/haproxy -D -p "${PIDFILE}" -f "${CONFFILE}" -sf $(cat "${PIDFILE}")
- eend ${?}
-}
diff --git a/net-proxy/haproxy/haproxy-1.4.15.ebuild b/net-proxy/haproxy/haproxy-1.4.15.ebuild
deleted file mode 100644
index f861c9b1da6d..000000000000
--- a/net-proxy/haproxy/haproxy-1.4.15.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/haproxy-1.4.15.ebuild,v 1.5 2011/09/21 13:44:51 idl0r Exp $
-
-EAPI="3"
-
-inherit eutils versionator toolchain-funcs flag-o-matic
-
-DESCRIPTION="A TCP/HTTP reverse proxy for high availability environments"
-HOMEPAGE="http://haproxy.1wt.eu"
-SRC_URI="http://haproxy.1wt.eu/download/$(get_version_component_range 1-2)/src/${P}.tar.gz"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 ~ppc x86"
-IUSE="examples pcre vim-syntax"
-
-DEPEND="pcre? ( dev-libs/libpcre )"
-RDEPEND="${DEPEND}"
-
-pkg_setup() {
- enewgroup haproxy
- enewuser haproxy -1 -1 -1 haproxy
-}
-
-src_compile() {
- local args="TARGET=linux26"
-
- use pcre && args="${args} USE_PCRE=1"
-
- use kernel_linux && args="${args} USE_LINUX_SPLICE=1"
- use kernel_linux && args="${args} USE_LINUX_TPROXY=1"
-
- # For now, until the strict-aliasing breakage will be fixed
- append-cflags -fno-strict-aliasing
-
- emake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" CC=$(tc-getCC) ${args} || die
-}
-
-src_install() {
- dobin haproxy || die
- newinitd "${FILESDIR}/haproxy.initd" haproxy || die
-
- # Don't install useless files
- rm examples/build.cfg doc/*gpl.txt
-
- dodoc CHANGELOG ROADMAP TODO doc/{configuration,haproxy-en}.txt
- doman doc/haproxy.1
-
- if use examples;
- then
- docinto examples
- dodoc examples/*.cfg || die
- fi
-
- if use vim-syntax;
- then
- insinto /usr/share/vim/vimfiles/syntax
- doins examples/haproxy.vim || die
- fi
-}
-
-pkg_postinst() {
- if [[ ! -f "${ROOT}/etc/haproxy.cfg" ]] ; then
- ewarn "You need to create /etc/haproxy.cfg before you start the haproxy service."
- ewarn "It's best practice to not run haproxy as root, user and group haproxy was therefore created."
- ewarn "Make use of them with the \"user\" and \"group\" directives."
-
- if [[ -d "${ROOT}/usr/share/doc/${PF}" ]]; then
- einfo "Please consult the installed documentation for learning the configuration file's syntax."
- einfo "The documentation and sample configuration files are installed here:"
- einfo " ${ROOT}usr/share/doc/${PF}"
- fi
- fi
-}
diff --git a/net-proxy/haproxy/haproxy-1.4.18.ebuild b/net-proxy/haproxy/haproxy-1.4.20.ebuild
index ab1388d5694c..a4b28d9dee81 100644
--- a/net-proxy/haproxy/haproxy-1.4.18.ebuild
+++ b/net-proxy/haproxy/haproxy-1.4.20.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/haproxy-1.4.18.ebuild,v 1.2 2011/09/21 13:44:51 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/haproxy-1.4.20.ebuild,v 1.1 2012/05/09 19:19:57 idl0r Exp $
-EAPI="3"
+EAPI="4"
inherit eutils versionator toolchain-funcs flag-o-matic
@@ -39,7 +39,8 @@ src_compile() {
src_install() {
dobin haproxy || die
- newinitd "${FILESDIR}/haproxy.initd" haproxy || die
+
+ newinitd "${FILESDIR}/haproxy.initd-r1" haproxy || die
# Don't install useless files
rm examples/build.cfg doc/*gpl.txt